Crash after Autotune, Pixhawk

Hi,

I flew a copter with 3.4.6 for some time and it flew ok. I made flights in different modes ( stabilize, Loiter, Auto and RTL) without huge problems. See Log:
Log good flight

Only after I tried to do Autotune i had a crash where I destroyed one propeller.
The copter suddenly started rolling left and right until it crashed. After analyzing the log with my basic skills I saw that the Vibrations were ok (definitely not the best), but the Gyro suddenly stopped working. Nothing else popped out to me.
Please see Logs:

Log crash 3.4.6

After that i decided its time to update to 3.5.3. Also I did remount the Pixhawk, as it turns out with not so good vibration dampening.

During my last flights i had quite a few errors before I even could arm my copter. Rebooting my Pixhawk helped and after a few successful tries i felt confident enough to arm my copter and fly. The log with the errors is here:
Log with errors
Please ignore the hard landing at the end due to the stupid pilot not landing with an empty battery…

During the next flight I tried again to to Autotune. Then after a short time the copter started rolling agin left and right until it crashed. This time the landing gear suffered.
Again the Log revealed that the gyro stopped and that I have bad Vibration.
Log crash 3.5.3

I would be really happy that someone could look at my logs and point me to the errors my Pixhawk or my setup that I did has or if everything is happening because I have bad vibration.

Thank you all very much.

In a word … Vibration


You will need to sort that out first before the poor Pixhawk has any idea of what is going on.
Have you ever driven a car down a badly corrugated road?

This is the IMU trace, and I know the Dev’s would prefer we looked at the Vibes, but the IMU tells the story very dramatically.
I am sure if you fix them vibes the autotune would have a chance of succeeding.

Thank you for your Input.

This is definitely something i needed to fix. I made myself a mount with earplug as described in the Vibration dampening article. I will see if it will be better.

However, I cant even arm my copter now.
I get “Accels not healty”, “gyros still settling” warnings all the time. Only after 3-5 tries it is possible to arm.
I calibrated the sensors many time and still don’t get rid of this problem.

Any Ideas?

Thanks

This is going to sound like a silly reply but in the chance it might help here goes…

I’m assuming its a OEM Pixhawk and not a clone, no matter.

1 Remove it from the copter and open the case. Insure nothing is loose inside the case.and all screws are secure.
2 Load Plane or another firmware on it then after a restart load the latest release of copter.
3, VIA USB and mission planner take the standalone Pixhawk with no peripherals attached and go through the calibration process.
4 Restart and connect via USB to MP and let it sit still, if errors still persist its hardware if not next step
5 Check the drones power supply for correct clean voltage (BEC, Pixhawk power brick, etc)

If all is good so far lets stick it back on the drone

Double sided sticky tape should be banned for mounting a flight controller. Frankly the small pieces of 3M foam at each corner work well or the ear plugs in a pinch. Generally the vibes in X an Y behave with the foam in four corners or earplugs BUT Z vibes usually still suffer. Here’s the trick…

You Need MASS

If you can live with weight it works wonders. These are 1/4 oz sticky weights.

Let us know how it goes!

1 Like

Thanks for this detailed suggestions.

First of all I am using a real Pixhawk.
The new mount with the earplugs certainly helped. Im sure i can tweak it a bit more with weights etc.

I carried out all your steps:

Did that and found no broken parts or broken pins as far I can see.

Did that and all was good. Tried multiple times at home without problems. Then I went outside and hooked up the battery and I was greeted by a “Accels not healthy” warning.
I then calibrated on the spot, tried a few times and decided to fly.
Surprisingly the flight itself was good. No problems.
After the flight with the first battery, while connecting the second battery, again the same problem: “Accels not healthy”.
I decided to end this flight.

At home I tried again a clean install of copter. At the beginning after a new installation I always get the warning about the accelerometers multiple times. After a few tries it works.
With all those tries the pixhawk is only connected to the PC via USB and to the spectrum receiver.

I start to think that I cannot get rid of this error with my Pixhawk. Maybe you have another Idea or atleast a confirmation that it is bad hardware…

Thank you for the help

P.S: Here the log from my flight
[Log]
(https://www.dropbox.com/s/hozazwt7vp8clvf/log_11_2017-10-14-17-38-04.bin?dl=0)