Couldn't arm motors in Guided mode

I am trying to arm copter without pre-arm checks and 3D fix.
I disabled all pre -arm checks which led to arm copter in STABILIZE mode.
But i couldn’t arm in GUIDED mode, i am new to these, would some one please help me to resolve.


Actually its showing pre-arm:EKF2 still initializing
i tried tuning

Any of your View or suggestion is highly appreciated.

Hoping for positive response.

Why do you want to arm in GUIDED mode? AC can fly only to specified GPS coordinate in this mode, so you’ll can do nothing after arming.

Thanks for your response @speakerx
Actually I would like to control pitch, roll and yaw
To operate drone without GPS accessibility.
Hope I am making sense.
Would you share me any views on how to approach this :neutral_face:

I believe GUIDED requires GPS, so this mission wouldn’t work?

hi @jax200
Thanks for your response. I tried to takeoff in STABILIZE mode, i couldn’t see any response from motors.
after i tried to switch GUIDED and arm, when i am arming it again gave EKF2 still initialising error,
Would you share any other thoughts

First get everything working in a standard configuration with RC control and GPS and well tuned.
Once it flies well and is reliable, disable the GPS and try GUIDED_NOGPS

If you jump straight to flying guided or without GPS you will never be able to tell where issues and faults are coming from.

1 Like

I edited my previous response.

Follow Shawn’s advice. Also ensure failsafe is set, and consider using a weighted tether and lower altitude when first using dk.

Also noticed from another posting if these parameters might be a factor.

1 Like