Could anyone can review my flight log for safe autotune?


-using FC : Pixhawk cube orange

-Copter type and size : quad, reptile 550, 6S lipo 2600mah * 2

-Special note on this copter :
I installed tarot martin 4008 and 14 inch props which is too much overspec for this size of copter.
I overlapped props for acheiving this.
because I want to lift heavy things with small size on purpose.

-flight log file link :

-Question(1) :
I guess basic setup is already finished and one thing left is autotune.
so before I perform autotune, I want to know whether if it is safe to autotune this copter and use this to serve the mission.
I tried to decrease the vibration and magnetic interference of this copter.
because it is overspec, there was too much vibration. now vibration is okay but I found there is much magnetic interference.(although this copter flew well without no problem, but mission planner auto analysis says it has large magnetic interference, and sometimes the heading spins while landing until performing magnetic calibration)
it seems external compass is okay, only internal compass(which is same height with big motor) have problem. I can’t determine which compass has magnetic interference because I don’t have knowledge on mission planner logs. is it correct that only my internal compass have problem?

as I said above, copter seems to hover well and hold position well although mission planner log auto analysis says there are many magnetic interference.

I want to know whether if I have to change “autotune_aggr” parameter since it have too much power than the frame size.
for your reference, to decrease the vibration, I mounted my pixhawk on the damper.
and, documentation says large copter(more than 13 inch props) should set Rate Roll and Pitch filters parameter to 10hz. I’m confusing because my quad size is not large but my quad has big 14 inch props. should I change filters to 10hz?
and my motor is 330kv which is under 500kv. documentation says this can generate sync problem. will it okay? and since my motor is overspec I don’t know about MOT_SPIN_MIN. will it be also problem…?

-for reference:
in the mission planner “initial parameter” tab, I entered prop size and battery cells informations. the copter flew very well with that initial parameter. it wasn’t sloppy and showed sharp movement appropriately. after that I changed parameters as mission planner messages.(ATC_THR_MIX_MAN to 0.5… etc)

I posted this to refer to other people’s opinions before autotune and to know if there is a fatal risk that can be avoid before flying. I know it is risky thing to fly overspecced copter. the responsibility lies with me. I will take precautions before flight.

Update to latest stable firmware - there’s important fixes for the Cube Orange, plus other good stuff.

The Initial Parameters was the correct thing to do. It will set all the filters you need, except you can also set this:
You can go to the Compass section and disable the internal compass there, it’s easiest and obvious.
Dont change the Autotune aggressiveness.

I would set these:
INS_HNTCH_FM_RAT,0.7 ← appears with firmware upgrade

which will prevent you from arming until there is a good GPS 3D Fix and Home can be set.
It seems to take a long time at first but you get used to it, and it takes a lot longer to walk and retrieve you copter from somewhere over the horizon.

Do the next test flight in AltHold and Loiter - upload that log

If those props are going close to overflying the center of the copter that will be a major source of your vibrations. You might need to put a cover of the flight controller, or the whole center plate, to shield it from prop wash.

Thanks. I will update the firmware and change the parameter today and fly it tomorrow.

after that I will upload the log.

for your reference, I already disabled internal compass. this log was recorded after disabling internal compass.

but mission planner log auto analysis still says there are large interference.

In the next test flight do plenty of yaw and circles or even figure 8 if you can manage it.
Magfit will sort out the compass settings after the next log.

this is my flight log after modifying the parameter except battery failsafe parameter.(I will modify the failsafe function until next flight.)

the flight quality was very satisfying. I felt like autotune was already done.
I did yaw, circle, figure 8 flight as you said.

and you are right. because props close to overflying the center of copter, FC is being affected by prop wash. but now I don’t have ways to prevent that. because prop and FC is too close, it is hard to make cover for them. regarding good flight quality, maybe there are no problem.

Put these in EXACTLY

You can copy/paste this into notepad, save as “new_compass_values.param”
then load it via MissionPlanner / Config / Full Parameter Tree / Load from file (top right corner)

It’s advisable to have BATT_FS_LOW_ACT set differently to BATT_FS_CRT_ACT
There was a bug that should be fixed now, but still… There’s no reason not to set BATT_FS_LOW_ACT to 2 or 3.

Also set
because some parameters can need adjusting after test flights. Or we miss setting something from earlier :slight_smile:

Now seriously, I would change those props to something smaller. The vibrations and prop wash are going to cause you endless trouble. And going down a size or two wont make much difference to flight time unless you stack on too much weight.
Smaller props spinning a bit faster give better attitude control and resistance to disturbances too.
I’m not sure what sort of prop mounting system is on those motors, but if you can get a set of these Master Airscrew 12inch MR series, you wont regret it. Also buy their prop adapter rings at the same time.
They also do 13inch, but I suspect you’ll be back into an undesirable situation.
I’ve used these and they gave long flight time and heavy payload capacity (for their size), quite exceptional actually.

Also, while you are thinking about redesigning…
What ESCs do you have?
Seriously consider BLHELI32 ESCs of some sort, even a 4in1 type.
You can use bi-directional DSHOT and get the RPM data to drive the Harmonic Notch Filter. And with the Cube Orange it’s easy to also get the temperature and voltage data from the ESCs too.

Thank you for the recommendation on the parameters given. I will modify for the parameters and fly my copter.

and thank you for your advice.
I will consider your recommended motor and setup at next build of my small copter.
but, at this time I will move onto big copter rather than changing this copter setup.
because I have to lift 1.2-1.7kg, it would be good to move on big copter.

I don’t think this copter is waste of money Because I had a good experience and learning with this overlapping props and motors.

and I will try this copter to lift heavy thing because this copter is not for general purpose, it is just for demonstration video. it doesnt require long-time endurance and trust for long-time frequent flight.

All I have to do is simply shoot a video of lifting a 1.2kg object, so it does not require much ability and precision. This kind of flight performance is fine. last flight was very satisfying.

If there is a problem while I fly this copter, such as flyaway, I will my crash copter via stabilization mode at any time. so don’t worry.

I tried 11,12 inch props before and it was good. but flight time decreased small and THRUST_TO_HOVER was not good.

Thanks to the parameters you recommended, the flight performance appears to be excellent. My copter hovers stably in one point well and the movements during yaw, circle, and figure-8 flights are very smooth.

I’ve attached my log file and parameter file for your reference:

However, I did not follow your advice regarding the following parameters:
COMPASS_MOT2_X, 10.000
COMPASS_MOT2_Y, -7.656

This is because I was experiencing issues with my power module. I believe that the COMPASS_MOT values are related to the power module parameters and that if the current changes, the COMPASS_MOT values should be changed accordingly. I have two parallel-connected 6S batteries, each with two power modules.

I already adjusted the power module parameters using the formula:

However, the result was not what I had hoped for, as shown in this image:

this problem haven’t solved from long before.
We previously discussed this issue in the Cube Pilot forum.

The red graph in the image shows the current value of the “battery0” power module and it fluctuates excessively. It should be more stable, like the green graph.

To resolve this issue, I adjusted the following parameters:
BATT_MONITOR, 10 (Sum of Selected Monitors)
BATT_SUM_MASK, 3 (bitmask, current will be summed and voltages averaged).

However, the result did not represent the total of both batteries. It only showed the values for battery 2.

Therefore, to get the total current, I cannot rely on the log or MAVLink values. I need to double the current value from the log.

In any case, I think I need to obtain new COMPASS_MOT values since they are related to the power module values, and I changed parameters to rely on only the second power module.

For your reference, it doesn’t seem like the vibrations of the copter are a too heavy based on my naked eye visual inspection. I have a receiver antenna, wifi telemetry antenna, and other dangling items on my copter, and during flight, they remain very still and don’t shake.
and the vibration values in the real-time analysis graph from the mission planner log appear to be below the standard.

What is your opinion on the vibrations? Is the low value on the log just achieved by using the harmonic notch filter?

As you previously mentioned, prop wash can affect the flight controller(FC), but in the case of my copter, which is a quad-V configuration, only one or two propellers are near the center, they only cover the wire connector part on the back side of the Pixhawk cube orange FC. I would like to hear your expert opinion on this situation.

and whole responsibility is on me. I will always take precautions and if anything goes wrong, I will use various methods to crash my copter safely.