Servers by jDrones

Copter Tailsitters

Interesting, no deflection at 50% throttle, downward deflection when speed increase as the autopilot compensate for a tendency to climb and upward deflection when speed decrease. I think it looks like to the behavior of a stable plane, I mean a plane with a right CG position.

@losawing I moved the CG back 2cm with the JWL-065 airfoil:

and it’s still controllable in manual mode, inverted flight still requires some down elevator and it still pitches up as speed increases in level flight.

I also tried the MH-106 13% airfoil with -1 degree incidence on both wings, and that shows less tendency to pitch up but is still stable. I pushed the CG back another 2cm with that wing, and it is still stable with a lot more down elevator authority than the JWL airfoil.


I’m not sure whether those CG adjustments (Z is tailsitter body-frame X) are directly comparable, since the change in airfoil probably moves the calculated CG.

I forget whether you use RealFlight yourself?

No, I do not have RealFlight. I have had always more fun making things, testing and sometime craching…
The first time I made a transition to FBWA, the CG was about 2 cm backward, and the biwing unstable. I think, it had resulted in a crash without the pixhauk help. I will test more…
When I made the design of the biwing, I made it in a very conservative way so I choose the JWL065 for the Cm stability. This is a link to a similar airfoil PW51. You can see that the Cm is almost 0 whatever the reynold number and incidence. This is what we want for a tailless airplane as we dont want the pitch moment to change with speed.
http://airfoiltools.com/airfoil/details?airfoil=pw51-pw
But I think now the biwing is not tailless. It has a very large stabiliser instead, the rear wing. Ecalc allow also to calculate the stabiliser volume and the biwing configuration gives a stabiliser volume of 0.5 which is a normal value and, I think, allow for a more cambered front wing airfoil with higher lift coefficient. As a consequence this airfoil would have a higher Cm with higher variation but the rear wing is there to compensate like a stabiliser would do.
Wings incidence relatively to fuselage does nor really matter but incidence between front and rear matter. I am not able to calculate what should be the angle betwwen wings but obviously it depends on CG position, respective wing surface and airfoils and probably speed target. But at least you showed with RF8 that the relative incidence with the actual CG is good at 20m/s. Nice result…

I’m seeing a strong pitch-up moment at high airspeeds with the JWL-065 airfoil, and am not able to do an outside loop in RF8, even with increased values for GSCMIN. Setting the upper wing incidence to +2.5 degrees relative to the lower wing improves that situation, and there is then very little pitch response to throttle.

With the MH-106 airfoil and top wing relative incidence at +1.0 degrees the pitch response is much faster in manual and qacro and throttle to pitch coupling is not noticeable.
http://airfoiltools.com/airfoil/details?airfoil=mh106-il

I wonder if these results with RealFlight are accurate enough to be useful.

I have not tested the outside loop but I will try tomorrow with enough altitude… I guess your test was in q_acro mode. I am surprised the outside loop fail, because the differential thrust between top and bottom motors is strong. Your test with increased top wing incidence may suggest there is strong interaction between wing in that specific attitude. Did you try to disable bottom wing elevon ?

Disabling the elevons on the bottom wing didn’t seem to make much difference, but I haven’t looked at the log yet. And I still haven’t figured out why flaperons don’t work. When I assign flaperons, the surfaces don’t even move in the right directions.

Try to follow your motivation. Already installed Win 10.
Do you need to do a command or to enable something in RF8 after starting like discribed in the Wiki for RF9 to connect like this:
On RealFlight 9 go to Settings->Physics and enable the FlightAxis option then restart RealFlight.

And as in RF8, in the manual of RF9 is nothing (FligthAxis) to enable at this place (Settings>Phyics)

Edit:
Thanks for your link for Ubuntu at MS I got it ready to start and with exit to get off again.

Real Flight VS RF8 won by 5-0 :slightly_smiling_face: As the plane was happy, he made just for you a new figure, a kind of edge loop from hover to hover. The video quality is not great.

Maybe the simulated drag is too low? I’ll see if I can increase it.
Perhaps also comparing a simulation log to the real log would tell us something.
I’ll put a simulated log up in the SITL_models repo.

If you’re using the flightaxis beta of RF8, you don’t have to do anything to enable SITL, just start RF8 normally, then start SITL in Ubuntu.

To run SITL in Ubuntu on Win10, you first start a command line window by clicking on your installed Ubuntu App in the Windows Start menu. On my machine it is “Ubuntu 18.04 LTS”:

image

That will open a command line window similar to the Windows “Command Prompt” window. The command interpreter running in this window is called a “bash shell”, and it is where you will run ArduPilot SITL.

Assuming you have just installed Ubuntu, you first need to set up your Linux build environment for ArduPIlot. In the Ubuntu shell, follow the instructions here: https://ardupilot.org/dev/docs/building-setup-linux.html#building-setup-linux
Once you have your build environment set up you are ready to run SITL:
https://ardupilot.org/dev/docs/setting-up-sitl-on-linux.html

Since my Windows IP address is 192.168.0.100, this is the command I use (in the Ubuntu bash shell window) to start SITL with RealFlight:

../../Tools/autotest/sim_vehicle.py -j4 -f flightaxis:192.168.0.100

That command is run from a directory I create for each RF8 model I’m using with SITL. For the BiWing, it is:
~/linux_git/kd0aij/ardupilot/ArduPlane/BiWing

Note that “~” represents your home directory (mine is /home/markw)
and I cloned the ArduPilot repo to /home/markw/linux_git/kd0aij/ardupilot

When you start SITL with RF8 already up and running, you should see the message "“FlightAxis Controller Device has been activated” at the bottom left of the RF display:

You have forseen, what happens next. Entering the command to link with RF8 I got a serie of error messages. And I wanted to ask for a advice. But you where faster and posted a whole “tutorial”. Thanks a lot.
In the link I should made some commands:
Linux/Ubuntu users can install with apt :

    sudo apt-get update
    sudo apt-get install git
    sudo apt-get install gitk git-gui

The first was ok, a list of updates where to see.
The second seems no longer to be nescessary
The third produced 2 errrors.

you forgot the “sudo” on the third command
But gitk and git-gui are repository management tools for developers that you won’t need for running SITL.
Just proceed on to cloning the ardupilot repository:

git clone https://github.com/ArduPilot/ardupilot
cd ardupilot
git submodule update --init --recursive

That will create an “ardupilot” directory where you run the command.
Running it from your home directory is fine, and in that case your ardupilot repo will be at /home/“your username”/ardupilot

Then continue with the instructions at https://ardupilot.org/dev/docs/building-setup-linux.html#install-some-required-packages

After installing those required packages you should be ready to run SITL the way I suggested here:

After downloading and extracting of about 450 tools, I tried to start flightaxis.


Something missing?

I forgot to explain how to create a SITL model directory in Linux, and my instructions weren’t displaying correctly. I edited the earlier post, but it should have looked like this (2 dots, not three, and in a subdirectory as explained below)

That command should be run from a subdirectory of your ardupilot directory.
In your ardupilot directory, type

cd ArduPlane
mkdir BiWing
cd BiWing
../../Tools/autotest/sim_vehicle.py -j4 -f flightaxis:192.168.1.5

and it should work.
Sorry about the complexity of this process, but once everything is set up properly, it’s fairly simple to run SITL.

I’m happy about your support, not easy for you on distance.
I think I’m able to develope now a Software similar to Facebook or Google with this toolshop…:wink:

The name of the directory “BiWing” should this corresponde with the name of the Airplane?

The name of the directory can be anything that’s convenient for you.

When you are simulating multiple models, using separate directories is an easy way to organize things. The current parameters are saved there in a file named “eeprom.bin”, and logs are written to a “logs” subdirectory. The first time you run SITL with a particular model, you will have to load all of the parameters from a file, and you don’t want to have to do that every time.

When you start SITL, it will load parameters from eeprom.bin (if it exists) so that any changes you made on the last run are retained, just as you would expect with a real model. And you know that all the dataflash logs in the logs subdirectory are from that model also.

Thats just what I wanted to ask today. I suppose, the command to start the connection is always the same. So I wondered, why to use a directory. It’s clear now.
After 632 compilings, stop and no connection to the waiting BiWing on RF8


And Ubuntu does not accept commands ls, cd and exit

Edit:
Detected a Warning: no config… at the beginning second line.
I use a LAN between the 2 PC with no issues.
The IPv4 adresse of the PC where RF8 runs is: 192.168.1.5
Does it needs acces release to the Program directory of RF8?

That’s looking pretty good; it built ardupilot successfully and appears to be running both ArduPlane and mavproxy.

Did RealFlight display the message “FlightAxis Controller Device has been activated”?

The reason ls and cd don’t work is that’s the mavproxy console, a command line GCS for issuing commands like “param load …” and “mode qhover”. Type “help” to see what commands are available there. Documentation is here: http://ardupilot.github.io/MAVProxy/html/index.html

I’m comparing your console output to mine to see if there are any significant differences.

Nothing to see in RF8, the BiWing jumps up 20m and then crashes after loading the airplane or pressing the red button on InterLink.

And yes, QStabilize as command get a answer: Got MAVLink msg: COMMAND_ACK …
Here the reaction of help:


thanks again

Just to be certain: you are running RF8 and WSL on a single Windows 10 computer?

Before you start SITL, does “ping 192.168.1.5” show that you can send and receive data (in the Ubuntu bash shell)?

Servers by jDrones