Copter shaking on ground but okay in airbone


I have the Hex, size of 1800m, 32inch folded propeller
When arming on the ground the arms shake like crazy, please have a look on this video (and ignore the rolling shutter effect)

However, when taking off, there is no more oscillation. This is the first flight with ready to tune parameters. I think this problem comes from mechanical structure. Can we ignore this shakes and just take off and go directly to tuning process?


1 Like

Hi could you please give more details of your drone such as motors esc and also the bin file? For some escs such as tmotor alpha you’ll need to set mot_thst_expo lower than default value. That’s why it’s important to know what esc and motors you’re using. Also the video isn’t available publicly

1 Like

Ground resonance, make your landing gear stiffer/different.

I guess anyway, your video is private…

Thanks for reply @JackJavan and @iampete
I have made the video accessible, sorry for that.

Motor: P80 III
ESC: Alpha 120A HV
MOT_THST_EXPO = 0.66 - I did experiments on the thrust curve to figure out MOT_ parameters. Happy to share the test report on Hobbywing X8 and X9 too.

This is the bin file. No tunes have been done yet because of being stuck at this step. I just went stabilize and alt_hold to make sure that the shaking is gone in on airborne, so please don’t dive in the PID.

saw your video. you gotta give them some thrust. if you have alpha esc programm box make sure to update the firmware on that buggy esc. mine shakes too if I give it that low of pwm but I set the mot min spin higher to avoid this. (p80 III on alpha esc 80A)

Thanks. That thrust came from MOT_SPIN_ARM. Anyways, I also think by apply more RPM at the arming state will solve. However, the drone should be in resonance state as @iampete mentioned, I really want to solve the root problem. I will try and keep you posted.

I also have the ESC firmware upgraded.

1 Like

I just had a similar thing with a quad where we upgraded the battery, props and ESCs.
I thought at first it might be a BLHELI thing with the new ESCs, but it doesnt seem to be now.
A quick test proved it’s now ready for flight and more tuning by lowering the rate PIDs, accels, Angle P terms and also the Filter values. Basically a complete rework!

You can see in your log how the servo out values are all over the place, motor RPMs will be bouncing up and down like crazy and causing the shaking.

Based on your log, I would set these and test again:
Then do another test flight and provide the .bin log.
You could even drop the Rate PIDs by a further 10% or 20% if you need to.

I would avoid doing any tuning of PIDs dynamically/inflight from the radio or ground station until you’ve got this fairly well tuned. It’ll be a braver person than me that tries that. I prefer to see the test flight in logs and think about it before changing anything.

1 Like

Actually a big part of the shaking problem I had was the BLHELI Rampup Power setting - I changed it from 50% down to 24% and everything seems fine. On 30% there was still shaking sometimes, but not as bad or consistent as with 50% rampup power.

@xfacta I am using the Tmotor Alpha ESC and they did not run BLHELI. In the ESC configurating GUI, there is also no way we can change the ramp -up parameter, I just can temporarily solve by increasing the MOT_SPIN_ARM/MIN and even MOT_THST.

Is this scarifying trivial?

@xfacta Sir, Thank you for this
I am making Hex copter, I am done a hex copter test (prototype) on F550 Frame. I am just transferring all electronics and flight controllers to Big Hex copter. The big copter size is 1900 mm, T motor P803 100KV, 32-inch propellers, and 12S voltage. Today I did a ground test, I will include a log.

  1. What are parameters do I change after change to a bigger hex copter.
  2. How to avoid crashes. ( actually, I am having fear inside)

Thanks and regards

A good place to start is to read the ArduCopter tuning process instructions

1 Like

OK, @amilcarlucas Sir, But this is a big hex copter right, that is why am asking for any parameters like filters for that setup. a little bit of fear. :grinning:

Thanks and regards

The information I posted is valid for big and small frames.
And if do not follow it you might crash. Do not skip any step.

1 Like

The 1st thing you should do is get battery voltage and current monitoring working.

Listen to @dkemxr . He knows about this stuff.

@amilcarlucas Sir,

Yes, sir, I will make parameters list for big hex copter using this

Can I assume you had no props on during the ground test you posted the log for? If you had voltage/current in the log I wouldn’t have to ask…

Pressing “Ctrl-A” in Mission Planner will automatically do that for you. But you still need to read and understand the ArduCopter tuning process instructions page

1 Like

@amilcarlucas Sir can I use these parameters because am also using the same population system.

@amilcarlucasok sir, i have done this,

Thanks and regards