Copter only unstable on pitch Omnibus F4 Pro

Hi all

I built a quad, but i cant seem to get the pitch to be stable, its enough for me to hear the change in motor speed.

The frame is a T4
Motors: Racerstar BR2216 1400kV
Props: 9443 carbon self locking
FC: Omnibus f4 V2 pro
ESC: Racerstar 35A anniversary edition 4 in1
Im running Dshot150

I’ve added some notch filtering, slowed the PID loop on the pitch only but i have to slow it down so much that its way too slow. Its like there is noise but only affecting the pitch.
CG and thrust center is on the same spot, lifted the motors 10mm to get away from turbulence.
Rubber mounts on the FC.
I did multiple calibrations of the accels and gyros and the ESC.

There must be something i’m missing… any help will be much appreciated.
Log with the bitmask at 196607

Hello! I think you have two problems, vibes and compass. The accelerometer is clipping a lot and should be ideally 0 (clipping happens when the accelerometer reaches its maximum). You should try to isolate the FC from vibes, check that the props are balanced…

Here you can see as clipping goes to more than 800

And you have a large change in the mag field of 194.97%, and should be under 30%. It is related with the throttle. Here you can see it:

I hope that information can help you!

Thank you for the reply, i have to apologize though, when i saw the clipping in your screen shots i realized that i uploaded the wrong bin file. The correct one is 2020-08-07 12-11-14, Uploaded now.

While the vibe is higher than i would like but still generally below 12 there is no clipping.

I put the BN880 on a mast and did another flight,after mag calibration. Log file also uploaded, the one with “_mast” still no change to the behavior. Im starting to think that its the FC.

@davidae you set me down an interesting path with the vibration. :slight_smile:

I started at first principles but found a fairly interesting phenomenon.
So since my first post i printed a vibration damper with the balls instead of using the rubber stand offs.
And also dropped down to 4.0.2
But when i ran the copter without the props, it started “walking” along the floor with 4.0.2 and 4.0.3

Here are my findings, in order to compare apples to apples i’m only testing one motor but the same happens with all of them.
Connected to the omnibus, the motor sounds very rough a lot like but a bit more violent.

This is when the motor is connected to the FC (take note of the scale) The bit in the middle where the vibe drops down is actually the motor at full throttle.

This is connected directly to the receiver

So clearly the FC is inducing the vibration, motor is warmer and draws more current.
@rmackay9 does this look like sync issue? Funny enough i didn’t notice it when i first set the quad up.
The logs are in the same google drive folder