Copter 4.4.3 - Unusual CW yaw in forward flight only


Frame : Protek60 cinelifter
FC: cube orange+
Motors : Xing 3110 1600kv
ESC: Blitz E80pro
Radio : herelink

I have been facing an usual yaw issue with my copter, where it would yaw CCW 90° in forward flight when the copter gains a little speed. When the copter is making this yaw turn it doesn’t accept any RC input until the turn has been completed. The drone has been autotuned multiple times and the rates are not too far off from the autotune values.
The yaw issue happens in all flight modes stabilized, loitre and position hold and only when the drone is moving forward and starts gaining a little speed. The drone behaves perfectly normal in backward pitch, roll right and left at full speeds without any issue.
I am using in-flight FFT for these flights but the results are the same for throttle or ESC telemetry-based harmonic notch filter.

I have attached 3 log files : 1) stabilized forward flight 2) loitre forward flight 3) hover for 40s

I should also add there have been 2 3 instances where the issue didn’t happen in alt hold mode. I have been able to stop this from happening if I set lower acceleration and lower speeds in loitre mode.

There is a large difference in motor outputs even when the copter is not moving.
When the copter moves the differences are exaggerated (as we expect) but motor 3 is hitting minimum

See if you can better balance the copter, and check very closely for any twisted motor mounts (maybe not) or some difference between props or motors.

There is a good chance the yaw change you see is because of compass interference.

Change these parameters to fix up the filters:

INS_HNTCH_HMNCS,1 <- maybe 3, but not more, leave it at 1 till we see the next log

these to help with the attitude control a bit:

PSC_ACCZ_I,0.32 <- watch out for the typo

Now do a flight with plenty of circles, yaw change and even a figue 8 if you can.
Let’s see that log.
We can run that through magfit and sort out any compass issue.


Hi Shawn,

Thank you for your quick response.
The motors are not twisted but yes the copter is slightly back-heavy at the moment as we do not have all the payload onboard, this would be minimized when the payload is added to the front.

I have made the pram changes you asked for and did two flights, one with multiple circles, yaw, and figure 8 and the other in stabilized and loiter forward flight.

Logs: 28/11/2023 - Google Drive

My question is if this is a compass issue would it affect the flight in stabilized mode? I had tried to rule this out by disabling the compass altogether however the issue was still present in stabilized mode.

After the parameter changes here are a few observations:

  1. The yaw rotation is very minimal in the stabilized mode now, it goes straight but I can see little twitching and the motors also do not sound happy. The altitude control is very much improved in stabilized.
  2. The yaw rotation is still the same in loiter mode, also the altitude control in loiter is worse. The copter gains altitude in forward flight and loses altitude when pitched backward.
  3. My ATC_RAT_YAW_D=0.02 which is very high from the autotune value, I was experimenting with this to sort out the issue earlier and I have not changed this since. This value was taken from @andyp1per 7" arducopter build. Should I lower this and do another test flight?

Thank you

The parameters I gave before wouldnt have changed yaw much, but will just generally help.
I ran that log with circles and yaw through Magfit.

So you could set these:


There is almost no interference from motors which is unusual for smaller copters, and that’s good.

The GPS is bit of a problem though. The update rate is all over the place. Try setting these for different flights and see which gives you the shortest time to 3D Fix and the lowest HDOP.

I find the new Yaw D autotune does a good job and manual yaw tuning is not needed. If anything the result can be softened by lowering ATC_ACCEL_Y_MAX and rounding down the ATC_ANG_YAW_P and ATC_RAT_YAW_P / I values.

You have very low vibrations and almost no noise happening. There is a couple of rogue frequencies around 85Hz and 11Hz that seem unrelated to the motor noise. Probably just keep and eye logs sometimes.

1 Like

Hi Sahwn,
I have made adjustments to the parameters as per your suggestions above. I have not changed COMPASS_MOTCT to 2 because the current sensor setup is not done on our copter.

I have done another yaw autotune just to be sure and attached the flight logs. :

I understand you suggested some filter changes earlier and that would make the drone fly a little better. What I am trying to figure out here is what exactly I am doing wrong, is there an issue with the parameters/tune that is causing the copter to yaw without inputs, or may it be a hardware issue that I need to address, maybe replace the cube/ESC/motors and try with a new one?

here is how the copter looks, the cube is placed at the back and is not in the center, could that be causing an issue like this to happen?

Hi! This problem seems a lot like what sometimes happens to my 7 inch quad when I reach close to its maximum speed of 100kmh. I still did not find the solution to this problem because I did not have the time to make tests but I am thinking that it may be lack of authority in the yaw axis due to frame shape and aerodynamics. It is a problem known in betaflight as “yaw washout”. If you search it you will see that the solution they propose is to increase P and I terms. That is what I will try with mine.

However, if you try this, be carefull. I am not completely sure if it will solve the problem or cause a crash due to increase of authority in the yaw axis and as a consequence too low authority in roll and pitch.

Thank you for so much your response Andre,
So I took a look at the yaw washout issue you mentioned and the first recommendation everywhere was to reverse the prop direction, so I went from props out to props in and this seems to have fixed the issue. I don’t understand why the yaw was so problematic in props out orientation so I will further keep on testing this to figure out where the issue was.


1 Like

Yes I forgot they also suggested to change prop orientation :sweat_smile:

I am glad it worked for you!