Copter-4.2.3 released!

Copter-4.2.3 has been released as the official/stable version for multicopters and helicopters and can be installed from the various ground stations (MP, QGC, etc) or downloaded directly from

Changes vs 4.2.2 are in the ReleaseNotes and copied below

  1. OpenDroneId support (aka RemoteID)
  2. Firmware ID and CRC check (disabled by default)
  3. New autopilot support
    a) CubeOrange+
    b) Foxeer Reaper F745
    c) MFE PixSurveyA1
    d) Pixhawk6C and Pixhawk6X
  4. Bug Fixes and minor enhancements
    a) Battery monitor health check fixed to check all enabled monitors
    b) ICE Lutan EFI update serial flood fixed
    c) ICM42xxx IMU filter settings improved and allow for faster sample rates
    d) INA2xx batteries may init after startup
    e) KakuteH7 OSD parameter menu enabled
    f) Lua script support to set desired speed in Auto mode
    g) Payload Place mission command obeys specified altitude type (was always terrain alt)
    h) PreArm check that MOT_PWM_MIN/MAX are non-zero
    i) PreArm check of Rangefinder pin conflict and servo outputs
    j) SCurve logs debug if internal error occurs
    k) WSL2 upload fixed (developer issue only)
    l) BlueRobotics Navigator autopilot filesystem fix
    m) Auto takeoff with terrain altitude frame fix (could cause climb away if rangefinder became out of range)

Thanks as always to our beta testers!


I have to say I’m rather surprised to see this release as the problems on the Pixhawk 6X are still there:

(Pixhawk 6X, MP & QGC on Linux, 4X config, using 4.2.3 stable)

Firmware upload:
As mentioned in beta release the firmware upload proofs rather challenging.
This is MP:

Not much better in QGC - daily:

The only one that is working the regular way (without uploading the .apj file) is QGC-stable

Then there is the ongoing sensor issue. At least one IMU is still causing problems and as a consequence accelerator calibration can not be carried out in MP or QGC whilst this sensor is enabled.

1 Like

Has anyone tried successfully upgrading to 4.2.3? I am facing Failed to discover board id. Please reconnect via USB and try again.


1 Like

What board (FC)?
I can successfully upload firmware using QGC - stable version. (on Linux)

1 Like

My FC is Cube Orange, 4.2.2. doing it over Windows 10.

1 Like

Did you reboot your computer? at times when running Realflight I loose access and can’t connect sitl until rebooting the computer. Just thinking spit balling.

1 Like


Like @Karl_Schoelpple, I’ve just successfully installed Copter-4.2.3 on a CubeOrange using MP.


There are two slightly different versions of the Pixhawk6X board. You have the Holybro Pixhawk6X of course?

I know of the Pixhawk 6X and the 6C boards.
Are you saying there is another version of the 6X out there?
Whilst may 6X clearly states Holybro and came and sealed and what appears original box, I did not buy it through the Holybro website.
If there is another version out there, how would one know how to identify it?

So just like before (in beta):
If I activate only IMU 1&2 it will work fine and the accelerator calibration works at first attempt.
But I am not sure if the second is actually working as it only shows “Unknown” - I guess so nothing there & nothing else working, or do I see this wrong?



But the interesting thing was originally using 'Latest" I had all sensor showing in the .bin log file despite a “poor gyro health” showing and a question-mark showing in QGC - sensors.


There are apparently two different versions of the 6X. One from Holybro and one from another manufacturer. I don’t think this is really the issue though, I suspect we have an issue in our support of the board.

Sorry to give you the run-around but could you possibly set LOG_DISARMED = 1. Then reboot the autopilot and move it around a bit. Perhaps try to arm it, then download the log file and post it somewhere? This will give us more details on what is going wrong.

In the meantime, I have contacted Holybro and we are re-testing the upload and IMU on our side. @andyp1per also reported that he was seeing issues so sorry for not getting on top of this earlier.

Thanks for your prompt reply.
I have done a few successful flights but mostly tethered for safety reasons. - That’s how I found out about all 3 IMU’s showing despite the gyro health warning.

I guess for your testing process I should activate all IMU’s again ?

PS: Haven’t got a problem with this, in fact I’m glad we get this sorted before others get caught out.

So after doing a bit more testing I’ve discovered I can have a second IMU working and calibrated by having all IMU’s active, except the 3rd. This seems to be the one causing the problem despite the 4th. being listed in HWID as DevType “58”.
In that configuration I don’t get any messages anymore about poor gyro health. :grinning:

Looks like I need to force Windows to use other USB driver to work

You could try your luck using this driver.msi file:

…or as Windows is well known to be “funny” with USB ports simply do a re-start of Windows.

hmm, interesting … trying to ask windows to update the driver from the driver.msi installer.


We’ve done some work on fixing up the firmware loading (see PR here) and one AP dev and VP from Holybro have confirmed that they can now load the firmware successfully on the board.

… so could you try re-installing the latest beta Mission Planner and see if it can install 4.2.3 successfully?

Re the accelerometers, we also tested a Pixhawk6X and confirmed that (at least on our board) Copter-4.2.3 was able to communicate with the board’s IMUs successfully.

Could you try resetting INS_ENABLE_MASK = 128?

I’m not sure if it was intentional or not but on your board this parameter is set to 115 so two of the possible drivers have been disabled.

Thanks for that.
Yes, disabled other sensors in INS_ENABLED_MASK as those caused the problem with stopping me doing any calibration and showing the gyro unhealthy message.
There is also the issue with one showing “58” under Device Type, so not like on your HWID.
Will try and see what happens.

The plot thickens…
I’ve tried making the change to INS_ENABLED in MP (stable)but wouldn’t let me.
Then I’ve tried doing this in QGC and got following message:

Once the download for the updated MP finishes I will try it.

→ Update, unfortunately no joy.

When trying to change INS_ENABLED_MASK=128:

  • Please keep in mind I’m using Ubuntu 20.04