Copter 4.2.1 Motors suddenly stopping

While doing the motor test from the optional tab on the setup page the motors are suddenly stopping and going into a long beep sequence. While in the field when tried to arm the copter same thing esc making the arming sequence beep again and again.

Here is the video demonstrating it.

The motors are re-arming - can you post your settings? What ESCs and flight controller do you have?

Here are the params
para.param (16.5 KB)

Tried to downgrade to 4.2 but the same thing

Flight Controller Cube Orange
Firmware: 4.2.1 Bdshot
ESC: hobbywing xrotor micro 60a 4in1 esc ( now switching to holybro 4in1 to clarify was it thresc )

It would be worth trying SERVO_DSHOT_ESC=2 to see if that timing makes any difference. I suspect the holybro will work as I have tested loads of those on different boards. Might have to get an xrotor

You are using dshot - servo min and max should be 1000/2000 not 1100/1900


I have tested the motors with the holybro esc and they are not showing any issue now will go in the field and do a test flight today.

I am using AUX 9-12 for the esc and those set to 1000min - 2000max (if u are referencing this)

Not sure is there anything to do with this MOT_PWM_MIN/MAX, and the audio in the video, I can hear the warning of lower that expected arming voltage.

I haven’t tested the flight yet, and I got these messages.

I have to enter the RC3_min and Max values and get back the normal motor test percentage and behaviour.

6/10/2022 10:25:52 AM : PreArm: Check MOT_PWM_MIN/MAX
6/10/2022 10:25:27 AM : Frame: QUAD/V
6/10/2022 10:25:27 AM : IMU2: fast sampling enabled 9.0kHz/2.3kHz
6/10/2022 10:25:27 AM : IMU0: fast sampling enabled 8.0kHz/2.0kHz
6/10/2022 10:25:27 AM : RCOut: PWM:1-14
6/10/2022 10:25:27 AM : CubeOrange 00270027 30305114 35333339
6/10/2022 10:25:27 AM : ChibiOS: 93e6e03d
6/10/2022 10:25:27 AM : ArduCopter V4.2.1 (c8b6b674)
6/10/2022 10:25:27 AM : Frame: QUAD/V

From your parameters:


@Jai.GAY You check these params in the servo output tab and check for the max and min I have attached an image below.

After installing the new esc I have checked them and they are accurate now.

I also want to know whether I have faced a dysnc on the same motor out on a setup with two different esc and after 2-3min into the flight motors 2 and 3 suddenly stop working properly and this happens even are switching to different esc. Now I have switched to a different Fc and Motors will do the test flight.

Could this be a Firmware bug?

Mine is analogue motors, all show 1100, 1500, 1900, but my MOT_PWM_MIN/MAx is equal to RC3_MIN/MAX. just did a test flight, and the behaviour is the same as last time, both test flight and lab motor test. Without MOT_PWM_MIN/MAX, prearm-check fail and can’t arm.

if I set MOT_PWM_MIN/MAX to 1000 and 2000, the behaviour of the motor test is different from last time.

For CubeBlack, upgrade from 4.1.5, the MOT_PWM_MIN/MAX were automatically copied from RC3_MIN/MAX.

What issue you are facing with the copter?

Dose it also showing the same error before upgrading

No issue for HexaX (CubeBlack with GPS installed) for outdoor flying, got an indoor flying without GPS installed issue with QuadV (Cube Orange)

No, no such warning using 4.1.5.

My initial testing of the xrotor micro shows it works fine. Will now have to try with cube orange

I think perhaps you have a config error here. On the cubeorange to use dshot you have to connect to AUX1-6 and use SERVO_BLH_* to configure the output type. So for instance:


With this configuration it works fine for me