Copter 4.1 Beta 6 with EKF2 and Lightware SF45/b unstable flight behaviour

after I realised that the obstacle detection is only active from a height of 2 metres, unfortunately the same behaviour with the SF45/B as with Slamtec RPLidar A3…
Could it help to increase the lowpass filter?

Here is a video of our test:

And here the logfile:

1 Like

@webmotions in your log, it’s pretty much detecting an obstacle throughout the flight, at roughly 0.25 meters… is something obstructing the view of the sensor? I don’t see any obstacles in the video that are that close.

Also next time you fly, can you please enable RAW logging via PRX_LOG_RAW = 1

Also the height thing beyond which avoidance is activated is purely options… you are free to disable it via parameter. But it worked very well to avoid picking up ground obstacles while taking off and landing, when I was implementing that feature

Hello @rishabsingh3003,

the SF45/B has a scanning range of 320°, which is quite useful for our design. As you can see in the photo, we have a handle in the “blind spot”.
The parameters are also for this:
PRX_IGN_ANG1 = 180
are set. I have the impression that the SF45/B, like the Slamtec RPLidar A3, cannot cope with sunlight. On this day it was sunny. I will carry out a test with PRX_LOG_RAW today. I find the option to set a minimum height at which the obstacle detection is activated very useful, I just hadn’t thought of it.

@webmotions in my testing of the SF45/B (as well as Randy’s), even in sunny conditions, it was working well. (the twitch’s that can be seen in the video have been improved)

The best way to confirm if there are any obstructions is to keep it indoors, connect Mission Planner, open up the proximity viewer (Ctrl + F), and let it run and see if it is detecting obstacles. Maybe the ignore parameters aren’t set correctly

@rishabsingh3003 The values always fluctuate back and forth indoors as well. At the time of recording, nothing was moving in the workshop. I made the following changes to the parameters and flew a test:


it seems to work better this way, except for a few small jerks and wobbles

@webmotions I have considered in the past the default PRX_FILT value is too low. The filtering on the SF45-B is already heavy as far as I remember (from the hardware as well as driver), why don’t you try PRX_FILT = 0 and disable filtering all together, although from logs it looks okay to me.

Another thing to consider is reducing AVOID_ACCEL_MAX, that would smoothen out those jerks, and the expense of slower avoidance response

1 Like

Hi All,

This should be fixed in Copter 4.1.0-rc3

1 Like