Copter-4.1.3-rc1 released for beta testing

Copter-4.1.3-rc1 has been released for beta testing and can be downloaded using MP or QGC’s beta firmwares link or it can be downloaded directly from firmware.ardupilot.org.

Changes vs 4.1.2 are in the ReleaseNotes and copied below:

  1. Enhancements:
    a) CUAV-X7 servo voltage detection support
  2. Bug fixes
    a) Main loop delay fix for boards with 16 bit timers (affects KakuteF4, MatekH743, MatekF405, MatekF765, SpeedybeeF4)
    b) MOT_MIX_MAX constrained between 0.1 and 4.0 (would previously reset to 0.5 if set too high or low)
    c) Polygon Fence upload fix when replacing the fence with one that has fewer points
    d) TradHeli fix for missions which continue after a Land command

I know it’s hard to get too excited about these little beta releases but any feedback on testing whether positive or negative is greatly appreciated!

By the way, this release makes Copter consistent with Plane-4.1.5.

1 Like

Hi @rmackay9
The yaapu script (latest version 1.95) still doesn’t work. Furthermore, passing from 4.0.5 (working yaapu) to 4.1.3, a serial 4 appears that did not exist in 4.0.5, even if the BRD_ALT_CONFIG parameter is 0.
FC omnibus F4 V6.0.

Hi @Alberto_Ds,

OK, thanks for the report. So I guess this is perhaps not new to 4.1.3 but instead something that has been reported before in earlier 4.1.x releases? Are there any existing reports that you know of or maybe you’ve just started using 4.1.x and just noticed this?

FYI @yaapu

1 Like

Thanks @rmackay9

I just tried 4.0.7 stable and yaapu works perfectly, without changing anything other than the FW. Since 4.1 something has happened with the serial management, at least in the FC omnibus nano V6.0 F4 which needs an external inverter.
I don’t think the problem is with the script, but with the serials.

4.0.7 only 3 serials, yaapu works well.

4.1.3 rc1 4 serials port on the same FC??? Yaapu stop working

On 4.0.7 i have:

serial 1 Fport
serial 2 Optical flow
serial 3 GPS

On 4.1 I see serial 4 that I don’t use and that has the same settings as serial 1 (I didn’t manually set anything on serial 4)

Can you test this PR: backport of RCIN fix by tridge · Pull Request #19577 · ArduPilot/ardupilot · GitHub ? I think @tridge fixed this already.

1 Like

Thanks @amilcarlucas
no way :frowning:
unfortunately nothing seems to change. Exactly like 4.1.3 I find serial 4 copy of serial 1 and “no telemetry data” on the radiomaster.

I’ve added this to the 4.1 issues list but I don’t think it will be resolved before 4.1.3 goes out. Hopefully @yaapu can help us get to the bottom of it though.

1 Like

Thanks @rmackay9
in this case the script is important because it is a quad sub 250gr and there are no other telemetry. it is also interesting to check ekf3 on such small copters.

Possibly related, but it looks to me like the inversion config is wrong on this board. Have a look at Invert SBUS on RC serial connections on F4 by andyp1per · Pull Request #18361 · ArduPilot/ardupilot · GitHub for some that are working properly.

1 Like

on 4.0.7 I use an external inverter like this and it works fine. I don’t know if this is relevant.

Hello, on ac4.1.1 why guided mode no respect geofences? It just mark geofence breached on the gcs, but don’t stop.
If i go in loiter on auto modes on the same flight it respect it……

@kuspower,

Can you clarify the situation in which you saw this problem? Perhaps provide an onboard log if possible.

I just checked in SITL with 4.1.3-rc2 (which should be the same as 4.1.1). I created two polygon fences, one larger inclusion fence and then another smaller exclusion fence.

Then I tried “Fly-to-here” outside the larger inclusion fence and the command was rejected. Then I flew the vehicle through the exclusion fence and it correctly RTL’d home.

By the way, Guided and Auto modes don’t stop at the fence like Loiter mode. This was a conscious choice because we didn’t want vehicle to get stuck behind fences in Auto mode. This behaviour is not new to 4.1 though.

To cause the vehicle to avoid the fence then Dijkstra’s can be used. Even in Guided this should work although you will need to set GUID_OPTIONS = 64.

1 Like

Hello Randy, thank you so much for your feedback.

I experienced this issue with guided mode and AO activated to Dijkstra’s type but without setting guided option bitmask to 64.

Thank you !

I wish you happy end year celebrations.

1 Like