Servers by jDrones

Copter-4.1.0-beta3 has been release for beta testing

I just uploaded Copter-4.1.0-beta3 to my cube orange and MP crashes each time it tries to connect through USB mavlink. Does not do this on 4.0.7 nor Copter-4.1.0-beta1.

Is there somewhere that I can download the Copter-4.1.0-beta1 apj so that I can continue to work on my project? I failed to save it earlier and now beta3 crashes MP. Thanks.

Sure, here:
https://firmware.ardupilot.org/Copter/beta/

Pick the version you want.

QGroundControll will flash this also.

1 Like

@justin_holm,

No, I don’t think beta1 is available anywhere anymore. We only keep one beta around at a time.

Is it possible to share which version of MP you are using? It’s written on the top left of the MP window.

I’m using 1.3.74.1 build 1.3.7816.17147 with a cube orange and -beta3 and it seems to be OK.

I tried the Beta3 (cube orange) with the following two version of MP with the same result, crashes MP:

MP 1.3.74.1 Build 1.3.7803.12511
MP 1.3.74 Build 1.3.7563.27684

I tried the arducopter latest version from May 1, 2021 and it crashed MP as well. It seems to crash when it starts pulling all of the parameters. I have only tried through USB.

1 Like

I was having the issues after I upgraded to beta last night, it gave me the message param storage failure after I pressed calibrate compass and at the same time disconnected. I figured it was a mission planner thing. Anyway uninstalled, installed latest and its back to normal now.
Custom H7 FC, param storage is to sdcard and not flash.

Malc

I dont know if its a issue, but when connecting to mission planner using beta, it doesn’t show the small window with the process of loading of parameters, it goes checking mavftp and then it stays that way, it does not go to getting parameters

1 Like

The parameters load in ~3 seconds with mavftp with beta. It’s not an issue it’s a feature.

1 Like

This feature will work with telemetry radio also or it’s an usb only.

1 Like

mavfpv is used for any connection. With a telemetry radio it will take a bit longer to load but much faster then before.

1 Like

Is this new in 4.1? Because i see mavftp in 4.0.7 too.

Corrado

1 Like

Not sure actually. I have been running Dev versions on so many craft for quite awhile, don’t recall.

1 Like

I would reconsider your stance. Once you ascend above treetops, especially at night, wind speeds can go from zero to 30+. You’d never know from the ground because the winds are laminar.

@justin_holm,

Txs for the feedback re MP crashing while loading parameters. I’ve seen this a few times now as well and I think @meee1 is looking into it. It’s also on the 4.1 issues list so it won’t be forgotten.

@justin_holm,

@meee1 (aka Michael Oborne) tells me that he thinks he’s fixed all the MP param load issues in the latest beta. I’ve lightly tested and it seems OK to me now.

By the way, the latest beta MP can be downloaded by opening MP’s Help screen, then select “Check for BETA Updates” and after a few minutes it should be updated (you may need to press a confirmation near the end of the process).

1 Like

@rmackay9,
I’ve tested three different versions today, It’s still crashing. image
Can you tell me which version you used?

@XinChengGe,

I’m on the last one on your list and I also had it evaporate once last night but not again today. @meee1 requested some windows event logs from me so I’ve sent that and hopefully this will help get to the bottom of it.

image

Sorry for suggesting it’s all fixed when it appears it’s not completely fixed.

Alright, I can reproduce it everytime, Just let me know If you need any help.

1 Like

@XinChengGe, txs, I’ve passed this onto @meee1 and the “MP evaporation” is back on the 4.1 issues list so it won’t be forgotten.

@rmackay9 Oh my… forgot to say, It’s only happened on telemetry, USB is fine

1 Like
Servers by jDrones