Servers by jDrones

Copter-4.1.0-beta3 has been release for beta testing

Copter-4.1.0-beta3 has been released for beta testing can be downloaded from MP, QGC, etc via their beta firmwares links.

Note: beta2 was skipped due to an issue with the build server.

The changes are in the ReleaseNotes and also copied below:

Changes from 4.1.0-beta1

  1. Attitude control and Navigation
    a) Auto mode Spline command fix when using terrain altitudes
    b) Drift after takeoff fix if GPS position has moved
    c) Feed forward angular velocity calculation fix
    d) Guided mode option (GUID_OPTIONS) to configure how SET_ATTITUDE_TARGET’s thrust field is interpreted
    e) Improved position control during loss of yaw control by using thrust vector with heading
    f) Standby mode disables hover learning
  2. BLHeli improvements and fixes
    a) Bi-directional ESC telemetry fixes
    b) Bi-directional dshot 1200 supported
    c) Control of digital with non-digital outputs fixed
    d) Support dshot commands for LED, buzzer and direction control
    e) Passthru reliability improved
  3. New autopilot boards
    a) PixC4-Pi and PixC4-Jetson
  4. Avoidance fixes
    a) OBSTACLE_DISTANCE_3D boundary cleared after 0.75 seconds, allows easier multi-camera support
    b) Simple avoidance logging re-enabled
  5. Other enhancements
    a) Auxiliary function logging shows how it was invoked (switch, button or scripting)
    b) CAN ESCs can be used as battery monitors
    c) External IST8308 compass supported on CubeBlack
    d) FLOW_TYPE parameter hides/displays other FLOW_ parameters
    e) FrSky telem reports failsafe, terrain alt health and fence status
    f) Harmonic notch support for CAN ESCs (KDECAN, PiccoloCAN, ToshibaCAN, UAVCAN)
    g) OSD gets fence icon
    h) RunCam OSD and camera control
    i) Septentrio GPSs support GPS_SBAS_MOD parameter
  6. Bug fixes
    a) Barometer averaging fixes for BMP380, BMP280, LPS2XH, SPL06 drivers
    b) EKF3 fix to reset yaw after GPS-for-yaw recovers
    c) KDECAN output range, motor order and pre-arm check messages fixed
    d) Logging memory leak when finding last log fixed
    e) Pixhawk4 mini safety switch fix
    f) SD card slowdown with early mounts fixed

We still have quite a few issues to resolve before 4.1 becomes the stable release but your help with the beta testing is really important and greatly appreciated!

By the way, I mentioned in the beta1 release thread that the BendyRuler object avoidance issues would be fixed in beta2 but I’m afraid they will be included in beta4.

P.S. beta2 never made

8 Likes

I was just noted in the copter 4.1.0 beta1 release that improved calculation of wind speed and wind direction.
if so could you implement wind failsafe function. If more wind for in one direction at particular time trigger RTL .

@kalai1219,

This is theoretically possible but my personal view is that this could be quite a niche requirements and we probably wouldn’t implement it in the core ArduPilot C++ code. Instead we would recommend it be implemented using Lua scripts.

Anyway, feel free to raise an enhancement request in the issues list.

There seam to be no mention that now all telemetry ESCs can be used as a source for battery monitor.

@amilcarlucas, ah yes, I’ll add it to the list, txs!

@rmackay9 there is still no beta2 version in https://firmware.ardupilot.org/Copter/beta/

Hi @sergbokh,

Yes, you are completely right and it was caused by this PR about 4 days ago. This has been fixed now and hopefully the betas will appear within the next 3 hours. Sorry for the delay but thanks for the report!

1 Like

Oh…Great, I wait it for a whole day.

Hi @rmackay9,
Still not beta2…

@XinChengGe, @sergbokh,

Alright, it took another attempt but we got the build server fixed and now beta3 is out. Thanks for your patience!

2 Likes

Is the FFT running with data before or after the harmonic notch?? Today I set the INS_HNTCH_REF a bit higher and the FFT params (like FREQ_HOVER and THR_REF) changed significantly after a test flight.
Before I changed HNTCH_REF, the param FREQ_HOVER was around 95Hz and THR_REF was 0.31-ish. Now they are 112Hz and 0.24, respectively. Both flights were just hoverings (no sharp maneuvers).

It runs using pre-filter data

@rmackay9
I updated from beta1 to latest beta (Mission Planner doesn’t show, if it is beta3, so this is my assumption) a few minutes ago through Mission Planner.
After this, Mission Planner crashes, when trying to connect again via USB. It starts communication and the text-to-speech already reports “mode changed to stabilize” but when the pop-up shows “checking for MAV-FTP”, the Mission Planner crashes.

I tested this on two different Windows 10 machines. One has Mission Planner 1.3.74, the other already has 1.3.74.1 (the latest beta).

So currently I am locked out from my autopilot :frowning:

I also tried to reinstall the beta but now it simply says, that the latest beta is already installed.

EDIT: When I connect with “herelink”, the Solex app reports ArduCopter V4.1.0-beta3. But also when connecting Mission Planner through the herelink connection, the Mission Planner crashes during the phase “Checking for param MAVFTP”.

EDIT2: After several more tries, Mission Planner could connect without crashing. Seems to be difficult to reproduce…

EDIT3: Are there any further changes in beta3 than listed above for beta2?

1 Like

@rmackay9

Just as Hacky is reporting, we can also report 4.1 beta 3 causes MP to crash on connect (only tested on USB), seems to happen when it tries to download params on FTP.
QGC connects fine.

1 Like

@Hacky, @pompecukor,

Great thanks for this report. I’ve seen MP crash when using UDP but I also found it hard to reliably reproduce. I’ve passed this onto @meee1 and he’s taking a look. txs again.

can you guys try updating beta again, also when you say crash… is it program exit. or just not connecting?

I’m pretty sure they mean that MP is suddenly disappearing…

@Michael_Oborne
Yes, like rmackay9 says - it is just suddenly disappearing. I tried with UDP (via herelink) and with USB cable.

I have another issue (not sure, if related only to the beta3):
Yesterday I connected a second external compass (IST8310 on the I2C connector). It was detected successfully and marked as external (third in the list)

Then (after shutting down the copter) I disconnected it again and after next boot, it was still in the list, but marked as “Missing”. So far so good…

But when I click on “remove missing” and reboot, it still appears after next boot in the list (marked as missing).

Even more strange:
When I connect it again, after next boot it is still marked as “Missing”.

This means, I can neither get rid of it in the list nor I can get it activated again when connected.

When I start compass calibration, it shows all the three green bars growing during movement but also after calibration and reboot, it is still marked msising… :thinking:

EDIT:
Now it seems to be resolved. Steps were:
(Compass not connected)

  1. “Use Compass 3” was unchecked
  2. Pressed “Remove Missing”
  3. “Use Compass 3” was checked again
  4. Reboot

After a reboot, the IST8310 was no longer listed.
Shutdown again.

Now, IST8310 was physically connected again to I2C.

After another power cycle, it was detected again and marked as external. So everything looks fine now but I still don’t know, why it did behave so strange before.

Servers by jDrones