Copter-4.0.1-rc3 available for beta testing

Copter-4.0.1-rc3 has been released for beta testing and can be installed using the ground stations’ (MP, QGC’s) Beta Firmwares link or it can be downloaded directly from

The changes compared to 4.0.1-rc2 are in the ReleaseNotes and copied below:

  1. Bug Fixes:
    a) Semaphore fixes for Logging, Filesystem and UAVCAN Dyanmic Node Allocation
    b) RangeFinder parameter fix (4th rangefinder was using 1st rangefinder’s params)
    c) TradHeli STB_COL_x parameter description fixed
  2. Minor Enhancements:
    a) Autorotate flight mode renamed to Heli_Autorotate
    b) Solo default parameters updated
    c) “Prepared log system” initialisation message removed

The most important fixes included are the semaphore fixes that could lead to data corruption in logging. This was discovered during the Copter-4.0.1-rc2 testing so thanks very much to @VDLJu for his report and assistance getting to the bottom of this. If others have been having problems with logging we are interested in hearing if this improves thing (it may not and we have more logging reliability improvements coming in a future release especially for the smaller boards).

Getting Copter-4.0.1 out quickly is quite important because of the FrSky SPort Passthrough telemetry issue (blog post) so any feedback on this release is greatly appreciated!

Assuming no issues are uncovered we hope to release this version as the default within the next week.


Have you tried using a JoyStick to control a copter in the latest 4.0 branch using the simulator? RC overrides do not seem to have any effect on the RC channels.


I guess you mean using MP’s built-in simulator with a Joystick? I just tried this now and it seems to work…

EDIT: I discovered an issue with MP’s RC calibration that I have raised an issue for here.

Hi Randy,

Today I did a test flight for approximately 8 minutes, and while the drone remained in hover, the system invoked the SmartRTL flight mode because of a radio failure, the suspect is that the maximum distance between the drone and the radio control was 150 meters, a distance close enough to lose the signal, that never happened, sometimes I flew the drone at distances of 1 km without radio failures.

Hi Randy.

Just finished going back and forth between 0.0 and 0.1-rc3 a couple of times on my Orange Cube that’s paired with an Emlid GPS appropriated from an Edge. The CAN mag simply disappears in rc3, and I get “Compass not healthy” messages.
Devices in 4.0.0:

Devices in 4.0.1-rc3:

Here’s a pair of LOG_DISARMED boots:

Have you tried booting the Cube via USB (only) and see if it shows up?

Curious if it is the Boot time of the CAN compass like it is on the Zubax

What is your BRD_BOOT_DELAY set at?

1 Like

The Orange Cube is pretty slow to boot, even with DELAY=0. The GPS led definitely stops being white before B/E leds go off under the cube.
THe issue appeared while powered from USB, on the desk.

Could you change the boot delay to 6000 and see if that helps

No, I compiled SITL from the latest Copter-4.0 source and connected with MP using UDP. I also tried my GCS as well. Both worked fine with 3.6, but not with 4.0. Did anything change regarding RC override messaging or semantics in 4.0?

It helps, the compass is detected, down to 5000. At 4500 it isn’t there.

I need at least 5000 for my Zubax compass to be discovered


We discussed the joystick with SITL issue on the dev call this morning and we think it could be related to a Windows 10 update that may have broken the joystick feature (in Windows). @DavidBuzz provided this link.


Thanks for the report.

We discussed this on the dev call today and we couldn’t think of any changes that should affect the RC failsafe. That doesn’t mean necessarily that it isn’t an issue, just that we couldn’t think of a cause.

From a look at the log I can see the vehicle is using SBUS and that the failsafe is caused by a “late frame” which just means that the autopilot didn’t get an update from the receiver within the required 0.5 seconds. I think the receiver is setup to send no pulses though so this seems normal.

There are no RSSI values in the log so we can’t see what the receiver thinks the link quality is. If we had this we could definitely see if the problem was in ArduPilot or in the receiver because if the receiver was reporting a strong rssi but AP still failsafed then that would be suspicious. On the other hand if the receiver reported the RSSI was weak then it would surely be an issue with the antennas or some other interference affecting the receiver.

I’m not quite sure where we can go with this. Perhaps you could try setting up RSSI for the SBUS receiver. I’ve never personally done this but we do have a wiki page re rssi.

I’m using Windows 8.1. I have SITL from the 4.0 branch running in VMware with Ubuntu 18 and I also updated a Pixhawk as well. Both don’t work. ArduCopter 3.6 works fine with the same version of MP and my GCS.

With 4.0.x, the joystick is recognized and responsive in the MP joystick setup, but not in the RC calibration panel.

I’ll try another laptop just to be sure it’s not some type of odd hardware issue related to 4.0.

My other laptop behaved the same way. The RC override messages are being ignored.

Good day,
tested today this version… the behavior of obstacle avoidance don’t have a good performance. Would you mind if its possible implement the drivers for the teraranger evo 600hz… evo 60m and evo3m coz drivers limit reading sensors framerate at 100Hz


Thanks for the report. It’s probably best to open a new topic and if possible provide an onboard log file so we can have a look. It’s important to also clarify what “don’t have good performance” means (in the other thread). AP has support for the TeraRanger Tower and EVO so it may work. I guess you’ve tried and it didn’t work?


Ok, thanks. From a quick discussion with @peterbarker it seems like the issue could be outside of ArduPilot or at least outside of the ArduPilot flight code. The issue is more likely within the simulator or MP. I’ve reached out to @peterbarker and @Michael_Oborne (@meee1?) to see if they have any idea.

Good day, teraranger tower and evo work well…no issues for the configuration of the parameters on MP with 4.0.0. and more, but the reading of the sensors is slow… asap i will send you the log file of some test I’ve done.

1 Like