Copter-4.0.0-rc3/-rc4 available for beta testing!


Re the missing serial reports, we’ve found (and fixed) the issue (fix is here). It’s clear we are going to need another release candidate so we plan to release -rc5 on Monday which will include this fix.

thanks very much for finding this and reporting back! Really great.

1 Like


Thanks for the report. We’ve got a fix for the missing serial6 on the MatekF405-wing board as well and it will also go out on Monday as part of -rc5. Thanks very much!


Re the CubeOrange startup, there are a few possibilities:

  1. The autopilot is starting up but the LEDs are not coming on because the GPS/compass unit is connected through CAN so the CAN_P1_DRIVER and NTF_LED_TYPES params must be set.
  2. writing the new I/O firmware (and/or bootloader) took 30sec or so but the autopilot was rebooted before this could be completed (waiting longer should resolve this problem)
  3. something wrong with our bootloader or a sensor is broken.

Can you try options 1 and 2 and then if that doesn’t work could you provide a video of the flight controller’s LEDs? The GPs/compass unit’s LEDs don’t tell us much but there are some LEDs on the flight controller itself (I think) that tell us the state of the bootup.

I set all the necessary parameters for the compass in the previous version of copter 4.0.0-rc2 and also set the led diodes. before installing copter 4.0.0-rc4 everything worked fine now after several minutes my computer has not detected the orange cube

1 Like

@Mallikarjun_SE, re the GCS failsafe, please tell me if you find it difficult or annoying. It’s possible that we should disable it by default but I’d like to hear feedback from people…

I would opt for disabling GCS failsafe by default since I can barely see use for it unless you are controlling the drone primarily by a GCS with some long range gear instead of RC.

I am using QGC and Solex as GCS running on an Android device or MP on a laptop, connected over Wifi to an onboard companion computer.
Due to the relative low range of the wifi access point compared to RC there are from time to time connection losses and a GCS failsafe action would be annoying and unnecessary.

1 Like

thank you Randy! :slight_smile: look forward to the RC 5! the filters on the fw copter 4.0 are very important for small quadcopters like mine (1.9 "props)

Hey @rmackay9
Yes. Disable by default is good idea.
My telemetry has a Bluetooth module pass-thru and GCS failsafe triggered couple of times in close proximity. I really need GCS failsafe but I don’t want it trigger when there’s good RC connection(probably allow for small LOS radius where GCS failsafe won’t trigger)
But I’m trying to get used to new GCS failsafe method before making a comment. I just get a random thought about fixed wing aircraft where GCS connection loss can be due to orientation of aircraft especially during landing. I wouldn’t like the AP trigger GCS failsafe in such situation.

1 Like

It really surprised me… I use crossfire, also w/ the bluetooth pass-through. And yes, my first flight w/ it, it started to RTL. But, I didn’t know what was going on, since that has never happened, and I was only about 50 meters away. In my somewhat panicked state, I didn’t realize what was happening, and thought I had lost control of the vehicle. So, I killed the motors.
Luckily it’s a little 3" prop copter, so a fall from 100 meters into grass didn’t cause any damage :).

But, I cannot have that failsafe enabled w/ crossfire.

I brought this up in the crossfire support forum, and bumped it a week later, but no one from TBS acknowledged my post. The issue is definitely that crossfire does not conform to the standards… They only send about 1/4 of the usual telemetry packets/frames (not sure which is correct, but you know what I mean).

1 Like

On the Solo, the companion computer is being seen by ArduCopter as a GCS. So you actually can’t even use the GCS failsafe on those. This can be corrected by changing some mavlink type IDs on the companion computer, but I do not know where or how that’s done on it.

@ Matt, randy
I thought Orange is the new Black :slight_smile: with just a faster uC in. I didn;t pay close attention to sensors. My bad. Anyway, it used to sport a Here during 3.7-dev and 4.0.0-rc1/2 double-taped ontop of the Cube and calibrated instantly. Troubles started when I switched to a Here2, in I2C mode, both taped to Cube and on a foldable stand. The quad is very simple, four aluminum arms bolted to a pair of fiberglass squares and a makeshift landing gear. No payload. Just a cheap, somewhat expendable test bird.

GCS failsafe-wise, I’d have it disabled by default. From my experience, a FCC Taranis with a 5dB antenna still gets passthrough telemetry at 2.6 Km. With a R9 module, the figure gets extended past 5. A typical SiK radio is only good for 2 Km, and if there’s a tree or building blocking direct los on a portion of the flight, the link drops.


I’ve remembered a 4th possibility that can stop an autopilot from booting which is if there is not enough power provided especially if using a USB cable. We can confirm this is the cause by disconnecting all accessories (RC receiver, telemetry radio, anything else) and then try powering it up again.

@Mallikarjun_SE, @wicked1, @mtbsteve,

Thanks for the feedback re the GCS failsafe. I’ve created a PR to disable the GCS by default and expect to include this in Copter-4.0.0-rc5 (the next release candidate). Before merging I want to discuss with some other devs as well.


still not working


This discussion is getting long enough that I have created a new topic here.

Thanks for the report and your persistence!

1 Like

Did you try a different PC to connect?

I saw these flags being set in ArduCopter 4.0.3 as well when flying an original Pixhawk-based quadcopter as well. Any ideas why?

I saw these flags being set in ArduCopter 4.0.3 as well when flying an original Pixhawk-based quadcopter as well. Any ideas why?

These flags aren’t actually related to sensors.

These indicate whether the current flight mode is attempting to control xy
position (true for loiter, false for stabilize, for example).

Similarly for Z.


Visit Topic or reply to this email to respond.

In Reply To

December 18 When I test using the simulator, I’m seeing MAV_SYS_STATUS_SENSOR_XY_POSITION_CONTROL and MAV_SYS_STATUS_SENSOR_Z_ALTITUDE_CONTROL flags set
in the msg_sys_status.onboard_control_sensors_health. Is that just a bug in the simulator? Maybe a flow sensor and lidar is enabled by default, but not

Visit Topic or reply to this email to respond.

You are receiving this because you enabled mailing list mode.

To unsubscribe from these emails, click here.

Peter Barker | Programmer,Sysadmin,Geek. | You need a bigger hammer.
:: in what circumstances would you want reverse thrust for takeoff? --tridge

1 Like

Mystery solved! Thanks Peter!

I don’t know where to write exactly, I have a holybro gps module and I redid it for pixhawk. accidentally burned a compass. put a new compass and it is not detected by the system. I soldered 8853 and it worked. I soldered another new ist8310 and it does not work, what is the problem? ardupilot 4.0.3