Cannot connect to CubeOrange with MissionPlanner

This is a discussion carried over from the Copter-4.0.0-rc2 testing thread in which @Jernej_Fajdiga could not connect to the autopilot (a Hex CubeOrange) using Mission Planner.

Question: when I successfully installed copter 4.00-rc4 on the cube. the cube no longer starts running. Can you help me?

Possible causes/solutions:

  1. The autopilot is starting up but the LEDs are not coming on because the GPS/compass unit is connected through CAN so the CAN_P1_DRIVER and NTF_LED_TYPES params must be set. We can conclude this is not the issue because you cannot connect with the MP.
  2. Writing the new I/O firmware (and/or bootloader) took 30sec or so but the autopilot was rebooted before this could be completed (waiting longer should resolve this problem). This is not the problem because I assume you’ve left it powered up for more than 30seconds after booting.
  3. Something wrong with our bootloader or a sensor is broken.
  4. If there is not enough power provided especially if using a USB cable. We can confirm this is the cause by disconnecting all accessories (RC receiver, telemetry radio, anything else) and then try powering it up again. This is not the problem because you’ve disconnected all accessories
  5. The wrong firmware has been loaded to the board somehow
  6. Bad USB cable
  7. Missing drivers on the windows PC

I’ve just received a report that there’s an issue with our CubeOrange firmware’s bootloader so I’ll respond back later.


(Did you try a different PC to connect?)
I tried on three computers on which the cube has previously been worked.

1 Like

The usb cable is fine because I tried two different cables and one that I always use to connect to my computer.

1 Like

all orange cube drivers are installed because the cube was already running on this computer

1 Like


We’ve reproduced the issue and we’re working on a fix.

This is likely a very important issue so thank you very much again for the report.

thanks. What about with my orange cube. it will be repaired or should I return it to the seller and request a new one

@Jernej_Fajdiga, we will make sure you get a fix or a replacement especially because you are the first to report this. If you PM me your address someone will send you one asap.

By the way, did you update the bootloader by going to MP’s Ctrl-F screen and pushing the “Bootloader upgrade” button or was it done some other way?

I connected the orange cube to the computer then connected to it with MP and under the option to install firmware the option is to update the bootloader. but as soon as i clicked the bootloader update i got an error after that i felt the controller was still working normally


So I’m looking at MP’s firmware install screen, and I see the “Force Bootloader” button. Is this the one you mean?

I’ve upgraded the bootloader while connected, using this button:

I have the latest beta MP.

1 Like

I apologize for being a little mistaken. Now that I see a picture of @ThePara. I can say that I updated the bootloader as he did.

1 Like