Copter-3.6.3-rc1 is available for beta testing

Copter-3.6.3-rc1 has been released for beta testing and is available through the Ground Stations’s “Beta Firmwares” links. The changes vs 3.6.2 are in the Release Notes and also copied below:

  1. Bug fixes and minor enhancements
    a) Pixhawk4 RC input fix
    b) TradHeli parameter default fixes for Loiter and PosHold
    c) Onboard OSD fix for MatekSys 405
    d) Solo power off button delay time increased

The first issue affects users of the Holybro Pixhawk4 and is quite serious. We highly recommend that Pixhawk4 users immediately switch to this beta or hold off on flying until 3.6.3 is released.

Any beta testing and feedback is greatly appreciated!


Confirm OSD on MatekF405 working fine! Thank you!
A glitch with the altitude and compass, is also not yet evident. Maybe this is due to the fact that fixed OSD?

1 Like

Hello. When will BLHeli-S configure be fixed? Thx.

Installed and tested in Pixhawk4. Nothing problematic occurs yet. Gotta do some hovering tests first and hopefully everything works. Ground tests seems to be ok,… knock knock…
I used pixhawk 4 for couple of months without problems

1 Like

@rmackay9, what PR/Issue is D referring to? I’ve not see that in my digging.

here you go:

1 Like

thanks, randy!
might be worth mentioning that c) isn’t really restricted to mateksys hardware but fixes OSD for all onboard OSD board types afaik.

cheers, basti.

1 Like

Thanks very much to @AndreyI, @Tom-fly, @vierfuffzig and others who helped test this version. I’ll keep looking for reports but I hope we can release this as the official version perhaps as early as Tue or Wed this week.

There is another question, in the setting ARMING_CHECK included all tests. At such settings in the Stabilizer mode the copter ARM in the absence of gps_fix. Is that how it’s supposed to work?

@AndreyI, yes, that’s how it’s supposed to work. the criteria for arming is different if the vehicle is being armed in more manual modes (i.e. Stabilize, Acro, AltHold) vs more autonomous modes (Loiter, etc).

Perhaps it is wrong…
I take off in the Stabilize mode and only then I switch to Loiter. It turns out that without the “3d fix” will not be correctly remembered point house.

Conduct experiments:

  1. Turning off the “GPS Lock” check.
  2. I turn on the “Loiter” mode and try to make ARM, it does not work. Writes that there is no 3d fix.
  3. I turn on the “Stabilize” mode, ARM is normal.
  4. Enable “GPS Lock” check.
  5. Copter behavior remains as in paragraphs 2 and 3

It is unclear then why this check and when it works?

@rmackay9 where can I get the device driver after updating to 3.6.3? I just flashed over to this firmware and switched to the Chibi OS firmware, but now cannot connect to my pixhawk 2.1 and my laptop can’t seem to find drivers for fmuv3.

Check to see if the com port has a different number

1 Like

I actually got it working on another newer laptop, I plugged in and it downloaded the driver automatically and was able to connect over COM 6… so I wonder if it’s just an age issue with this old laptop that I was trying to get working with it.

one issue noticed, battery level isn’t working anymore. I tried almost everything but it just doesn’t recoqnize voltages at all. SOmebody else notices similarities?

@Iron_Donkey I resolved this issue on an old laptop I use in the workshop by un-installing MP and doing a fresh install from the .msi file.

The new drivers are apparently installed correctly with the new install.

Having a 3D fix does not mean the GPS fix is good enough for the EKF to be happy with it.
So even though it shows a 3D fix on the ground, I always switch to Loiter to check that it is good enough.
It always takes an extra couple of minutes for the 3D Fix to settle down before the EKF is happy with the vertical and horizontal innovations.

1 Like

Yes, what @mboland says is accurate. I think in Copter-3.7 we will change it so that the LED doesn’t go green until the EKF has a good position estimate. This will make the LEDs at least consistent regardless of the mode and reduce some confusion. I am sure we will face a barrage of complaints something like, “why does GPS lock take longer on 3.7?” or “Why does the GPS report 3D lock but the LEDs are still not green?” but we will just have to try and explain this difference between “GPS 3D Lock” and “Good EKF position estimate”.



Could you provide a dataflash log so we can look into the battery level? My guess is that the issue is an outdated Mission Planner or the battery monitor configuration hasn’t been done quite right… but let’s see.

P.S. I’ve check on my IRIS which uses an original Pixhawk (now running ChibiOS) and it seems to work OK for me.