Copter-3.6.0-rc8 available for beta testing

Copter-3.6.0-rc8 is now available for beta testing. If using MP this can be downloaded after pressing the “Beta Firmwares” link on the Install Firmware screen (QGC and other GCSs have a similar feature I believe).

The changes vs -rc7 are in the ReleaseNotes and also copied below:

  1. TeraRanger Tower EVO lidar support added
  2. PCA9685 and NCA5623 LED support added (replacements for Toshiba LED that is becoming end-of-life)
  3. Missions can start with DO_ commands (first NAV command must still be takeoff)
  4. ChibiOS fixes:
    a) DShot and BLHeli stability improvements
    b) added OmnibusNanoV6 bootloader
  5. Bug fixes:
    a) AP_Stat only saves values to eeprom if they change (reduces CPU impact)
    b) boost throttle respects safety switch
    c) TradHeli reduce chance of tip-over when landed in Loiter

We will have at least one more release candidate (-rc9) before we go live because we have an outstanding issue with new Loiter’s initialisation (it twitches if Loiter is engaged while the vehicle is moving quickly)… still, I think we are getting close to an official release.

All testing that people can do is greatly appreciated!

1 Like

How does the fact that the bootloader has been added for the Omnibus Nano V6 affect the installation process of Arducopter to this board? I updated the bootloader on my board with the procedure outlined in the Wiki (using dfu-ultil) and then installed Arducopter w/o issue, I’m just curious for future reference.

it means that hex files including the bootloader and ardupilot in one file are now available for download. That makes it easier for a first time install on a bare board.
Cheers, Tridge


So what would be the easiest process to install on a new board?

Hi @rmackay9,

I really want the driver for Lidar Lite V3HP in the next release, I made PR for this library last month, but it haven’t been approved yet. I hope you can help me complete my first PR for Ardupilot.

1 Like


ok, thanks for the reminder about the Garmin range finder driver… I’ll see if we can get that in for the next release candidate…

1 Like


I think the wiki instructions for Loading Firmware onto ChibiOS-only boards should work. The important part is to download the firmware which ends in _with_bl.hex from

Copter-3.6.0-rc8 OSD doesn’t work on Omnibus F4 Pro. Flashing to latest solve problem.

According to wiki page for this board default HAL_BATT_CURR_SCALE in hwdef should not be set form 18.2 to 38?

Testing 3.6-rc8 with a Teraranger Tower Evo.

Basically it works, but i think it’s not respecting AVOID_MARGIN distance, which i set to 8 m but it begun to work at 5,5/6 m. I’m using one single sensor, pointing forward.
I still need some more flights (different shaped obstacles, more kinds of materials) to understand if it’s sensor reading or ardupilot sw to be fixed.
Also, i would like to have opportunity to assign some functions to a switch and pot (turn avoidance by switch, and tune AVOID_MARGIN by a pot (with selectable MIN and MAX values) similar to what i can do with CH6 and PID tuning. Time for a PR? :slight_smile:

The problem that the Omnbius F4 Pro connection to the external compass cannot be calibrated still exists. The compass is 5883, and the flight controller can correctly identify it, but it cannot be calibrated.

1 Like

Yes have same problem my one is the new matek gps&compass with the Q5883

Yeah me too, i have the Omnibus F4 V6(full size but running the nano firmware), managed to get it most of it working e.g. accel calibration, SBUS working, but i have the same problem.

When you enter the calibation for compass there is no progress bar so no calibration can be done.

1 Like




Today, I re-purchased a separate external compass MHC5883L, and connected it correctly to the OmnibusF4 Pro V3. After connecting the MP, I can recognize this external compass. I will enter the compass calibration page as soon as possible and start the compass. Calibration, finally have a percentage progress bar, but after the rotation in all directions, the progress bar is finally stuck in the 99% position can not be completed automatically, I did not wait, but chose to click the “Accept” button, and then restarted Fly control, re-enter the compass page and see the value of the calibrated compass.

I can’t figure out why the external compass installed in the GPS module is unable to perform normal compass calibration. Where is the problem?

Have you tried the MissionPlaner compass calibration?
Hold down control while clicking compass on the left hand menu

Is to calibrate the compass in the MissionPlaner, the operation steps are no problem, the other pix flight control board is no problem.

I installed it on a radiolink minipix, everything works except for the radio inputs.
I using a Flysky receiver with the ibus protocol…Is a bug???
Someone can help me?

1 Like

F4 V5.1, latest rc8, same problem with compass calibration. PreArm: Compass not calibrated. The external compass with GPS is well recognized. I tried relax mode. When I reach 99% progress meter starts again. I tried to click on the Accept button when around 90%, with the previous version was working ok.

I figured this out…
Do the old style mission planner ‘live calibration’. (Hold down shift or control (i forget which) when clicking the “compass” menu item in MP)
It should work.
Then, go back and do the onboard calibration, and it should save.

At least, that worked for me yesterday, w/ the latest beta.

For me I was able to calibrate with QGC 3.4.2 without any problem. Was not working using latest beta MP. Must be a MP issue. What’s strange, when I come back to MP and go to the Compass Tab, I have a Roll 180 now…

1 Like