Copter-3.6.0-rc7 released for beta testing!

My 210 PixRacer is back in the air on Chibios! Compass issue resolved as noted and everything I tested was on! All flight modes good (Stabilize,Loiter, PosHold, AltHold, Land) and it ran a short mission perfectly. Thanks for the great work!

1 Like

Tried an upgraded ChibiOS build of 3.6.0 rc-7 on my dead cat Quad with PixHawk FC. All Ok so far with latest build. No issues with Stab, Alt Hold, Loiter, Circle, Poshold, Mission, RTL, Smart RTL.
Will try a complete set up from scratch later along with trying on PixRacer, weather permitting.
Another great job.

1 Like

it is not listed in the changes - but i noted that somehow ‘autotune’ mode number switched from 17 to 15?
old mode 17 now triggers a complaint upon booting up - ‘Failed to initialise RC function (17)’.
i hope i did not screw up - i tried to get rc7 code, but it is same in the most recent master as well.
also, in the MP - list of modes now trimmed down severely - probably an MP only issue?

kakute f7 hwdef is wrong - RCIN will not work this way - sharing same timer with motor - but i sent message to Andrew about it.

Can confirm commpassmot now working on the revo-mini, I’m getting 100% interference though, too close to the esc i guess and no room to move it, think i will just disable it for the time being.

Thanks for the fix

1 Like

Hi all,

I just did a fresh install of Copter-3.6.0-rc7 on my Omnibus F4 Pro V3 board and can’t get the OSD overlay to work. The screen stays blank. It did work on rc5 and rc6.
Can someone point me in the right direction?

Edit: just to be sure I re installed rc5. Osd overlay works as expected. Then installed rc7 again and osd overlay doesn’t work.

Best regards,

Jan Willem
The Netherlands

1 Like

I mentioned it earlier, but - the BOOST function (SERVOx_OPTION 81) does not work properly. When using rc6 on a Pixhawk 1 set up as
an X quad and I set SERVO5 OPTION to “81” and SERVO_BOOST to “2”, the output does not respond. If I set SERVO OPTION5 to “53”, I get a mirror of input #3. If I then set SERVO OUTPUT5 to “81” without rebooting, I get the expected output on SERVO 5. But the controller “forgets” these settings when the fc is rebooted, even though a parameter dump shows “81” and “2” for these values.

Also, as soon as I WRITE the “81” value into the fc, the props spin at their min values - before the safety switch is pressed.



Thanks for the report. This sounds like we’re not enabling the output properly, i’ve added it to our list of things to fix so it shouldn’t be forgotten.


This probably came up somewhere else, but the “15” vs “17” confusion comes from the FLTMODEx parameters vs the CH7_OPT, CH8_OPT, etc parameters. So when assigning a flight mode to the flight mode switch, the FLTMODEx parameters are used and the correct number is 15 (as shown in the screen shot above). If assigning AutoTune to an auxiliary switch, “17” is used (and this should also appear correctly in the MP’s list).

AC3.6rcX series firmware I have been following the test, each version has a relatively stable flight performance, should not be far from the official version of 3.6, these days with CAUV V5 with CUAV C-RTK GPS The series test is very good and the flight is stable.

Thanks to the development team, looking forward to the arrival of the 3.6 official version of FW!



The tradheli with Pixhack is looking good! really stable position hold.

1 Like

I think this is fixed in the Copter-3.6 branch, ready for the next rc.
Can you check if the ‘latest’ build works for you?
Cheers, Tridge

Hi Tridge,

I can confirm that OSD overlay works on my Omnibus F4 Pro V3 board with the most recent beta build: 2018-08-03-06:08.

Best regards,

Jan Willem

1 Like


Using Pixhawk 4 latest fw, flown today in Stabilized and except for my poor flying skills all seemed well.

I want to set ch 7 for Auto Tuning and ch 8 to RTL, however I have an issue with setting channel 7 and 8 in Extended Tuning in MP - both drop down boxes are grayed out (was ok on rc 6 I believe but I didn’t revert).

I have set it manually in parameters list RC7_OPTION and RC8_OPTION but UI still grayed out and doesn’t show the correct parameters.

When switching on radio, MP shows the correct flight mode on flight data view.


1 Like

Mission Planner needs to be updated to reflect some changes in Arducopter. I’m sure they’re working on it.

I had the same problem this weekend, but just used the ch5 flight mode switch to do what I needed.

@wicked1 thank you. I guess we are leaving at the edge :slight_smile:.


Can you explain what this is? On 3.5.x I have been setting RSSI_CHANNEL to 6 and it seems to work. Is this something different in 3.6? Thanks.

Both of these worked great. On multiple tests, I had the compass_orient set for 38 (solo leg compass). I have a HERE GPS/Compass installed, which requires compass_orient to be set for 0. Compass calibration completed successfully and updated the parameter to 0 in the process.

Tones were all working in ChibiOS as well, including the compass sounds that were not working in -RC6.


I was able to do some testing on one of my bigger quads today and it’s flying perfect on a Pixhawk classic . I using the new w66A WRAITH32 METAL V2 - 32BIT BLHELI ESC at 6 cell and getting a stable position hold like always. Question do i need to use the aux channel out in order to use Dshot like before or can we now use the Main out 1-8? Thanks again for all your impressive work.

1 Like

One thing I am noticing is the external led is red after arming and does not change to green when acquiring GPS. I using GPS blending set to best GPS.

Solved: replaced the led/USB and it worked.

I am using Omnibus F4 V5 (not the pro version). I am not sure if it is intended to incorporate this board into this branch? I thought I would give it a go anyway.

On 3.6.0-rc7 I am unable to arm. I get either ‘pre arm: waiting for Nav Checks’ or ‘bad logging’ messages in mission planner. This happens even if I set ARMING_CHECK = 0. I have also reformatted my SD card and am using a high quality high speed card. My Hdop is low (usually 0.6) and the number of sats is greater than 13.

I have flashed 3.6-dev and I don’t have these issues and am able to arm and fly in acro, stabilise, and alt hold. I have other issues on the dev build whereby I cannot change into any flight mode that requires GPS and the CH7_Opt and CH8_Opt are greyed out (however they are available in rc7)

I have re-flashed rc7 and the exact same issues have returned, meaning I cannot arm.

Would anybody be able to shed any light on whether I might be doing something wrong or whether it is in fact an issue with rc7? Thanks.