Copter-3.5 Testing List

I have problem, in Copter 3.5-rc1 and 3.4.4. In connection with Mission Planner " “Getting Params 1” in a pop up window. As soon as that operation successfully completed the screen refreshed and all of a sudden a new pop up window appeared with the message “Getting params 12” and it stays there forever unless you press the cancel button,"
When I remove the Minimosd from Pixhawk telemetry #2 port there is no problem loading when connected to USB and telemetry (port #1)

If I connect to QGroundcontrol with USB the same thing happens, “Getting params 12” goes on forever. I hit cancel and go into QGroundcontrol software. The interesting thing is, there is a section that shows Vehicle #1 and Vehicle # 12. Vehicle #1 shows all the parameters (params 1). Vehicle # 12 show no parameters.

So it is pretty clear that you have a Minimosd issue, you should take it there.

“Getting params 12” and it stays there forever unless you press the cancel button, and then the screen refreshes, you are connected and everything works fine

Ah, I know this MinimOSD issue although in a different context.
It’s really a mission planner issue I think. It’s always trying to download parameters from all mavlink devices it sees. I’ve created an item for the MP here:

@rmackay9 I don’t see how that is a MP issue. I think that all MAVLink devices need to answer parameter requests, I think that’s not an optional part of the protocol.

Finished the first Flight with V3.50 RC1, PixHawk v2.4 (3DR) (Hexcopter, with HP4114-350KV) with the following result:
Took off in Stabilized after flight mode Loiter gave me a green indicator, to make sure I had GPS lock and EKF was fine.

As Mot-Hover-Learn = 2 initially, first thing was try was to hover the drone, for the code to find the correct value.
So after hovering for about 10 seconds, I switched back to ALTH.

Make sure that you are more than a few meters (10 or higher) up in the air, as on a high powered drone, you will experience quite a drop in ALTH, which you need to be able to counter act the fall…

After this I did play with Loiter, Alth, and tried Land…

On the Land command nothing happend, so it stayed up in the air, same level, and even after giving it some time, no land was started… , tried a couple of times to switch (loiter -> Land)

Decided to bring it down in ALTH, and after some minor issues with Trottle below Failsave, which comes up in the logfile as RADIO Failsafe) (as I changed the trim on the trottle, the trottle stick down position ended up below Radio Failsafe value which prevented the Arming (Trottle stick down, left)

After succesfull Arming I took off in ALTH and flew a little and activated RTL.
RTL worked fine, and landing from RTL hight worked fine as well,(at 10 Meters moved over to slow decent mode, and effectively landed.

So tested:
STAB, ALT, LOITER, RTL, LAND (not successful)

Copter Yaw seems to be way more smooth as before, Loiter kept position well in windy environment, and aggressive roll maneuvering in ALTH did perform well. (Testing GIMBAL settings) (No Auto Tuning on this version performed yet, so flying with the 3.4.4 settings here)

See log attached…(to figure out the LAND issue)

i have tested it on my stretched f550 hex with good results.

  • Oneshot125 with blheli working with 20a littlebee with active braking enabled on 2213 950kv motors, 9443 carbon prop on 4s.

  • stabilised works

  • althold works

  • Autotune worked but was a little aggressive on the stabilised P i ended up with around 0.3 for rate P/I and 18 for stabilised P

  • yaw control is stable but very slow. it was set to 2.0 P and 0.2 I

  • oled screen is working and is great but it could do so much more.
    heading to verify compass
    alternate between gps 1 and 2
    allow configuration using the oled using the handset controls like they do on osds for changing flight mode assignments, pid, compass and accelerometer calibration etc.
    Vtx control using the new tbs unify and immersion tramp transmitters

  • landing gear function works but when it hit low battery failsafe and landed it did not automatically deploy the landing gear and it done a belly landing luckily i have a 16ah 4s battery hanging under it and is almost level with the gopro gimbal so it took most of the weight.

  • rc failsafe and battery failsafe:land works (apart from gear issue), i have not tested RTL yet.

  • relay funcion works, im using it to control shutter and mode on modified sj4000 camera.

  • camera trigger works

  • I had some issues with the gimbal configuration screen in mission planner, it would let you select settings but when you went back it was blank.

I tested 3.5 on my Quad this afternoon

Got an EKF error on take off

Stabalise works both at low and high speed

Altitude Hold works

Loiter works (When first tried to fly forward in loiter the quad went slightly sideways but sorted itself out very quickly)

RTL Works

3.5 works as well as 3.4 on my quad will test the fence and fail safe tomorrow

2017-02-04 14-07-15.bin (3.0 MB)

Did a successful Copter 3.5 RC1 test today:

FC: Linux BBBmini
Frame: 250 Quad

  • MPU9250 fast sampling enabled
  • EKF3 in use at the first land in auto a kind if toilet bowl, same mission again without toilt bowl while land
  • Stab, Loiter, PosHold, Auto, RTL


Test Rig Flight

Edit: Hexa Frame
AltHold : Worked
RTL : Decent was incredibly slow - must not have set that back. Oddly enough with 20 sats I was not less than 10’ off. Pretty atypical on both my rigs. M8N on both with 3.01 FW.
PosHold : Worked
Accelerometer Calibration - OK
Compass Calibration - OK
Radio Calibration - for some reason I had to redo this - worked.
Radio Failsafe : Test - change throttle pwm to outside of range - works - didn’t test in flight
EKF3 (Enable by setting EK3_ENABLE=1) works - no wacky EKF changes or messages that I observed.

Pixhawk : 2.4.6 clone - nothing but goodness.

Not nearly as long as I wanted to fly thanks to a bad telemetry cable problem I had to track down.
After resetting everything, redoing accel, radio and compass calibrations, took it up and landed.
Took it for a spin at multiple heights and speeds on a low battery. Landed, changed batteries and back up
for some higher speed runs up and down the street.

I feel like its more responsive and overall felt "quicker"
Not sure if that’s in my mind or whatever.
Without a tune, no noticeable hover or stability issues, no steering issues.

LOVE the onboard display…can’t overstate this thanks - makes for simple tinkering without having to break the radio or GCS out as well.

I’ll get more in tomorrow and get my main out.

Good work thanks guys.


I have a Quad with a Pixhawk and Taranis. and a servo gimble for the Lidar Lite. Since I downloaded V.3.5rc1 the Tilt(Pitch) .gimbal is reversed. In the Mission Planer gimbal setup page the does not let you reverse it. Also it looks like that page does not control the setup any more.
Any help please


Another test flight today

Pixhawk 2

did notice a bit of toilet bowl in loiter and was flying at an angle in loiter after a a minute or so everything sorted itself out. Tried Polygon fence and in Stabilize and Althold to Quad performed a RTL without any problem but in loiter the quad just bumped into the fence and didn’t perform RTL.

See log below

Battery failsafe works
Pos Hold works but did notice a bit of toilet bowl if i stopped quickly.

Think the toilet bowl is more a problem with my setup

I found an interesting bug today, if i tried to arm it before ek3 had fully initialised it would lock up the flight controller totally and i would have to power cycle it to bring it back,

when i say locked up, led stopped, oled froze, rc passthrough for gimbal stopped it would not respond to anything.

the only way i found around it was to arm in LOITER, then it wouldnt let it arm before it was ready.

3.5 rc-1 Test Results.
450 clone quad, “x” configuration.
I upgraded from 3.4.4
I did have to re-calibrate compass due to “inconsistand Compass” message.

Flew multiple flights ;Stab, Altitude Hold, Loiter, Circle, Poshold, and RTL. All OK.
Takeoff in Stab, Altitude Hold, and Loiter, OK.
RTL landed and disarmed OK.
Too windy today to try auto tune.

Tried the SSD1306 display on a mRo Pixhawk- Love IT. Module was from Amazon a Diymall product ( ).

Great work,

Main Rig
AltHold : Worked
RTL : Worked Well, on target.
Land: worked well
Stabilize: worked well - but wanted to spin on the horiz on liftoff, it acutally spun maybe 60deg while lifting.
PosHold : Worked well
Accelerometer Calibration - OK, but took almost a minute to set.
Compass Calibration - OK
EKF3 (Enable by setting EK3_ENABLE=1) works - no wacky EKF changes or messages that I observed.
Edit: Optical Flow: seemed to be working.
1.3" Onboard display: Working

Lightware SF11/C on I2C worked perfectly - thanks!

Pixhawk : 2.4.8 clone

Another short one…maybe 10 or 15 mins with a battery change.
This is my big heavy rig.
Still felt quicker and more responsive even with my big hog battery on it.
Little bit of wobble in Alt-hold but I’m sure a tune is in order.
Good up and down the street flying at mulitiple heights and speeds, hovered well.

Lookin good folks. Here’s a folder full of logs from tonight.

EDIT: I did notice some pretty good lag on telemetry to radio, especially on flight mode changes, seems like the ton of EKF3 info was happening when the lag was occurring. Could be a Craft and Theory thing too.

Hexa Main Logs

3 posts were split to a new topic: Navio2: erratic PWM output

Same thing happen to me tonight. My grandson wants a pixracer into his Quad-copter. Pixracer still on the bench and has 3.4.4. installed. USB and Mission planer is working perfectly. I have tried connect a new Radio Telemetry module tonight. It starts normally but than is getting stuck during-“Getting Params 1”. I have never seen that before. But also I have never used that Radio model from Bang-good before. I will try tomorrow a radio which has been working with my Pixhawks. No OSD connected. I have tried Telemetry 1 and Telemetry 2 same result. I thought I should let you know that it will happen in some situation.

Thanks for the report. I’m pretty sure this is an issue with the mission planner.
I’ve raised the above issue and ping’d Michael Oborne so hopefully he can have a look.

could you please post the tlog, as I would like to inspect how mission planner is dealing with it. or not as the case may be

I have done the Accel calib sofar only2017-02-08 20-49-05.tlog (557.1 KB)
2017-02-08 21-35-00.tlog (1.1 MB)
with USB. 2 Files attached smaller is the one where MAVlink gets stuck.