Copter-3.5 Testing List

This is a list of the things we should test in Copter-3.5. Items will be listed as “Not Tested”, “OK”, or “Problem”. If you successfully test a “Not Tested” item, please post below and we can update it’s status to “OK”.

Frames (do these frames fly at least as well as AC3.4):

  • Quad : OK
  • Hexa : Not Tested
  • Y6 : Not Tested
  • Octa : Not Tested
  • OctaQuad : Not Tested
  • Tri : OK
  • Heli : Not Tested
  • Single : Not Tested
  • CoaxCopter : Not Tested

Flight Modes (

  • Stabilize : OK
  • AltHold : OK
  • Loiter : OK
  • RTL : OK
  • Auto : OK
  • Acro : Not Tested
  • AutoTune : Not Tested
  • Brake : Not Tested
  • Circle : Not Tested
  • Drift : OK
  • Guided : Not Tested
  • Land : OK
  • PosHold : OK
  • Sport : Not Tested
  • Throw : Not Tested

FailSafes (

  • Radio Failsafe : Not Tested
  • Battery Failsafe : OK
  • EKF/GPS Failsafe : Not Tested
  • Circular Fence : Not Tested
  • Polygon Fence : Not Tested
  • Crash Check : Not Tested
  • Parachute : Not Tested
  • ADSB Avoidance : Not Tested

New Features (

  • PixRacer Board LEDs : OK
  • PixRacer ESC calibration : Not Tested
  • PixRacer relaxed compass calibration : Not Tested
  • Onboard Display : Not working on PH2
  • Here+ RTK GPS (Ublox M8P RTK) : Not Tested
  • EKF adjusts for GPS offset from IMU : Not Tested
  • Lightware Lidar can use I2C port : Not Tested
  • MaxBotix sonar with serial interface
  • Bebop optical flow : Not Tested
  • Precision Loiter using IRLock sensor : Not Tested
  • Object Avoidance with SF40c : Not Tested
  • EKF3 (Enable by setting EK3_ENABLE=1)

Optional Hardware (

  • Landing Gear : OK
  • Precision Landing / IR Lock : OK

Boards (do these boards fly at least as well as AC3.4):

  • Pixhawk (and compatible) : OK
  • Pixhawk 2 : OK
  • Pixracer : Not Tested
  • PixhawkMini : Not Tested
  • AUAV-X2 : Problem?
  • Bebop2 : Not Tested
  • Navio2 : Not Tested
  • Erle-Brain : Not Tested
  • VRBrain : Not Tested
  • IntelAero : Not Tested
  • QC SnapDragon : Not Tested

What does EKF 3 do for us and what should we look for to report as “successful”?

For the EKF3, I would say if it seems to fly normally that’s a sign of success. So perhaps change the EK3_ENABLE to 1, reboot the board and take it for a fly and if it works, I think that’s good.

One change in EKF3 is that it can figure out the accel calibration values without the user going through the regular calibration. So you could try it on a board that hasn’t had it’s accelerometer’s calibrated, turn off the arming checks and see how it does in Loiter mode.


1 Like

Thank you for the list. Have always wanted a go-by since I tend to stick to my typical flight routine.


Onboard Display is a go - Pixhawk clone 2.4.8 and 2.4.6 both. Love Dat…Thanks!

Using DIYMall .96 oled

Lance, thanks updated!

Onboard Display is a go - Pixhawk 3DR.

Using SunFounder 0.96

If I wanted to reset the accel parameters to Default (uncalibrated) so I can test the EKF3 accel cal feature w/o defaulting all parameters would I just set the INS_ACCxOFF_X,Y,X to 0 and INS_ACCxSCAL_X,Y,X to 1?

@juanjojjjjjj, thanks! I’ve added it to the list of confirmed-to-work displays.

Onboard display works great with CRIUS CO-16 (SSD1306)

I have Loaded 3.5 onto a quad the pixhawk 2.1 everything calibrated and looks ok apart from the compass calibration on 3.5 the reading for compass 1 is in the green and compass 3 doesn’t appear at all. The Compass values are quite a bit different from the previous version.

Pervious Version

Latest Version

Tested Hex Pixhawk 1 Very windy but held position well
Pos Hold -OK
Loiter - OK
Landing - OK
Landing Gear - OK

One battery test flight PH2 quad
Modes: Stab, Loiter, Pos Hld, Alt. Hld, Auto, Land, RTL
All worked perfectly. compass and gps stable.

I like it---- Cheers RB

After loading new firmware, (PixHawk 1, v2.4), dual GPS (Ublox 6m 3DR, and Ublox m8n, used for Compass as well) Prearm message came up, compass not calibrated…, so calibrated the compass (complete new set of settings for compass 1 and 2.

Switch to loiter and wait for the full green indicator (in house testing on the bench) got 10 sats… small display kept showing compass needs calibration, but prearm indicator on display showed Prearm Passed…(and full green light on PixHawk, so in the field I would have taken off…)

SSD1306 is already paying for itself…

So needed an extra reboot to get the new compass values loaded…
Now it started complaining about the Fence which I previously had on Circle and height only (value 3)

Started thinking that GPS must be too unstable (I.e. Detecting speed, while in fact there was nothing moving). But even after a long wait this fence message didn’t go away… so changed fence parameter to Full (7) which solved that one…??

Compass not calibrated message

Primary GPS has changed…

Thanks very much for the reports! I’ve updated the list a bit. Also I’ve added a list of board types.


  • I’ve added the Crius screen to the Display wiki page.
  • I think we may have an issue with the onscreen display never clearing messages. MP clears them after 30seconds so we might need to add that.

@ardisd, the compass offsets look quite similar before and after so that’s fine. It does look like a compass has gone missing but I wonder if perhaps you’ve disabled the external compass? It definitely looks like what was “compass #1” is now missing. But that doesn’t explain why the new “Compass #1” is appearing as “external”.

In relation to clearing messages, that’s happening at the GPS line as well when switching from 10 Sats back to 9, it leaves the 0.
Top line indeed keeps telling you that throttle is between failsave, even after powering up transmitter, so it seems it is not getting updated with latest info…

Re. Compass I made a comparison on the PARMs just after flashing v3.50 to have the initial values, and one just after compass calibration…, seems that in specific fields we had a 1 before (at flashing time) which may have been the reason the compass calibration message came up in the first place…

The compass values itself are quite different as well.

See screen dump


Thanks for the report. I think the differences in compass calibration numbers (offsets, etc) are OK. My guess is that this time you’re using the onboard compass calibration while previously you were perhaps using the “Live calibration” (the one that showed the spinning globes).

Re the screen, ok, a little more work to make it perfect I guess!

Regarding the “missing” compass in Pixhawk2: it’s normal. Previously we had three compasses running:

  • one AK8963 inside a MPU9250
  • one LSM303D
  • another AK8963 inside another MPU9250

Now, the first MPU9250 is doing high rate sampling and that isn’t possible while using the compass. So the compass inside the first MPU9250 is not used and only the other two compass are visible.

To complement this information: the MPU9250 chips were in early Pixhawk2 versions (some in Solo for example) MPU6000, which doesn’t have a compass. Usually only one compass is used at a time (and most people will have a better external compass) so having two internal ones is more than enough. Also, the system only supports a maximum of 3 compasses even if it detects more.

@rmackay9 how can you disable external compass?? and is there a way to tell if the external compass is working