Copter-3.5 Testing List

I have a Quad with a Pixhawk and Taranis. and a servo gimble for the Lidar Lite. Since I downloaded V.3.5rc1 the Tilt(Pitch) .gimbal is reversed. In the Mission Planer gimbal setup page the does not let you reverse it. Also it looks like that page does not control the setup any more.
Any help please


Another test flight today

Pixhawk 2

did notice a bit of toilet bowl in loiter and was flying at an angle in loiter after a a minute or so everything sorted itself out. Tried Polygon fence and in Stabilize and Althold to Quad performed a RTL without any problem but in loiter the quad just bumped into the fence and didn’t perform RTL.

See log below

Battery failsafe works
Pos Hold works but did notice a bit of toilet bowl if i stopped quickly.

Think the toilet bowl is more a problem with my setup

I found an interesting bug today, if i tried to arm it before ek3 had fully initialised it would lock up the flight controller totally and i would have to power cycle it to bring it back,

when i say locked up, led stopped, oled froze, rc passthrough for gimbal stopped it would not respond to anything.

the only way i found around it was to arm in LOITER, then it wouldnt let it arm before it was ready.

3.5 rc-1 Test Results.
450 clone quad, “x” configuration.
I upgraded from 3.4.4
I did have to re-calibrate compass due to “inconsistand Compass” message.

Flew multiple flights ;Stab, Altitude Hold, Loiter, Circle, Poshold, and RTL. All OK.
Takeoff in Stab, Altitude Hold, and Loiter, OK.
RTL landed and disarmed OK.
Too windy today to try auto tune.

Tried the SSD1306 display on a mRo Pixhawk- Love IT. Module was from Amazon a Diymall product ( ).

Great work,

Main Rig
AltHold : Worked
RTL : Worked Well, on target.
Land: worked well
Stabilize: worked well - but wanted to spin on the horiz on liftoff, it acutally spun maybe 60deg while lifting.
PosHold : Worked well
Accelerometer Calibration - OK, but took almost a minute to set.
Compass Calibration - OK
EKF3 (Enable by setting EK3_ENABLE=1) works - no wacky EKF changes or messages that I observed.
Edit: Optical Flow: seemed to be working.
1.3" Onboard display: Working

Lightware SF11/C on I2C worked perfectly - thanks!

Pixhawk : 2.4.8 clone

Another short one…maybe 10 or 15 mins with a battery change.
This is my big heavy rig.
Still felt quicker and more responsive even with my big hog battery on it.
Little bit of wobble in Alt-hold but I’m sure a tune is in order.
Good up and down the street flying at mulitiple heights and speeds, hovered well.

Lookin good folks. Here’s a folder full of logs from tonight.

EDIT: I did notice some pretty good lag on telemetry to radio, especially on flight mode changes, seems like the ton of EKF3 info was happening when the lag was occurring. Could be a Craft and Theory thing too.

Hexa Main Logs

3 posts were split to a new topic: Navio2: erratic PWM output

Same thing happen to me tonight. My grandson wants a pixracer into his Quad-copter. Pixracer still on the bench and has 3.4.4. installed. USB and Mission planer is working perfectly. I have tried connect a new Radio Telemetry module tonight. It starts normally but than is getting stuck during-“Getting Params 1”. I have never seen that before. But also I have never used that Radio model from Bang-good before. I will try tomorrow a radio which has been working with my Pixhawks. No OSD connected. I have tried Telemetry 1 and Telemetry 2 same result. I thought I should let you know that it will happen in some situation.

Thanks for the report. I’m pretty sure this is an issue with the mission planner.
I’ve raised the above issue and ping’d Michael Oborne so hopefully he can have a look.

could you please post the tlog, as I would like to inspect how mission planner is dealing with it. or not as the case may be

I have done the Accel calib sofar only2017-02-08 20-49-05.tlog (557.1 KB)
2017-02-08 21-35-00.tlog (1.1 MB)
with USB. 2 Files attached smaller is the one where MAVlink gets stuck.

I have 3DR radio hooked to Pixracer running 3.5.1 with no issues. baud set to 57600.


Installed copter-3-5-rc1Octa to run through all the tests outstanding that I can.
Pixhawk, (Pixir, Lidarlightv2, OpticalFlow. all currently unplugged)
H8 rig
Both OLED and MP reporting
Pre-Arm Check firmware or Frame_Class
Frame_Class = 3

any Ideas?
0:Plus 1:X 2:V 3:H 4:V-Tail 5:A-Tail 10:Y6B (New)
Frame = 0 OK
Frame = 1 OK
Frame = 2 OK
Frame = 3 check firmware or FRAME_CLASS
Frame = 4 check firmware or FRAME_CLASS
Frame = 5 check firmware or FRAME_CLASS
Frame = 10 check firmware or FRAME_CLASS

An octa H configuration isn’t supported, it never was. If you used an octa firmware before with H configuration set, it would actually use an X configuration.

Ah Ok this would explain a lot. I have a load of H8 frames and always felt the motor mixing was not quite correct for the inner motors, although they fly quite well. I may have to have a look at custom mixing then.

Meanwhile I will set Frame to 1 (X) and carry out as many tests as I can.

I know little about that, but how does your octa H differ from an X?

I have just connected an older 3DR radio to the Pixracer and have no problems with that one.

750mm quad , pixracer 3.5rc1

loiter: ok
parachute: ok (ground test)

compass auto learn does not modify live calib values

tried so far:
compass live calib with compasmot , flight log reported mag error by MP auto analys above 60%
compass autolearn did not change values , reported mag error by MP auto analysis above 60%
COMPASS_LEARN set to 0 1 2 do not produce any change in params (no sure if they are supposed to)

Is it possible that MP auto analysis tool is not working properly ? (MP

For testing purposes i did the following test
flown an auto mission with WP_YAW_BEHAVIOR set to 2, no ROI set, then flown the same mission with ROI set.
Copter orientation maintained according to ROI PERFECT!
Superimposing flight paths in google earth there are differences less than 1.5m between the two flight.

No reason to believe compass is not working as expected but the numbers.

Second issue i was not able to change the speed no matter how i set it. wp nav speed is set to 650cm/s. changed speed in MP to 700cm/s no effect, (both columns) , max speed it was able to achive 500cm/s



I think the difference between an X and an H is just the direction of the propellers. It’s not a change in shape of the frame. So some vehicle manufacturers (including EnRoute) make vehicle frames that physically look like the letter “H”. This doesn’t mean they’re “H” frames from an ardupilot point of view though. To ArduPilot, an “H” is the same as an “X” except the motors spin in the opposite direction.

I’ve just added “H” frame support for Hexa and Octa so this should go out with -rc2. There is a danger though that hexa/octa people who were confused about the difference between H and X will find their vehicles don’t fly on AC3.5.

@rmackay9 You should notify @meee1 of that, otherwise I think those options won’t be selectable in MP (in the setup screen).

I have started a new topic regarding the H frame as it’s going off topic:-