Servers by jDrones

Copter-3.5-rc1 released for beta testing


(Petr Zverina) #63

HOW CAN I SETUP frame for y6b ??? value 10 write me UNKNOWN !

(Francisco Ferreira) #64

Why the caps lock? Please write properly, there’s no need for that.

Have you set FRAME_CLASS to 5?

(Petr Zverina) #65

yep, and fliped on start, so seems like y6A

(Hubertus Paetow) #66

@ Rolf
had same issue on pixracer - slow parameter transfer.
Found: In 3.5 serial5_baud defaults to 921600 but should be 921. Changed it and wifi works fine again.


(Francisco Ferreira) #67

Flipping doesn’t mean it is acting like Y6A. I just looked at code and it is the same as before merging all frames into one binary. Please open a new topic with your issue (with a log!).

(Francisco Ferreira) #68

That was almost certainly a coincidence, writing 921600 or 921 shouldn’t make any difference.

(cala2) #69

I have FRAME CLASS and FRAME TYPE to choose
In a 250 cuad, I suppose to set 1 in the two params?

(Rolf) #70

Thanks for the information. Tried 921 and another wifi-adapter with the same issue. Perhaps its a problem of Win10 & MissionPlanner. On my android with tower no problems.

(Petr Zverina) #72

its dont mean , but can be it reason. becouse y6A have other order of motors :wink: same flip was happend in 3.3 when i set wrong select frame :wink:

(Hubertus Paetow) #73

You´re right. Problem occurs randomly and sometimes disappears when changing the baudrate in MP.
Wifi worked fine in 3.4.


(Francisco Ferreira) #74

FRAME_TYPE is the same as the old FRAME parameter. The FRAME_CLASS corresponds to the old different firmwares (hexa, octa, etc.). So for a quad you put FRAME_CLASS to 1, FRAME_TYPE should be the same as you had in the FRAME parameter (actually if you upgrade from a previous version this should already be set as only the name changed).

(Francisco Ferreira) #75

@Hubertus_Paetow @Rolf

The wifi issues aren’t an ArduPilot problem. If you read this long topic, you’ll see that other people also have problems and an update to the Wifi board helped. As I’ve said there, from an ArduPilot perspective, the wifi connection to the board is just another serial port, we don’t do anything different from a telemetry port.

(artemen) #76

I’ve flashe auav pixracer today with ac3.5rc1, one of the issues was that I wasn’t able to save any of the parameters via esp8266 bridge, flashed back ac3.4.5 and able to save params again. (I couldn’t save Arming Check 0).

(artemen) #77

Just reflashed ac3.5rc1 and ac3.4.5 and ac3.4.4 wifi bridge is almost useless on ac3.5rc1, takes forever to download params and will never save any, always return an error. flashed ac3.4.5 and all is back to normal.

(rmackay9) #78

Thanks for testing. I’ve reproduced the issue and added it as a to-do item to fix for AC3.5.

(Dave) #79

I have realized this also with Copter 3.5Rc1 and Rover 3.1.1. Pixracer’s both.

(artemen) #80

The same issue with Frsky telemetry… At least on pixracer. Didn’t have time to check OSD, but I anticipate the same result…

(Dave) #81

Frsky Telemetry is working for me. PixRacer to an XSR and on the Taranis no problem as with previous version. Using telemetry option “4” (Frsky Sport) in Mission Planner.

(artemen) #82

I am using frsky D with D4RII.
Went back to ac3.4.5 all is back.
Double checked all frsky telemetry settings an hour ago.

(Luís Vale Gonçalves) #83

Drotek Tiny RTK is already supported by Arducopter