Copter-3.5-rc1 released for beta testing

I have FRAME CLASS and FRAME TYPE to choose
In a 250 cuad, I suppose to set 1 in the two params?

Thanks for the information. Tried 921 and another wifi-adapter with the same issue. Perhaps its a problem of Win10 & MissionPlanner. On my android with tower no problems.

its dont mean , but can be it reason. becouse y6A have other order of motors :wink: same flip was happend in 3.3 when i set wrong select frame :wink:

You´re right. Problem occurs randomly and sometimes disappears when changing the baudrate in MP.
Wifi worked fine in 3.4.


FRAME_TYPE is the same as the old FRAME parameter. The FRAME_CLASS corresponds to the old different firmwares (hexa, octa, etc.). So for a quad you put FRAME_CLASS to 1, FRAME_TYPE should be the same as you had in the FRAME parameter (actually if you upgrade from a previous version this should already be set as only the name changed).

1 Like

@Hubertus_Paetow @Rolf

The wifi issues aren’t an ArduPilot problem. If you read this long topic, you’ll see that other people also have problems and an update to the Wifi board helped. As I’ve said there, from an ArduPilot perspective, the wifi connection to the board is just another serial port, we don’t do anything different from a telemetry port.

I’ve flashe auav pixracer today with ac3.5rc1, one of the issues was that I wasn’t able to save any of the parameters via esp8266 bridge, flashed back ac3.4.5 and able to save params again. (I couldn’t save Arming Check 0).

Just reflashed ac3.5rc1 and ac3.4.5 and ac3.4.4 wifi bridge is almost useless on ac3.5rc1, takes forever to download params and will never save any, always return an error. flashed ac3.4.5 and all is back to normal.

Thanks for testing. I’ve reproduced the issue and added it as a to-do item to fix for AC3.5.

I have realized this also with Copter 3.5Rc1 and Rover 3.1.1. Pixracer’s both.

The same issue with Frsky telemetry… At least on pixracer. Didn’t have time to check OSD, but I anticipate the same result…

Frsky Telemetry is working for me. PixRacer to an XSR and on the Taranis no problem as with previous version. Using telemetry option “4” (Frsky Sport) in Mission Planner.

I am using frsky D with D4RII.
Went back to ac3.4.5 all is back.
Double checked all frsky telemetry settings an hour ago.

Drotek Tiny RTK is already supported by Arducopter

@Rolf (& others), Tridge and Peter Barker resolved the the Pixracer ESP wifi issue today so parameters load at the normal (fast-ish) speed. This will go out with AC3.5-rc2 which I hope to push out soon. The only final hold-up on -rc2 is I’d like to include the GPS blending but that needs just a touch more code review. If it takes too long then I’ll just release -rc2 without the blending.

I can confirm that the parameters load normally with PixRacer with today’s master.

Thanks Randy, Tridge and Peter for solving the issue.


I am unable to finish the wizard no matter what I do. Stuck at Step 15 of 16. if I click finish, nothing happens. I can go back a step. If I use the window “x” the window sill doesn’t closes.

MP running on Windows 10.

So I have a pixhawk that has bin fine I just uploaded the new version of mission planner and updated to firmware 3.5.1 (8ab1b3eb) I calibrated the mandatory hardware. I’m running a ecternal compass along with the internal one. I have ran the calibration for Compass sever times now. I keep getting a pre arm rc yaw not calibrated. What is going on? I have it connected by USB

Do you konw how the IMU&GPS offset works?I can’t find them in ardupilot.