Copter-3.5.4-rc2 available for beta testing

We’ve just pushed out Copter-3.5.4-rc2 for beta testing so you should be able to download it from the Mission Planner’s Install Firmware screen’s “Beta Firmwares” link (and perhaps other GCSs too). This has just a couple of minor changes on top of Copter-3.5.4-rc1 to address some compass issues that turned up during testing (ReleaseNotes.txt).

Changes from 3.5.4-rc1:

  1. Compass improvements / bug fixes:
  • probe for LIS3MDL on I2C address 0x1e
  • bug fix pixracer compass detection

Any help with beta testing is greatly appreciated! If all goes well we will release this as the new official release in a week or two.

many thx!

I missed the pixracer compass detection bug, and failed to find a related PR (my fault).

Would you mind to provide a pointer to what this was? Or when it was resolved?


1 Like

Hi Olliw,

Here’s the bug fix from Tridge.

The bug apparently crept in as we merged the very extensive compass driver changes from master (or more correctly the latest Plane release branch) into the Copter-3.5 branch. During that process a break statement went missing and my understanding is that on the pixracer it would lead to the incorrect drivers being created or perhaps multiple drivers would be created. We had one report of issues calibrating the compass on the pixracer but I’m not sure we actually tracked the cause of that that issue back to this bug… I guess my point is that we found the missing break and fixed it but at least I’m not totally sure what bad behaviour would result and so it’s possible my description in the release notes is not perfect.



MANY thx for this very detailed info, much more detailed than I hoped for. THX.

1 Like

Awesome will be installing this on my pixracer to test, it seemed to have a very hard tome finding the compass/gps on previous release will let you know what I find out!!

1 Like

Maybe I just didn’t look hard enough but I didn’t see smart RTL on this release?

I successfully tested (at least first order testing on the bench) an external LIS3MDL on the best rc2 build…good readings on all axes.

Question: it appears that the external LIS3MDL reads correctly when mounted upside down (chip top facing the floor and with X and Y swapped (with compass orientation set to “none”…which I think? is the case for how an external compass based on the HMC5883 was treated?

Neo-M8U still not working :frowning:

Is there any hope that this release fixes known problem with Here GPS (90 deg wrong heading, sometimes)?

Re SmartRTL - no, i’m afraid it’s not included - it will go out with 3.6.


No, this won’t fix the occasional 90-deg issue with the Here GPS. I suffer from it as well some times especially if I quickly unplug and plug in one of my vehicles. The issue is really more hardware rather than software and so far we haven’t discovered a way to detect and somehow reboot the GPS/compass.

Randy, thank you for answer! Sorry if this is offtopic, but I am worried about this problem with Here GPS. Is it safe to use Here as secondary GPS, and NEO-M8N with HMC5883L compass (from Hobbyking) as primary GPS/compass?

Re mixing GPSs, in terms of GPS blending, there have been some reports that mixing Ublox GPSs works a-ok.

From a compass point of view, as long as there’s more than one compass enabled, the HERE GPSs 90-degree issue should be caught by the arming check. I agree it’s pretty annoying but like I mentioned above, personally I only see it when I quickly unplug and plug in a battery. If I leave it for 6+ seconds before plugging in the battery again I never see the problem.

1 Like

Autotune didn’t seem to be working on this release with pixracer, at least when you try and do each axis at at time instead of all at once, I will try and do all at once with some extra battery on board. I will look for some DF logs from my last flights.

I have recently added one of these to my pixracer build running AC 3.5.4 mRo GPS u-Blox Neo-M8N Dual Compass LIS3MDL+ IST8310. I can get the compasses all to calibrate fine but if I have all the compasses turned on I get prearm: compass inconsistencies, until I shut all but two of them off then I get bad compass health and it seems as thought in loiter or poshold mode the copter seems to wander like I do if I have had to much to drink, it gets the toilet bowl effect.