Copter 3.5.0 rc5 test and problem

flew 3.5.0 rc5 on 666 Quad using a Pixhawk 2.8 and f450 with a AUAV Pixracer. All flew well. in Stabilize, Althold, Loiter, Poshold, Circle and Missions with RTL. However there seems to be a problem with the Battery-used mah, Watts, and Amps reported in MP. (both current and latest Beta MP). I saw values jumping and I really don’t think I was using 1,275,750 Watts!! Voltage is reporting OK. Older 3.5.0 rc4 logs run OK in MP, so I think it may have something to do with the new rc5 and maybe it’s smart battery code?

Both quads flew great, even did a new Autotune on the Pixracer, with no issues with the flying.
Thanks for another great release.

1 Like

Ok, thanks for the report. It may be that the latest beta mission planner is required but in any case, we will look into this. We certainly made changes to the battery code as part of the smart battery improvements.
Thanks again!

LidarLitev3 value Always 0.05 on AC3.5.0-rc5
for distance greeter than 2 meter see some other values

Randy, Thanks2017-05-04 09-21-31.bin (1.0 MB)
for looking at this.

Today rechecked on Quad AUAV Pixracer, with latest MP 1.3.48 build 6332.13861, with same issues. ( Did both stable and Beta MP yesterday as well.)
Attached is a short flight from today ( Happy May the “‘Forth’ be with you”), battery not fully charged, but MP reporting correct Pack Voltage. Same as yesterday with both Pixhawk 2.4.8 and Pixracer flights.

Dataflash looks OK as to volts and current, but not TLog, (live or on replay,) in MP. Please look at the Battery cell voltages also as all are reporting a number of 65.535. I really think this is a MP math / wrong data point calculation problem.

Do I need to raise an issue with MP, Or can you do so? Is there some newer Beta MP I am not seeing through the “Check for Beta” in MP that I should use?

2017-05-04 09-20-48.tlog (216.4 KB)

1 Like

@rmackay9 @JoeBreznai Got same problem here with battery, the current jumps from 0A to 20A, sometimes 4020A, with firmware v3.5-rc5. And this problem happened in arduplane too. Have you solved it?

@Firefly- Using the latest BETA Mission Planner solved it.


1 Like

@JoeBreznai OK, thanks! I will have a try.