Copter 3.4rc1 RTL to rally point issue

I believe I have found an Issue with 3.4rc1. On two different flights (.bins below) I have had an abnormal RTL response. During the first flight below, shortly after takeoff, I realized that I did not start my gopro. After switching to RTL, the IRIS+ increased altitude well past the RTL altitude setting, breaching the fence before finally descending to land.

On second flight, at end of flight during loiter turns (that I meant to delete due to proximity to road) once again I switched to RTL. As with the first flight, the IRIS+ immediately ascended well past fence breach. I was watching on telemetry, thinking the fence breach should bring it down… NOPE. Fence set at 120m. Altitude increased to 120, breach noted via telemetry, then 130,140,150… Past 150 I switched to loiter and brought it down on my own.

On both flights the rtl alt was 65m, fence set at 120m, and there was a rally point between the IRIS+ and home location.

1st Flight

2nd Flight

Actually, 125 m fence alt, 55m RTL alt.

Hi @lifepac,

I’ve looked at your logs and found the issue. We are adding the RTL altitude to the rally point altitude instead of navigating at the rally altitude. I’ve opened a PR to fix it (

Thanks for testing!

What do you think about the fence breach, or specifically that the breach did not stop the ascent. Thanks for all your work here.

It is up to the controller to respect the fence. Because of this bug the RTL controller wasn’t respecting it, that’s why it breached. The fence action is to RTL, but you were already in RTL… If it had gone to more 100m than the fence (so 225m), it would have switched to Land.

@lifepac: Well not only 3.4 RC1 but as well in 3.3.3

  • The aircraft is different.
  • The version is different (you’re 3.4 rc1 and in this example 3.3.3
  • In this instance RTL (or trying to RTL) no rally point but from guided mode.

Same result: RTL shoot for the sky! :cold_sweat:

I did cancel the RTL as it was obviously not correct behaviour.

Something is really wrong somewhere!

Sorry you’re having troubles Henrik, but I think your issue is different and can be solved in your parameters. What is your RTL_ALT set at? Post a bin file for the most accurate analysis.

Thanks for answering.
the bin file seems too big and zipped is 1.56 MB stops at 60%

Without starting guided mode, instantiated by follow me, RTL worked fine at current altitude.


Your issue is an different version and certainly not related to this one. I saw that you have already opened a topic in the correct category so let’s not discuss your issue over here.

As Michael said it dint work with arducopter (but will work in next version) I wanted to know if Arducopter 3.4 rc-1 or future Arducopter 3.4 rc-2 will?

Thank you


@henrik04 I’ve merged your thread here. Rally points work in stable versions of ArduCopter. Copter 3.4-rc1 has a bug, identified in this thread, that will be solved for rc2 (still not in master).

Now I am confused.

Arducopter 3.3.3: RTL works fine and goes back to launch (Seems to ignore rally point 0 zero)

Michael_Oborne10h wrote:
rally points are not available on copter. I assume that’s what you re using. the next copter release should include rally points however.

I’m not sure why Michael said that but unless I’m confused with something it is supported:

Assuming the code in mission planner (1.3.38) is similar between moving base ( updating the home position for RTL and follow me)
My experience using RTL after using follow me:

  1. the aircraft (arducopter 3.3.3) start at an altitude of 180 meters. (relative zero)
  2. Follows accurately the “moving base”.
    • at that point in time the relative altitude is about 8 meters.
    • Parameters are: Return home at current altitude
  3. As the code apparently doesn’t look at this parameter, the aircraft altitude wants to jump up from current altitude plus absolute altitude which is not correct.

This is confirmed if you look at the two screen captures above in this thread.

Note: Using RTL without follow me works perfectly well.


@henrik04 I’m not going to discuss potential issues in 3.3.3, there won’t be any more releases for Copter 3.3, we are going for 3.4. What matters is if it works in 3.4 or not, and we know that in 3.4-rc1 there is a bug that we hope to fix in rc2.