Copter-3.4-rc6 available for beta testing

Copter-3.4-rc6 is now available for beta testing. It can be downloaded from or loaded through the Mission Planner’s Install Screen’s “Beta Firmwares” link.

The changes from the previous release candidate are in the ReleaseNotes.txt and copied below:
Changes from 3.4.0-rc5

  1. Object Avoidance with SF40c 360 lidar (wiki page coming soon)
  2. ACRO_Y_EXPO parameter allows exponential yaw in ACRO mode (slow yaw at mid stick but fast response at full stick)
  3. ACRO_THR_MID parameter allows custom mid throttle for ACRO mode
  4. Precision Landing reliability and accuracy improvements using mini EKF and adding IRLock lens distortion correction
  5. Bug fixes, minor improvements:
  • fix DSM binding on Pixracer
  • resolved position jump caused by EKF core change (also added logging and reporting to GCS)
  • EKF failsafe while in LAND triggers non-GPS LAND
  • small throttle jump removed when switching between AltHold, Loiter
  1. Safety:
  • EKF falls back to optical flow if GPS fails
  • pre-arm check that GPS configuration has completed

I think we are getting quite close to the final release but we still have at least these three issues to resolve:

If you see any issues, please report them in the Copter-3.4 section of the discourse server:

Thanks for testing!

Warning there are two known issues with -rc6 (these are already fixed in master and will be released in -rc7 by Oct 25th)

  1. Bebop2 motor order is wrong meaning they simply won’t fly (this doesn’t affect Pixhawks or any other frames)
  2. RC_CHANNELS_RAW are not being sent which upsets some OSDs

5 posts were split to a new topic: Can’t download ArduCopter beta firmware

Hello Randy,

Could you please verify the issue regarding random esc arming when using oneshot?
It doesn’t happen before 3.4rc2 version. I saw that you’ve closed the git issue #4789. The random arming could be related to this bug.

I’m using oneshot right now and it is pretty annoying to keep waiting for all motors to arm one by one. Do you think I should open an new git issue?


PixRacer compass - are there improvements?

I updated a 250 quad racer from APM micro to Hobbyking PixRacer with external Micro HKPilot GPS And Compass u-Blox NEO-6 and HMC5883. Running now 3.4-RC-6 MP 1.3.41

With RC4/5 there was the issue, that after a compass calibration in Mission Planner and disconnect power supply for some minutes, the FC could not arm in case of inconsistent compasses errors.It was only possible to fly with internal compass disabled and only the external compass enabled.

As soon as RC6 is out, I calibrated and activated all 3 compasses again. The Pixracer was connected many times within the last days without any inconsistent compasses error. (No test flight in case of rainy weather)

Additional information: compass calibration was made with “Live calibration” to get compasses working.
Which function has “onboard mag calibration”? - I cannot find a description (Additional information in Advanced Compass Setup would be great.).
When doing “onboard mag calibration” after “live calibration” there are also inconsistent compasses errors.

Are there improvements in RC6 that are not listed in release notes?


IRLock precision land code no longer seems to run when in RC6. I reverted to a previous working version to double check hardware, runs well. Seems like something about RC6 and IRLock (Precision Land) or about how it interprets parameters may have changed.

I am running a Pixracer with 3.4-rc6 and I am not getting any Frsky telemetry from the flight controller. I have soldered the “in” and “out” together and connected them along with the ground to the Frsky Telemetry port. I do get my lipo readings on my Taranis so I know that part is working.

No new sensors are discovered when searching though and it just shows the RSSI, SWR, Cels, RxBt. It is like there is nothing coming in from the FC. I checked all of my connections with an ohm meter and they are all good.

I’m not sure if this is a firmware thing or not.


Russ, did it ever work before? It’s best if you open a new thread with your question. I’ve been flying RC5 and RC6 with FrSky telemtry successful on a Pixhawk, but I don’t have a Pixracer so I can try it on, but I doubt it’s a firmware issue.

It’s not a firmware issue, it’s working fine for me. Configure Serial4_protocol for Frsky(4 for X-series) and Serial4_Baud for 57600. Then discover sensors on the Tx.

Dave, Thank you! That was exactly what I needed. Do you know where that information is kept online? I certainly missed it somewhere. Thanks again as it is working great now!


Russ, You have to make a deduction from the connector information provided here that states that Frsky telemetry is on Serial4:

I use Teensy’s on other craft to convert Mavlink to Frsky so have some experience with setting up the protocol in MP. Glad you got it working!!


Update: I see Leonorin has posted on another thread so removing my question here.

Re FrSky telemetry, I guess this wiki page is too out of date to be useful?

We can update it of course, I don’t use FrSky (I don’t think it’s legal here in Japan) so I just need some info on how we should improve the page.

You could add a Pixracer section to it I suppose. It supports Frsky protocol natively on serial4. So it’s essentially the same as configuring the Pixhawk but no additional hardware required. For X-series Rx’s:
Make the Rx and Tx lines common (tie them together) from the Frsky port on the FC and connect to the Sport of the Rx.
Set Frsky protocol in Mission Planner on serial4 (Serial4_protocol parameter)
Set baud rate for serial4 to 57600
Discover Sensors from the Tx and configure your telemetry screens as desired.
The data sent and the variable names are the same as shown on the current wiki page with the addition of A2 which on some X-series Rx’s is a general purpose 3.3V analog input.

Update: There is still the “inconsistent compasses” issue.
After some rainy days, get outdoors to fly the quad copter.
After powering the copter outdoors, no arming: “inconsistent compasses”. Disabled compass 2 an 3 in tower and could start.
Back indoors all 3 compasses can be activated and are consistent.

when there is always the same temperature as on the desk, compasses are consistent.
when there is a temperature change, compasses get inconsistent. Out: 14°C

PixRacer compass

Made some flights on week end with Emax 250-Nighthawk.

  • Improvement? With RC-5 it was only possible to fly with only external compass 1 activate, otherwise “inconsistent compasses” avoided arming. With RC-6 two compasses 1 an 3 are active and are working.

Mavlink Messages in OSD
MinimOSD Firmware minimosd-extra can display mavlink messages since version 890. That helps to know, why the copter will not arm - THXs to night-ghost who reactivated the dead minimosd project!

@ randy: err-24 ?
While reviewing datalogs, there was an err-24 message, what is a possible reason for this error? I noticed no problems during flight.

I use that minimosd, I’m getting mavlink messages about yaw realigned, EKF 1/2 switched to 2/1, some anomaly. When this happens, my copter’s level gets misaligned by a few degrees compared to stabilize center and starts drifting. If I ‘shake’ it enough this effect disappears.

I have another, with every 2nd startup, I get compass not calibrated. Then I calibrate, restart/take off (compass 3 is already disabled).
After changing the battery, i always have to re-calibrate.
Once I had the same with RC5, but I thought its was a one time problem.

Did you maybe saw these before?

I have a similar problem w/ pixracer compasses… I can never get it to arm with compass 3 enabled. It is calibrated and has better values than compass #2, but if it is enabled, I cannot arm. It says “compass not calibrated”. But it is calibrated, and all the fields have values, in the config. If I disable it, and re-enable it, I can arm w/ it enabled. But on bootup, it won’t arm w/ all 3 enabled.
I’ve tried it with a few different pixracers, and in a few different locations (in copters, out of copters, on my workbench, out in a field, etc).

Also, the Pixracer status indicator LED still doesn’t work. Any chance that will be included in 3.4?

I found some helpful discussion on github about pixracer compasses… If anyone else is having trouble, update MP to beta, and under “onboard mag cal” is a dropdown for “fitness”. Setting it to “relaxed” allowed the onboard cal to complete. (previously only the “live calibration” was working) . And after the onboard cal completed, I can now boot w/ all of the compasses enabled.

1 Like

I’m going to close this chat because AC3.4-rc7 is now available!

@wicked1, thanks! We’re planning to sort out the wiki’s compass page soon.