Can't download ArduCopter beta firmware

Using APM Planner 2.0.24 I cannot load the new FW. The key command is command Q for beta right? When I do that it crashes APM Planner?? Perhaps I’m doing it wrong??

NOTE: The reported version in this post is incorrect. APMP 2.0.24 does not have this issue @billb

And if I use an older version of APM P I can select beta… it gets to the point of asking my to unplug and re-plug in the usb to the pixhawk… it erases the board but then just sort of hangs … it never uploads the new FW. perhaps the new beta isn’t ready on APM P yet??

Happened to me few times. Keep the battery conected all the time and do all the steps without disconecting the battery.

Thanks but still no go. It’s almost like there’s nothing available for download. Perhaps Bill needs to update the server with the FW??? I tried 3 different cables too.

It’s get’s this far and stops

You have to use 2.0.24 or it won’t work as it won’t redirect to the mirror servers to download the fw

Can you post the text from the output window, it should be something like the following, notice the redirect line.

Started downloading redirect to Finished downloading /var/folders/v4/vb8p8rh92h999czdd512fp980000gn/T/APM Planner.k23124 Requesting Board ID Requesting Board Rev Requesting FW Size Requesting board Serial Number Erasing board Erase Complete Flashing Firmware Flashing complete, verifying firmware Verify successful, rebooting

That did the trick Bill thanks!! I forgot to look / get a screen dump of the output window sorry. But it definitely loaded 3.4 RC6 no problem using 2.0.24 :]