Copter-3.4.3 released!

Copter-3.4.3 has become the default official version deployed through the ground stations. There are a few important fixes vs 3.4.2 so we strongly recommend that people upgrade.

  1. Bug Fixes:
  • reduce unnecessary EKF core switching and fix position reset
  • attitude control does not limit rate if ATC_ACCEL_MAX is zero
  • ignore arm command from GCS if already armed
  • set land-complete to false during auto takeoff
  • onboard compass calibration memory init fix that could lead to failure to complete
  1. Minor Improvements:
  • LeddarOne driver robustness improvements
  • allow MOT_THR_MIX_MAX to be as high as 2.0
  • uavcan bus settle time increased to 2sec
  • helicopters do not hold position during auto takeoff until rotor is at full speed

For users upgrading from an earlier AC3.4.x release (i.e. AC3.4.0, AC3.4.1, AC3.4.2) there shouldn’t be any need to do any re-calibrate or gain modifications.

Thanks as always to our beta testers for putting this version through it’s paces ahead of the release!

1 Like

I have been trying to get this release, but with no success. In MP I have clicked BETA release, however, it reverts to V3.3.3

Hi Randy,
It was my fault, I had forgotten how to get the FW with MP. Now got it, and it now allows me to set up RSSI, which I have been struggling with.
Thank you for the great work.
Phil

100% working, no issues , just like the previous releases. Thanks!

I have tested 3.4.3 yesterday, it looks perfect!

Copter-3.4.3 changed some things for me.
When i arm my hex, the motors begin spinning.
No problem for because i set this to "0"
More serious is the fact that my throttle only needs to be at about 30% to get my hex hovering.
This was set in V 3.3.3 at 50%
Missing the throttle mid setting in Missionplanner?
Went back today to V3.3.3 and everthing was like before…

If that’s not a typo and you’re really coming from the 3.3 release, a lot has changed with the development of 3.4… Thr_Mid is totally different now. There are plenty of threads here about it if you search. You should look in to all the differences that have been made since 3.3.3!! There are a lot of them! It will certainly behave differently, and need to be configured differently in the 3.4 release, compared to 3.3.

Please can you point me a direction (site) where i can find more about this, because i don’t know where to start.
Thanks in advance :slight_smile:

Try Google:

Arducopter Release notes.

Thank you. :thumbsup:

For your specific question about hovering, there’s an active thread in the 3.4 section at the moment (should be one of the first things you see when you look at the 3.4 section), “Setting Mid throttle in 3.4. Where is the Mid Throttle Parameter?”
(And basically I’d bet you need to enable the hover learn parameters. And that would indicate you didn’t start over from scratch when you loaded 3.4… And I’d recommend starting over from scratch and re-configuring the copter… A lot changed, and it would be good to start from all the most recent default parameters)

You’re right, i did not start from scratch when i loaded the V3.4.3. :flushed:
Didn’t think it was necessary, because it never was in the past. :relaxed:
Thank you very much for your advice. :point_up:

Any changes to those using the coax copter frame? Would anybody be able to generate a build of this firmware for the coax copter?

Thanks

Joe,
I’ll create a coax firmware tomorrow based on AC3.4.3 or AC3.4.4-rc1 (which is about to go out).
You’re using a Pixhawk (or compatible) or a Pixracer probably?

By the way, I hope we can create the single & coax firmware by default for AC3.5 - the issue is just that we have a lot of boards and a lot of different firmwares so our build server takes a really long time which means it takes a long time for our automatic checks of various developers code is slow. We have some changes to improve performance though which should allow us to add the single + coax builds.

Thanks for responding and that is great to hear! I am using Holybros Pixhawk (takes V2 firmware), but I am also trying to use a 3DR Pixhawk Mini (Also V2). However, after uploading this firmware (That works on the holybro pixhawk) to the mini the Main LED stays a solid whitish/pinkish color and throws an error Check BRD_TYPE: no I3gd20 found in Qgc. If you could advise and provide the updated firmware build that would be awesome.

PS: I see it has been some time since progress was made on the coax frame so if you need/want any feedback on the current build (I am using the last posted build that was on the Coax Support Topic page) let me know.

Like the error says you have to configure the BRD_TYPE parameter to the correct board. Also, support for that board is only in master, not in the 3.4 releases.

Would you be able to advise me on where the BRD_TYPE parameter gets set and what it should be set to for the Pixhawk mini?

You may have to look at the full parameter list to find that parameter. For the values look at http://ardupilot.org/copter/docs/parameters.html#brd-type-board-type

Thanks. I found the parameter and changed it to 5 (Pixhawk Mini) and it just changes the error to Check BRD_TYPE: No MPU9250 found with the same solid pink light. Any other ideas?

I apologize for clogging this topic with this issue, but I do appreciate the help! I will wait for @rmackay9 to make a build and hopefully that will solve the issue.

Thanks!