Servers by jDrones

Copter-3.4.3-rc1 ready for beta testing

Copter-3.4.3-rc1 is available through the Ground Stations as a beta release. There are four important bug fixes (and 4 minor enhancements) as listed below. These can also be seen in the ReleaseNotes.

  1. Bug Fixes:
  • reduce unnecessary EKF core switching and fix position reset
  • attitude control does not limit rate if ATC_ACCEL_MAX is zero
  • ignore arm command from GCS if already armed
  • set land-complete to false during auto takeoff
  1. Minor Improvements:
  • LeddarOne driver robustness improvements
  • allow MOT_THR_MIX_MAX to be as high as 2.0
  • uavcan bus settle time increased to 2sec
  • helicopters do not hold position during auto takeoff until rotor is at full speed

If all goes well we will release this as the official default version in about a week.

Thanks in advance to anyone who can give this version a spin and confirm it’s working or not working well, thanks!

4 Likes

I have done my standard first impression test with my RJX520 Helicopter for testing out new things and that FW3.4.3-rc1. In Stabilize take-off, Hover = Alt Hold and Loiter. Moving the Heli in all directions. In Loiter several speedy pirouettes, and also RTL with full autoland. Total of 8 minutes. Absolutely no issues, Loiter better than ever. a bit windy but not bad. Thanks Randy for the great work.

AC3.4.2 Heli FW Guided mode automatically decrease the height without giving the change height command?

http://discuss.ardupilot.org/t/ac3-4-2-heli-fw-guided-mode-automatically-decrease-the-height-without-giving-the-change-height-command/13232

I used the Guided mode to test the T-rex500Pro’s three flight tests every time it was directed to a target, and it automatically lowered the altitude during the flight, knowing that it hit the ground. And this period did not change the height of Guided mode value!

This problem does not occur on the AC3.3.3 Heli FW!

3.4.3rc1 version FW is not aware of the existence of this bug?

Ok finally got a chance to do some quick testing here.

The LeddarOne seemed to perform fine at first…then I got a little bit of bobbing, but nothing major.

I was still getting the persistent “Bad Lidar Health” errors.

Everything seemed ok while moving. Hovering was a bit different thought. Seems a bit unstable to me for some reason.
I also noticed an Err 2202 in the log…haven’t had a chance to look.

The most concerning thing was the crazy RTL behavior. When you flip it, it spins about 90deg…then moves laterally about 5 or 10 ft. - really fast. Not at all behavior I feel safe using RTL with.
Now I haven’t looked fully into my setup, which is not any different other than hooking the Leddarone back in, and changing those settings. I also added a hall sensor I built, and calibrated that, but I believe that shouldn’t be causing anything like that.

Here’s the log, I’ll have another spin tomorrow when I have more light.

Thanks!

49.bin

Edit:
I let it go for a little bit on the second RTL try but when I realized I didn’t have any pitch or roll control I flipped RTL off again. It was also descending way too fast.

2016-12-05 16-38-30.zip (2.9 MB)

Hi @rmackay9@tridge

Just use my nano 450mm wheelbase OCTOROTOR brush into the corresponding 3.4.3rc1 firmware to test the Guided Mode, and Heli FW, the use of the boot mode to land the problem, I upload log, please Randy to see if the firmware problem

Using:

  • Untested Pixhawk (true blue not a clone)
  • Hyper tested: very small 550 mm quad / motors / M8N external Compass / 5 volts clean power to Pixhawk and GPS/compass / rfdesign telemetry.
  • Loading rc1 without problem on Pixhawk
  • Calibrating and compass “rock and roll”

17 sats hdop 0.55 on the laptop prior starting… Aircraft has been on the field for more than 10 minutes to get everything at the same temperature. 31 degrees Celsius (87.8 Fahrenheit)

  • trying stabilize for a while: Looks and feels ok.

  • trying Altitude hold: Seems a bit twitchy but ok…

  • Switch to loiter … “Bad move!”

  • Then everything became completely out of control.

  • Switch back to ALT hold… seems turning out of control…

  • Switch back to Stabilize but seems to have a mind of its own.

  • Compass seems to have lost its marble.

  • Hit land to try saving the aircraft. Lost altitude slowly while circling until crashing.

Looking at log: No vibration. but EKF_CHECK-2 red error…
replay TLog: Compass completely confused. BUT same compass worked without glitch for many many flights.

Need to fix the aircraft prior further testing :frowning:

Reply to myself…
After disabling the internal Pixhawk compass through mission planner, had a good flight this morning with the same aircraft and same configuration.
Back to base I tried the following:

  • Disabling the external compass and enabling only the internal Pixhawk compass to verify what is happening.

Gee!! looking at the mission planner “hud”, while aircraft is on the ground (not flying) the hud is moving like a watch handle, gently from north to south without stopping anywhere! So it really shows that this “real” Pixhawk has a serious problem.

Henri

The problem has been solved!

Thk @gblanco !

http://discuss.ardupilot.org/t/ac3-4-2-heli-fw-guided-mode-automatically-decrease-the-height-without-giving-the-change-height-command/13232

Lance,
Thanks for testing and reporting back. I had a look at your log and the leddar one data still looks quite bad. We see jumps of about 10m quite often. I’m unsure if this is a hardware problem or a software problem. I have asked the developer of the driver, Matsuura-san to have another look. I think maybe the only way to get to the bottom of this is for me to get a LeddarOne range finder myself to test it fully. Sorry for the troubles… I hate to say this but I think maybe you should get another range finder or turn it off until I can confirm the leddarone driver is ok.

Hi henrik04,
Thanks for the report, it’s very hard to look into the issue with log files I’m afraid.

That’s fine. Like I said…I’ve had this a year hoping I might be able to get it to work. After my failure trying to integrate it I just set it aside.

Work and weather have kept me from messing with it…but I’m going to try changing some of the hardware settings to see if anything stabilizes. I’m also not so sure this isn’t hardware and more specifically terrain change related (on the sensor itself).
I’m going to test that theory.
I’m emailing Leddartech, they’ve been super willing to help me with it. And we’ll see where that goes.
Maybe there’s a firmware update or something that might fix something.

I appreciate you guys messing with it. If I were in a better place financially I’d send you one. :slight_smile:

On a different note…do you think the strange RTL behavior is related to the rangefinder? I couldn’t see a correlation, and I’m still not sure what those errors are when I switch RTL on.

Lance

Thank you for testing and I apologize for the trouble. Im going to fly test again on weekend and feedback.

Henrik04,

I had the same problem and i was crazy looking for the problem… I discovered that little beeper near controller that i was using produced a magnetic field and internal compass did this, check if have something produces a magnetic field near the pixhawk controller.

Good luck :wink:

zubax can GPS still unable to detect compass, only gps signal.

1 Like

No apologies are necessary Shingo. I appreciate you guys working on it.

And I have zero issues testing this stuff…if I’m able to so far as the equipment.If there’s anything I can do let me know.

@rmackay9 ,
This might be the same thing that has been plaguing me since 3.3.3.
550 HEX on 3.4.3-rc1 - putting the throttle to 100% and pulling back within a split second, the motor output is so delayed they react after the throttle is back to 0%.

Detailed log attached

1 12-31-1999 6-04-08 PM.bin (878.9 KB)

@Lance_B,

I tested LeddarOne with Copter-3.4.3-rc1 this morning and flew very well. I sent log file to Randy.

S.Alt is red line.

I checked your 49.bin and compared S.Alt and flying path. I thought S.Alt jumps happen when vehicle flies over road. So I tested measuring distance using LeddarOne to a variety of target which are car body, car front glass, asphalt, wet asphalt, white line of road and grass. But LeddarOne could measure normally. :confused: There was no ‘Bad Lidar Health’.

I attached my LeddarOne device info that shows hardware and software version. Please compare to your LeddarOne.

Well that’s frustrating. Good…since it narrows it down to my setup…but frustrating nonetheless. Sorry I’ve wasted your time.
I even built a new cable using some shielded 22 awg. So it’s really starting to look like I have an issue with my sensor.
It’s odd though, if I take it off and connect it directly to the laptop, I get nothing like these kind of jumps in distance.

It seems to do this on mine when I just start moving, or when it’s hovering. It seems to be even worse over the grass. But I’m going to do a full on documented test to try to narrow it down farther.

So if you don’t mind, can you tell me what hardware setting you’re using on your Leddarone? To get 8hz, I think it’s either 2048 accumulations and 8 oversample - or 4096 accum and 4 oversample?
Are you using the smoothing algorithim?
15 sample points?
Manual intensity at 100%? or Auto?
Are you powering it through the Pixhawk or externally and, if so, which port?
What type of cabling are you using?

Also, can you tell me your exact settings on the FC under the Rangefinder setup?

Sorry for all the questions, but I’d like to match what you have and give it try that way.

Thanks again and sorry I feel like I’ve wasted a bunch of your time with it.

I checked mine and I actually have a newer board revision. The version,software,c r c are the same.

I’m waiting on a response from Leddartech…

Changed everything back to default and moved the unit to the accessory rail, and I’ll try this configuration tonight.

But if you get a chance please send me your setup config.

Thanks

Servers by jDrones