Copter-3.4.3-rc1 ready for beta testing

@Lance_B

Thanks comment. I will send my LeddarOne settings tomorrow. Could you send your LeddarOne settings? I will test using your settings.

@Lance_B

I attached my LeddarOne settings and Ardupilot settings screen captures.
I’m powering to LeddarOne through Pixhawk SERIAL4 and wiring using 30AWG.

LeddarOne and Ardupilot Settings.pdf (212.4 KB)

And I’m also considering what happens on your LeddarOne. ‘Bad LiDAR health’ occurs when there is no data while 200ms. It might take longer time to measure distance by diffuse reflection.I think it needs to resend data request when it takes longer time to get data than expected. I will add some fix to this problem.

Awesome thanks Shingo! If you need me to test it let me know.

Ok on the Leddarone, I’m using:
Accumulation 2048
Oversampling: 8
Points: 15
Smoothing: 0 at the moment, though I’ve tried it all the way to 16 with no noticeable change.
Led Control: Manual 100 - I’ve tried automatic and it seemed worse to me.
Baud Rate 115200
Modbus Address 1

On the Pixhawk I’m using:
Serial_1_Baud = 115
Serial_1_Protocol = 9
RNGFND_ADDR = 0
" FUNCTION = 0
" GAIN = .8
" GNDCLEAR = 11 (I’m about 4.5" to the PCB of the sensor, which is where they say the measurement is made)
" MAX_CM = 4000
" MIN_CM = 1
" OFFSET = 0
" PIN = -1
" PWERRNG = 0
’ RMETRIC = 0
" SCALING = 1 (HAVE TRIED THIS BOTH WAYS)
" SETTLE = 0
" STOP_PIN = -1
" TYPE = 12

I originally had it mounted on the right arm, about 17cm out from the center of the FC which is centered on top.

Frustrated last night, I reset my Pixhawk through Mission Planner. I also cut about 3" off the cable, re-terminated and resoldered all connections, and I’ve made a new accessory rail mount, which puts it squarely in the center, in front.

I’m using serial 4 for Open TX passthrough using a module I built. I have moved the Leddar to serial 2 though.
I’m going to get everything reset, and go give this a try using your settings on serial 2 and see what’s going on. If it still does it, I’ll reconfigure and move it to Serial 4. I’ll let you know.

One thing I noticed is I still had SR1 settings all set for the Teensy / Clooney telemetry - not sure if this would cause issues, and I couldn’t find the defaults which was part of my reason for resetting it.

I also spoke with LeddarTech today. Obviously they don’t know Arducopter. He did tell me that cable length for rx/tx with my wire size shouldn’t be the issue. He also said this isn’t a voltage issue - meaning they typically don’t cause this sort of behavior.

Thanks for the help Shingo.

@Lance_B

Thank yon for the information and sorry for reassembling your device.

I guess the problem is not by hardware from LeddarTech response, the surface type like grass and distance causes the problem.

Still not certain of that. They want me to connect it to the computer and log the readings over different surfaces using their software.

That’s fine but I’m not sure that at 6 or 10 feet this issue will even show up.
I need to figure out a way to do this at 20 or 40 ft or higher.

Maybe I’ll setup an arduino or teensy and mount it on the copter and try it that way.

I had a nice 10 minute fight last night over many different suraces and ranges of height and speed. I’ll post that logoes tonight.

@Lance_B

Thank you for testing. I will check your log.I think lt needs to retry to get new data before bad lidar health.

Here’s a nice long flight 2 nights ago using your settings, but on Serial 2. Lots of circles and hovering, landing etc. Over grass asphault concrete cars - rinse and repeat, different heights. Even looks like I hit it’s limit at these settings which was approximately 105’.
55.bin

Here’s one from last night, with yet again a different cable - just exhausting every possibility.
56.bin

I hooked it to my tablet, got up on a ladder where I could quickly change between 2 different types of surfaces and I cannot reproduce it when it’s hooked directly to the pc and the Leddar Configurator software, of course I couldn’t get much more than about 10 or 11 feet. But I get this on the copter at these heights.

Thanks Shingo. When you’re ready to quit beating the dead horse let me know :slight_smile:

@Lance_B

Thank you for testing. Im going to review your logs.

Hey Shingo…was wondering if you ever changed this, or if we’re done with it.

Been a busy last few weeks so I haven’t done much.

Gonna load the latest RC and start testing around.

Thanks.

Hey Shingo…was messing around last night after doing some re-wiring and cleaning up.
I have foil backed insulation on the walls in my garage. Holding the copter vertically I turned in a circle to test the readings shown on MP.

I managed to recreate the spike on a consistent basis. It happens as you move from a more diffuse surface, say black or brown and little reflectivity, to a highly reflective surface such as the foil. I could do this on a computer screen and TV screen as well.

I can’t get this to happen on the Leddar software, although I can see the change on the colored graph. It changes to an amber color instead of the green, but the reading remains consistent and accurate. So it may be a function of their noise or smoothing algorithms
.
I’m going to contact them about it, but I was wondering if it’s something you could maybe try as well?
I have to move kind of slowly from one surface to the next, and it seems to be a multiple of the actual distance, i.e. at 7ft, it jumps to 44ft. At 4ft it jumps to 30ft, or something to that effect.
I could make it happen more reliably at more than 7ft.

Thanks!

@lance_B

Thank you for testing and report. I checked your log file but I haven’t added any fix yet.

Your log’s distance was a multiple to actual distance. It is similar to your testing result.

I think it might need to ignore distance by amplitude value which is sent by LeddarOne.

However, I haven’t decided what is best way to manage this characteristic. At first, I am going to recreate the spike.

I think I agree lol.

I believe that’s what the Leddartech software is showing when it turns yellow on the graph. It just doesn’t show the spike in distance where the FC does.

Thanks Shingo

@Lance_B

Thank you for reply. I have tried recreating the spikde in distance this morning but I haven’t recreated yet.

I checked amplitude using Leddar confiurator app.(you can see amplitude from View -> Raw Detections) When the graph’s color changed to red, the apmlitude became over about 100.0.

Please let me know the amplitude that you could recreate the spike.

Could you introduce me LeddarOne person who you contacted? I will ask to give me some advice for improving ardupilot driver.

BTW. I talked about this issue with Randy. He asked LeddarTech to send LeddarOne for testing. So he will test too in near future.

Shingo

Well I’m glad Randy was able to get that answered. I asked them about it and never got an answer.
If they’re saying that Arducopter supports it, they need to make an effort to participate. And sending engineering samples out should be the first step.

Ok here’s the raw detection view. I’m getting something different than what you’re saying. When this happens, the second line pops up. Otherwise, it’s only the first line…which consistently reads correctly.

Here are pictures of the 2 specific locations in my garage that I can reproduce this consistently.

Pic1

Pic2

The first is in the general vicinity above the yellow package in the center of the pic…on top of that toolbox.
The second is to the left of the TV, and on the TV. If I sweep from the shelves, slowly, over to the TV, it happens every time.

The raw detections are made in the exact same areas.

I’ve been dealing with Alexandre Desjardins - alexandre.desjardins@leddartech.com

I’m going to email this to him as well. If you’d like me copy you PM me an email addy.
I’ll include this thread, and a link to the code as well.

Let me know if there’s anything else you need from me.

Thanks Shingo

@Lance_B

Thank you for replay. I guess the second raw data creates the spike. Before developing LeddarOne driver, I saw SDK samples that LeddarTech provides but I couldn’t find code that manages the second raw data.

I wonder the amplitude is very small. I don’t know it is normal. Please let me know If you got response from LeddarTech.

I am going try to receate the spike with similar your pics situation.

Thanks.

I agree with the 2nd line being the spike. And I’m not certain either.

I emailed him Monday I believe…but got his out of office response. He was supposed to be back today.

Of course, I did give him a lot of info…those pics, links to the code…links to this thread…maybe he’s pouring over it.

I’ll let you know as soon as I hear anything.

Hey Shingo…Update on this.

Jean-Francois Landry <jean-francois.landry @ leddartech.com> from Leddar support contacted me and asked me to record some sessions for him, and send the log files, which I did early this morning.

Hopefully we’ll get to the bottom of this soon.

@Lance_B

Thank you for update. I am sorry for I don’t have any update. I want to know what is the second raw data and how to manage the data to prevent from spiking.

Has there been any update or resolution on this? I’m trying to use a LEDDAR One for range finding and obstacle avoidance on my quad, but having issue getting it to work.

  • Ed