Copter-3.4.2 released

Copter-3.4.2 has been released and can be downloaded from the Mission Planner and other GCSs. Changes from 3.4.1 are listed below:

  1. Minor Improvements:
  • ACRO_Y_EXPO applies to all flight modes (but is defaulted to zero)
  • Autotune timeout increased (helps with large copters)
  • AltHold filter applied to P (was previously only for D)
  • arming check for compass health (was previously only a pre-arm check)

Thanks to our beta testers for putting this version through it’s paces over the past week or so.
2) Bug Fixes:

  • compass calibration (onboard) fix to return completion status
  • LeddarOne driver busy-wait fix
  • SBF GPS altitude and accuracy reporting fix
  • MAV GPS uses existing configured baud rate instead of auto detecting

WARNING #1: An issue has been found in the EKF “lane switching” code (responsible for deciding which EKF to use) which means that switches can happen unnecessarily and too often leading to sudden jerks in position. A fix is included in AC3.4.3-rc1 but until then, if you notice problem you can disable lane switching by setting EK2_IMU_MASK to 1.

WARNING #2: We have seen severe spikes in LeddarOne ranges in AC3.4.2. We recommend against using the LeddarOne until AC3.4.3 is released which includes robustness improvements.

WARNING #3: Your vehicle may turn off it’s motors for 2 seconds (and crash) if you send an “ARM” command to the vehicle from the Ground Station while the vehicle is flying. Most GCSs do not allow this and a fix is included in the next beta AC3.4.3-rc1

WARNING #4: You vehicle may falsely detect a landing (and crash) in AUTO mode if your vehicle is very powerful (i.e. hovers at less than 20% throttle) and the MOT_THST_HOVER parameter is set too high. Normal learning of hover throttle makes this unlikely but we’ve had one report of this. This is fixed in AC3.4.3-rc1.

1 Like

hi, I want to know if the version 3.4.2 I can upload it to VR BRAIN 5.2. THANK YOU

Hi Giovanni,

Although you can build 3.4.2 for VR Brain boards we don’t do it in the automated process right now. Virtual Robotix do their own builds and make them available in Mission Planner but I’m not sure how updated that is.

Tested 3.4.2 with:
Mission: (Using mission planner 1.3.41 on an old laptop that my daughter discarded long time ago tagged as a “brick!” running windows 7! :slight_smile: )

  • Auto takeoff to 25 meters. (Just vertical take off.)
  • 21 Way points with various altitudes and change of speed in between waypoints.
  • RTL (with altitude 0 in parameters) landed perfectly the quad and as expected the landing detector worked a treat and shut down the motors. Landed 18 cm from take off point.
    17 sats and 1.1 hdop prior starting the mission was shown on the laptop,


  • This was done on a very small home made quad. (550 mm {21.6 inches} in between motors) Pixhawk using linear external 5 volts LDO voltage regulator (no electrical noise feeding the Pixhawk.) Of course a separate small 2S battery to feed the voltage regulator.
  • Main battery telemetry cell by cell survey by Quanum. on 2,4 GHz.
  • Diversity modem telemetry by Rfdesign 900+ on 835 to 910 MHz
  • M8N GPS using an economical “on sale” gps: TRIPLE BAND RECEIVER EMI PROTECTION +HMC5983
  • FrSky Taranis transmitter and FrSky Rx6 binded on D16 limited to 12 channel on 2.4GHz.

Needed to be done: Auto tune… (Still waiting for “no wind” )

@henrik04, great, good that it’s working well so far.

Finally got my rig back up. Loaded this build up. Still constant BAD LIDAR HEALTH and altitude descrepancy between Rangefinder and FC (in this case LeddarONE, does the same with my other rig with Lightware SF11).

When landing complete, MP hud shows negative height and rangefinder reads correctly.

I’ve uploaded a good selection of logs on both last Saturday in a different thread. I’ll try to find it to link.

Lance_B, ok great, the dataflash logs should help once you find them.
A negative height on the HUD likely isn’t a problem because it’s most likely just baro drift which can go up or down.


I have tested the AC3.4.2 helicopter firmware, report here: RCHeli T-Rex500 ArduPilot AC3.4.2FW Maiden Flight

I agree…sorry I’m horrible about not making my point.

I think the discrepancy is what it throwing out the constant Lidar Health messages. It’s not something
that happened prior to the 3.4.2 RC2 build - the differences in height or the bad lidar health error.

I’m going to go fly in my typical place here shortly so I don’t have to worry about any possible interference in front of my house.
I’ll post that log afterward. The one from last night wasn’t long enough and was pretty out of control since I hadn’t tuned anything.

I posted logs in these 2 threads - I know these aren’t the 3.4.2 release, but they have the issue:
3.4.2 rc 2 and 3.5 Sensor Update - issue with 2 copters with rangefinder
Sensor Update Build with Crash log - this one crashed.


Performed all Accel, Level and Compass calibrations and they worked perfectly, quickly, and reported completions.
There was a weird lag before when doing the accel, and pressing a key to go to the next position wouldn’t work most times. This is definitely fixed.


I would Like to report a bug in arducopter 4.2.1 version.
When using auto flight, the command do digicam control doesn´t work.
I test it going back again to ac 3.3.3 and it works ok.

Hi Alberto,

I guess you mean version 3.4.2? Please read Randy found out it is an issue with Mission Planner. That is already fixed in master, so if get Mission Planner beta version you should get the fix - you’ll have to re-upload your mission then.

Yes you are right, I used ac 3.4.1 I´ll read about the mission planner beta and the 3.4.2 firm.

I am getting some weird motor start ups on 3.4.2 with a pixhawk and DJI1000+ frame. Sometimes on take off the motors pulse and it will want to rotate to the left a bit… maybe 15 degrees. It does not happen all the time and once I throttle up goes away so I have just been taking off very quickly. I have tried to recall all sensors and compass and I think the motor parameters are correct. Never had this issue on any other version. I can post logs later if needed but just looking for some advice on what to check.

We found an issue with the yaw-reset code which would explain a 15degree turn upon take-off. I was wondering if you could re-test with AC3.4.3-rc1 which should be available for beta testing within 6hrs or so. You’ll need to click on the “Beta firmwares” link assuming you’re using the mission planner. Other GCSs will allow you to load the beta version as well but I’m slightly less sure on what exact buttons to click to allow that.

I have been flying quad and hexacopter with 3.3.3 firmware.I am considering installing copter 3.4.2
and want to know if I have to recalibrate compass and accel?

Thanks rmackay9. I will try this as soon as I can. Probably in a few days. We are using the Uav for surveying the next few days but will try to get videos and logs with the old and new firmware. Thanks again too all of the ardupilot team for their work and support!!!

@servoman1 No, you shouldn’t have to. If anything needs to be recalibrated you should get a pre-arm message, so be sure to have your pre-arm checks turned on (they are on by default, but some users, unfortunately, turn them off).

Thanks for the reply Francisco.
I never turn off. Can’t wait to install tomorrow.