Servers by jDrones

Controversy --- does the AT (v1.1) project work

HI Greg, Pete,

Good news. After I managed to set the tracker “Home” and continued more testing, the tracker started to pitch

when I put the quad in “Circle” mode in SITL. Pls find attached the param values of my setting which works.

Greg, some questions on SITL. You once suggested me to put the vehicle in LOITER mode in a large circle to test both yaw and pitch.

  1. Could you tell me how to do this in MP ?

  2. Also when I put the quad in CIRCLE mode, it only circles 2 times and then crashes and disarm. Why ?

  3. When I land the vehicle, the altitude decreases. Why did the tracker not pitch ?

  4. When I disconnected the GPS from the tracker, the tracker also yaws. What role does the GPS play ?

There are more tuning to do. Will do field testing later as weather permits.

Thanks for all your and Pete’s help so far.

Frankie

Param__pitching works.param (8.45 KB)

The trick came from Rolf in post #4 of my mini AAT thread here. You use a quadplane in SITL and load a simple 3 step mission to get started. Simply set AUTO mode and ARM, then use the GUIDED mode Fly to Here with a right mouse click. The QP will loiter at the WP or you can set LOITER mode and change the radius as shown below.

I’m not sure about your other questions…

Hi Pete,

In my last message to you and Greg, I told the good news that my tracker started to pitch, but further testing shows

the tracker pitches back and forth, as shown in the video with link below.

You asked the log in earlier message. I don’t have the log available as I found out the SD card slot of my tracker controller
(Pixhack, same as Pixhawk)
is probably damaged, and I can’t insert the card. I will figure out what to do to get the log for analysis.

I resend the param file of my current setting to see if you can figure out why the tracker pitches back and forth.

Another point which puzzles me : 10 seconds after start of the video, the tracker sudden beeps, and the green LED turns from solid to blinking, meaning disarmed.
Even though it disarm, the tracker still pitches and yaws.
This disarming started to happen 2 days ago. I swear I did not change any param value. It just happened by itself, and is repeating everytime several seconds after I press the safety switch to arm.

But wiki says "
Flashing green: Disarmed (ready to arm), GPS lock acquired. Quick
double tone when disarming from the armed state."

And if you turn on the loudspeaker, you only hear one short beep at 10 second, instead of “Quick double tone”. Do you have any clue ?

https://drive.google.com/file/d/19QocGca6jTSlhjPJb5kKM_YlzW1yUDef/view?usp=sharing

Greg, thank you for advice on putting the QP in loiter mode. One point I am curious, does disconnecting the GPS from the tracker disable

the tracker ? Also does it make any difference to tracking with GPS 3D fix and without 3D fix ? It seems the tracker still moves even I disconnect the GPS from tracker.

Thank you for your help.

Frankie

Param__pitching works.param (8.45 KB)

The telemetry lost and found sounds used to be these. I can’t remember if this has changed.

  • Telemetry Lost = 1 short beep (like your video)
  • Telemetry Found = 1 long beep

I would expect it to disable the tracker but it may be an untested corner case.

Again, I would expect the tracker to stop or go into scan mode. It’s probably another untested use case.

Thank you Greg.

In the video of your
first tracker, where did you buy the white rectangular patch antenna
mounted on the other side of the controller ? Could you give me the
details? My DIY yagi is not portable compared to yours.

Since you have
experience building 2 trackers, did you encounter violent twisting
(yawing left to right, and right to left quickly and in small
angle) as soon as the safety switch is pressed ? This annoys me very
much and happens 5-6 out of 10 times, and I have to unplug the power
immediately to stop it. Could it be due to certain direction I fly
the vehicle in guided mode relative to the heading of the tracker, or
reflection of radio wave indoor ? Pls share your experience.

In your last reply,
what is the meaning of “untested corner case” ?

I put the tracker on a
tripod just 1 meter away from the laptop which runs SITL. The minimum
distance I set to track is 4 meter. Is this setting irrelevant while
running SITL ?

There is no quadplane
in 'Simulation” page. Do you mean multitotor which I have been
using all the time for SITL testing ?

Still figuring out why the tracker disarm shortly after arming and safety switch pressed. Disarming is followed by the green LED of telemetry radio starts blinking (solid green means radio link established). Any clue ?

Thank you,.

Both of my AATs use the ImmersionRC (IRC) SpiroNET 5.8GHz 13dbi LZR Patch Antenna. It is sold in many places and has come way down over the years so I picked one up at ReadyMadeRC.com in the U.S. for $25. Just do a Google search for it.

This may be due to your YAW_RANGE setting. Mine is set to 180 since I will never fly behind myself…only 1/2 of a circle or 180 degrees.

The minimum distance to track is from the AAT GPS position and vehicle GPS position, not the laptop location. A setting of 4m is too close for real operation. Use the default 15m or longer. I use a dual receiver so that the omni-directional antenna can be used if the directional patch antenna is in error when the plane is too close and travels across the field to fast. This can occur on a normal AMA flying field.

Select “quadplane” in the Model pull-down menu. See the image below.

Use the settings below on the SiK radios. Ignore frequency boxes if you are using 915MHz.

Hi Greg,

Thank you for your continued support.

Before solving one problem, another problem appears…that the telem radio link dropped continuously everytime

during testing. I have changed to your setting on the telem radio and tried, but did not fix the problem. In fact, my original setting was working perfect consistently before this happened.

I just posted this problem in greater details in a new thread in Antenna Tracker, hoping someone with similar problem can share the experience.

Frankie,

I would make sure that both air and ground modules have the same settings and are not too close together. If they still do not work properly, swap out the module, one at a time, with a different set, if you have one.

On both my AATs, I use 915MHz for the vehicle telemetry link and 433MHz telemetry for the GCS telemetry link. This dual-band operation seems to work well.

Hi Greg,

During SITL testing, I only use 1 pair telem module…one connected to the tracker controller (Pixhack),

the other to the laptop. So interference is not a problem. Though I have another pair (set to different Net ID),

for simplicity in SITL testing, they will only be used during field testing for vehicle telemetry. Both pair are 915Mhz

which the local regulation requires.

I have swapped another pair, also in SITL mode, but still did not fix the trouble.

The telem link drops out when 1 pair is used in SITL. This pair has exactly the same setting on each module,

otherwise it would not have worked for couple of months without link drop out until recently. I would try using

vehicle telem next time when I am out at the field.

Thank you.

Hi Greg,

I finally solved the problem of telemetry dropping. The reason of dropping is on the power supply to the Pixhack FC. To power the 2 servos, I have 5 V connected to the output of the FC. This also powers the FC, so I do not provide separate power for the FC. As soon as the tracker starts to track, more often than not, the telemetry drops. I now provide another 5V to the FC and no more telem dropping. Now I can continue with field testing later.

One question :-- The tracker starts to track even though the GPS on the tracker is not 3d fixed (blinking green light). I thought the tracker has to know what coordinates it is located, and track according to the position of air borne vehicle based on the difference in the coordinates between the vehicle and the tracker location. Seems this is not the case if it starts to tracke before 3d fix.
What is your opinion ? Thanks
Frankie

Hi Greg,

I finally get the tracker working, at least it tracks the vehicle, but not accurately. It lags in position in both pitching and yawing. See my latest thread posted yesterday with heading “Tracker lags in psotion in both pitching and yawing”

Could you share your experience to trouble shoot this problem ?

Thanks very much.

Maybe I can help a bit. I’m using the AT for many years already, without a problem. But we also had our startup issues.

First of all, check your PID settings. By finding the right settings, the AT becomes quite crisp.

Secondly, it depends on how far off the lag is. Mine is always a few degrees wrong, but I don’t care too much. The antenna itself has a 3db opening angle of about 10 degrees, so a few degrees to the left or right, or up or down, don’t worry me.

We can reach 25km on a 2.4ghz, 1 Watt transceiver. On the AT we have a flat panel antenna with 13db gain and on the aircraft a simple dipole with 5 dB gain.

Of course line of sight.

1 Like

Thank you. I have tried using other people’s successful PID, and I know these are for reference only.

Every installation may be different.However, they don’t work, in fact, getting even worse.

I will try other PID settings, by trial and error.

Servers by jDrones