Controlling TBS VTx power with Smart Audio

How do I set the ports and protocols?
I use the Crossfire transmitter and receiver.
There should be the ability to control the power of the video transmitter through the “TBS Agent”.
I connected the Smart Audio line to the Tx4.
I do not know how to configure the port or protocol in mission planner. I read somewhere that the port should be set as “pass through”, so the comands will pass through the Uart from the RC receiver to the VTx. Also to set it as a half duplex?! But without success.
BTW, the telemetry pass through the Crossfire connected in Tx6 & Rx6, works and I see the data through Yaapu.

If you are using CRSF you are better off connecting the VTX to the other pins of your RX and using CRSF to control it. Then it will show up in the TBS agent.

1 Like


I suspect you’ve already seen the VTX wiki page but just in case…

It seems to me that you are right. While this requires disassembling the system and soldering the smart audio line, it might be a simpler solution. Attaches a picture of the receiver. Do you have any idea where to connect the smart audio? Thank you, Itzik

Hi, yes of course. I was trying to follow the instructions, I probably missed something. During the attempts I lost conection with the receiver, probably a conflict in the settings.
I will try again.

Here is an example of a working setup. The VTX and RX are designed to be stacked:

So in this setup you would connect the UART to Ch1/2 and the VTX to Ch3/4

Hi thanks,
Since this is one-line communication, I guess I need to connect to either channel 3 or 4. Where do I set in the transmitter to which channel I connected the smart audio?

No, CRSF is full duplex you need to connect both pins and select CRSF as the protocol in your VTX

1 Like

Sorry but I probably could not explain myself correctly because of the language gap. The receiver is connected to the FC on two Tx6 / Rx6 lines using FD CRSF protocol. From the VTx only one wire (Audio) comes out and it is currently connected to the FC’s Tx4. Following your suggestion, how can I connect the VTx directly to the receiver?

What VTX do you have?

You should be able to do single wire Smart Audio from the RX to the VTX.

From the TBS Unify instructions:

1 Like

Yes, but I’m pretty sure that controlling the VTX via the flight controller is no longer possible if that’s what you want. CRSF repeats commands it does not process and so with CRSF the FC sees all of the VTX traffic, whereas with SmartAudio I’m pretty sure it won’t (although I could be wrong - be interesting to know).

This is the one:

Looks like it doesn’t support CRSF - you will need to use the wiring @Allister showed.

1 Like

Yes I realized that this is probably the way. I’ll try to connect tonight and see.

1 Like

I was able to connect to the video transmitter through the receiver. FYI, SA can only be selected on channel 4. Succeeds in changing channel and power through TBS agent.
Unable to connect the power selection to one of the switches.
Thanks for the help.

I guess to connect the power selection to a switch I think you would need to go through the flight controller then.

In regards to the Wiki ( I can’t see an option for SERIALX_PROTOCOL 37. I get up to 31 but I have manually typed it in anyway.

I also can’t enable set OSD5_ENABLE and OSD6_ENABLE = 1. That option is not available in the paremeter tree. I have set VTX_Enable=1.

I believe the first issue is whats causing my to not have VTx control as the OSD changes power via my switch settings but the VTx physically does not. I have used half duplex and also tried turning on Option (TX_PullDown) to be 68.

Firmware: 4.1
Kakute F7 AIO V1.5
VTx: Rush Ultimate Plus SA2.1

Apex Ardu.param (20.0 KB)

What have I missed??

Update mission planner to the beta version then you will see the new parameters

And onto my next problem…

I don’t think I have SA working as I can’t change power settings. The OSD displays VTx Power changes correctly but the LED indicators on the VTx don’t change.

I’m now trying this on a Kakute F7 Mini V2
Altal Micro V1.1 with SA2.0

The OSD pages don’t come up in MP but they are enabled. I’ve read that the beta builds are buggy and I will keep updating daily.


VTx Parameters.param (24.8 KB)