Constant beeps while trying to arm. Can't arm the airplane

When I try to arm my aircraft I get beeps like this: Motor continuously beeping and unable to arm - YouTube (not my video)

I feel like it’s an issue with speed regulator, but I couldn’t fix it, I tried calibrating, but feels like it just won’t let me

Hardware Used:
– FC Matek F-765WSE
– Speed Reg HobbyWing Platinum 60A

The beeps can be from the end points loosing information. remove the props and calibrate the radio, check your Dshot settings and power cycle.

I calibrated the radio in mission planner, how do I check my Dshot settings?

Try the Radio cal again then reboot. when the inputs are right the esc will beep twice.

I try to start radio cal by connecting battery power while transmitter throttle at max, but it doesn’t react. Just continues beeping

Ah that’s old school… If you have dshot go to the parameters page and select Dshot 150 save and power off and on make sure your props are off. then one more radio cal to be sure.

looking at HobbyWing Platinum 60A I don’t think they are dshot. Bummer.

How do I figure out if I have Dshot or not?

The funny thing is that everything worked last time and I didn’t change nothing, except moved the airplane to another country

How do I figure out if I have Dshot or not?

looking at HobbyWing Platinum 60A I don’t think they are dshot. Bummer.

1 Like

Is there any way if not using a Dshot?

Last time in plane i could not get the radio calibration/esc work with non dshot esc’s. if you have an extra Dshot esc you could try it. Or manually input the endpoints.

Another drone operator had recently issues arming because the throttle trim setting had been changed.(on the radio) - Perhaps check those quickly just to make sure it’s not something simple like that.

trims subtrims checked neutral

Don’t have dshot esc’s unfortunately. Can you give a clue how to input endpoints manually?


My ESC’s cheatsheet states that I have to calibrate it at first start, but I think I’ve done that before, and I even spun the motor before, but now, when ESC is no longer connected directly to a motor, but rather a Flight Controller, it stopped working. And seems like I can’t calibrate it while it’s connected to a FC and I really don’t want to reconnect the ESC straight to the motor.

Why are you worried about connecting to motors?
As long as you don’t have props on there is no problem.
The other thing you can do is using a 12V power supply, like an old style phone charger or router power plug, cordless tool charger,…as long as it is 12DC regulated. In that way there isn’t enough electrical current available to really power up a motor to full speed. (Unless its a small motor).
…but once again, without prop no problem.

I didn’t mean that connecting to a motor was a safety concern. I just said that when I connected ESC directly to a motor before – it worked. Now when my ESC is connected to a FC which is then connected to a motor – it doesn’t work.

Sorry, misunderstanding.