Servers by jDrones

Connection issue (between raspberry pi and Flight Controller) when using APSync

pixhawk
apsync
companioncomputer

(Gian Scala) #1

Hi,

When trying to connect flight controller to raspberry pi 3 I am facing following issues. I have posted a part of this issue as a thread in another topic but did not receive any response. Hence creating a new topic with detailed explanation and hoping to get help :wink:

I am using http://ardupilot.org/dev/docs/raspberry-pi-via-mavlink.html as my reference. I choose to use APSync and not Raspbian OS. I am able to connect to raspberry pi via wifi access point created by rpi3. I am also able to ssh with 10.0.1.128

The problems start from here:

  1. I added “dtoverlay=pi3-disable-bt” to config.txt to disable Bluetooth and am using /dev/ttyAMA0 port for communication. When I do this and try
  • sudo -s
  • mavproxy.py --master=/dev/ttyAMA0 --baudrate 57600 --aircraft MyCopter
    the raspi 3 is receiving heartbeats from flight controller but none of the commands (like ‘arm throttle’ or ‘param show ARMIN_CHECK’) are working. I get nothing in reply when I try these commands. I think raspi 3 is receiving data from flight controller but flight controller is not receiving anything from raspi3. I have also tried with different baud rates but only with 57600 I am able to receive heartbeats.

2)When I do not disable Bluetooth and use serial port “/dev/ttyS0”, I either start receiving some garbage or exception saying “SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)”

I hope I am more clear in my explanation here. Please recommend some solutions and possibly the reason why is it behaving in such a manner.

Thanks in advance.


(peterbarker) #2

There are other things listening on that serial port.

Start mavproxy like this:

mavproxy.py --master :14550


(Gian Scala) #3

Hi Peter,

Thanks.
when I try like this
mavproxy.py --master :14550 --baudrate 921600 --aircraft MyCopter

I still get no heartbeats. Whats going wrong? Thanks