Connecting to a Mac

I’m trying to connect my Mac (V10.9.5 Mavericks) to APM Planner v2.0.18
I’ve downloaded the drivers per instructions. I also tried to decipher the ftdi pdf.
I do not understand the code on the terminal app. It does not seem to be responding as advertised.
I think the main problem is the “Serial Link” that I should be using is not listed. I’m pretty sure its a driver issue but I can’t figure out how to resolve it.

I’ve been searching online and youtube for info. Any help is very appreciated.


what Autopilot are you using?

Its the Pixhawk i believe in a 3DR Iris+

Try the solution below

Last login: Thu Aug 20 13:18:02 on console
AGP-MB:~ HobiePilot$ cd /System/Library/Extensions/IOUSBFamily.kext/Contents/Plugins
AGP-MB:Plugins HobiePilot$ sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled

WARNING: Improper use of the sudo command could lead to data loss
or the deletion of important system files. Please double-check your
typing when using sudo. Type “man sudo” for more information.

To proceed, enter your password, or type Ctrl-C to abort.

AGP-MB:Plugins HobiePilot$ sudo touch /System/Library/Extensions
AGP-MB:Plugins HobiePilot$ xxxxxxxx
-bash: xxxxxxxx: command not found
AGP-MB:Plugins HobiePilot$ sudo mv AppleUSBFTDI.kext AppleUSBFTDI.disabled
mv: rename AppleUSBFTDI.kext to AppleUSBFTDI.disabled/AppleUSBFTDI.kext: No such file or directory
AGP-MB:Plugins HobiePilot$ sudo touch /System/Library/Extensions
AGP-MB:Plugins HobiePilot$

This is how it came out. I initially put in my password where it said and nothing filled in at all. I still hit return and nothing happened so I input the 2nd line again. This time it did not ask for a password. Not sure if that worked but it did something, so I did that last line and that one does not look like it worked. I have not rebooted yet…

Does it look right??

The first time you entered the commands the correct thing happened, reboot should now disable the Apple FTDI USB driver and use the one from FTDI.

Try rebooting

BTW, Thanks for your time Bill!!

So now Im rebooted. I tried re-reading that FTDIchip pdf. Still lost. Do I reinstall the VCP and D2XX drivers again?

you will need to install the FTDI drivers as supplied with the APM Planner 2.0 .dmg file


I’m confused (it easily done). If you are having an issue with the Pixhawk via USB. It should show up cu.usbmodem1 you can confirm this by typing in the Terminal application

THE FTDI driver problem is usually related to connecting via the telemetry radios. This require the baud to be set to 57600. the device is usbserial-XXXXX e.g.

bonney@slimvan:~$ ls /dev/cu.*
/dev/cu.Bluetooth-Incoming-Port	/dev/cu.BumbleBee-WirelessiAP	/dev/cu.RNBT-5F8E-RNI-SPP
/dev/cu.Bluetooth-Modem		/dev/cu.HC-05-DevB		/dev/cu.usbserial-DN0019M3

I have:
AGP-MB:~ HobiePilot$ ls /dev/cu.*
/dev/cu.BillsiPhone-WirelessiAP /dev/cu.Bluetooth-Modem
/dev/cu.Bluetooth-Incoming-Port /dev/cu.usbserial-00001014

I attached a screen shot. Seems that no telemetry coming in.

Here is a better pic, did not notice all telemetry not visible. the mode is in red and just says “Mode”

How are you connecting USB or 3DR Telemetry radio?

I believe the Telemetry radio but the antenna is plugged in to the usb which is confusing

can you show me the entry in System Information App.

Yes but how do i get there?


like this, select USB then the device in right hand pane

Here it is

Is the light solid green? That means it is connected to the Telemetry Radio on the Iris+

Can you connect APM Planner 2.0 if you plug the USB cable into the side of the Iris+?

No it was blinking.

I did not know I could do that. It is now connected directly to the Iris now. It immediately powered up with the ok sound (forget tech term) but is normal sound.

I looked the APM Planner app and it would not even try to connect this way.