Servers by jDrones

Connect to new pix 2.4.8 without a receiver


(David Rechler) #1

Hi all, I’m new here (as I am with pixhawlk). Trying to make my new, no-RC, quadcopter.
I took a brand new Pixhawlk out of the box, inserted the sd card, connected the GPS, button and buzzer, did not connect a receiver as I plan to fly the drone “autonomously”.
When connecting for the first time to the pc / Mission Planner :slight_smile:

  1. Seems like Com port is not detected (pix does not appear on any com)
  2. All LED’s are on (some steady others are blinking)
  3. Buzzer is sounding it’s sharp beeps non stop (repeated three at a time)

Is this because I did not connect a receiver? is it something else? how do I setup with no receiver?

Thanks in advance!


(David Rechler) #2

Hi all (again), found the answer in another place and seems like it works! the trick was to try another USB cable, all good and I’m advancing.


(David ) #3

Good day, you must set these parameters:

  • THR_FAILSAFE=0 to disable the RC failsafe
  • STICK_MIXING=0 to disable RC stick mixing in AUTO mode.
  • FLTMODE_CH=0 to disable flight mode change by RC channel
  • INITIAL_MODE=N where N is mode number you want to start in
    You will be able to fly in the following modes:
  • AUTO
  • GUIDED
  • LOITER
  • RTL

Just check also the arm parameters check.
Just test test before fly…


(Peter Hall) #4

or you could use a joystick functionality in mission planner, the joystick will then show up as if its a receiver. And you won’t have to change parameters as above, everything works as normal.


(David Rechler) #5

Thanks Dave, I’ll try.


(David Rechler) #6

Hi Peter,
The Joystick is a nice idea but misses the point of autonomous flight… joystick or RC system, both need a man in the loop. Thanks anyway, this can be an initial stage for mechanics and hardware tests.


(Peter Hall) #7

i would certainty recommend you use a RC system or joystick for testing, things can go quite badly wrong before you have a chance to click anything on a ground station. Better to get it working nice using RC first then once its working well in auto modes you can go to control completely via ground control.


(ppoirier) #8

I strongly disagree, building an autonomous system requires a method to override, this is standard engineering and safety practice.


(jS) #9

… I concure!
I should always have a plan B and plan C

Even when “failure is not an option”!

recomend rc sys then joystick

unless you like rebuilding things a lot


(David ) #10

I can advice you set also a rc just in case of emergency…


(David Rechler) #11

Thanks all, you are naturally right so I will follow your advice and use a joystick/rc for platform tests and verification however the final product has to be 100% autonomous. It will not be the first time. Check out a company called “zipline”, heard their CEO recently, he guaranteed you will not find a single joystick/RC in their company. Waypoints are loaded to the plane and off it goes.


(ppoirier) #12

If you intend to build and fly a fully redundant system with a patented onboard finite state machine for receiving commands using resilient communication links and in coordination with Rwanda airspace , my answer is a definitive yes ;-).


(David Rechler) #13

Hi dave,
Looking at the MP full parameters list I can’t find 3 out of the below 4 parameters. Only FLTMODE_CH was found…

Any idea? Wrong menu?

  • motors test via MP - It is written that motors are tested clockwise, mine rotated CCW during testing. Please advise… (switch a pair out of the 3 on all motors?)

Thanks

David


(David ) #14

good day, i need know your settings so i can test it


(Dave) #15

What 3 out of 4 parameters?

Sure, revers 2 motor leads or it can be done in firmware from the BLHeli Suite if you have such ESC’s.


(David Rechler) #16

your initial reply on this thread was the below. out of which I found only FLTMODE_CH.
(in the meantime I tested the motors, seems like one of the ESC’s I bought is dead. other 3 are working. bought “Readytosky Simonk 30A” from Ali Express)

  • THR_FAILSAFE=0 to disable the RC failsafe
  • STICK_MIXING=0 to disable RC stick mixing in AUTO mode.
  • FLTMODE_CH=0 to disable flight mode change by RC channel
  • INITIAL_MODE=N where N is mode number you want to start in
    You will be able to fly in the following modes:
  • AUTO
  • GUIDED
  • LOITER
  • RTL

(Dave) #17

3 out 4 good from a lot of those poor quality ESC’s is about par for the course I would say. And forget what I said about changing motor direction in firmware with those oldies. Rather than replace the one bad one buy 4 new good quality ones that support BLHeli.

Some parameters names have been superseded (THR_FAILSAFE is FS_THR_ENABLE) Stick Mixing and Initial Mode are for Plane.


(David Rechler) #18

Thanks,

Kind of disappointing though… it’s my first build and I was hoping I chose my components well as I want it to become an autonomous quad not a toy.

As it goes with Ali Express I already lost a month (+) waiting for the parts to arrive and just assembled the quad yesterday (including soldering the ESC’s power lines to a PDB in a way that replacing them will force me to disassemble a lot of stuff, before reaching first operation )-:

Having released some steam … which ESC’s are recommended these days?

Thanks

David


(David Rechler) #19

Actually… tried connecting the “dead” motor+esc to a receiver and an RC, works perfectly. Now it became interesting. Connected it again to the pixhawk, run motor test again and… it IS working but starting at 50%. Calibration issue? all other 3 are working at any %.
Calibration was performed via MP.


(Dave) #20

Could be a calibration issue but I wouldn’t use those ESC’s on any craft and one you expect to build for autonomous flight, no way. Hobbywing make good quality ESC’s.