Compass unhealthy, Help needed for a rookie!

Dear all,
After eventually getting my APM 2.5 set up, I had a lot of problems to get passed the pre arm checks due the the compass health check failing.
eventually after many attempts of calibrations it passed and I was airborne.

I am a beginner so go easy on me :slight_smile:

Now after 3 or 4 flights and a few low impact crashes, The drone would not rearm.
Im getting compass not healthy.

Trouble shooting so far:
compass calibrated a few times…My message then changes from compass not healthy to check mag field and evenly returns to compass not healthy.

Calibrating location changed a few times…no difference.

Changed data cables.

Changed computers( Im using mac)

I have been into the parameters and disabled the compass however this doesn’t seem to the disable the pre arm compass check?

This configuration has an external GPS antenna with a built in compass.

I read on this site about cutting the trace, however if I was able to Arm and fly a few times already, could this really be my issue?

Perhaps there is a real problem with the compass?

Any help greatly appreciated.

Sorry… Typo.
My board is an APM 2.8 not 2.5.

If one was to replace this FC what would you replace it with? It seems that this issue with the compass is inherent in every version of the the APM FC?

There must be a better solution?

Hi, APM 2.8 has an internal compass , that can be disabled by removing a jumper . Remove it ,select external compass , and do a calibration.

Thanks very much for your reply.
Could you show me the jumper that needs to be removed?
I have also been been looking at the options for selecting the external compass…

It would appear that the Mac platform for mission planner is a lot different from the Windows options?

Beat regards,


I used to pull my hair out with the compass. I also have a 2.8 but have since upgraded to a Pixhawk 2.4.8. Well, I finally came to the realization that the compass on my Ublox 6 gps was not working properly, and most of the cheap GPS’s with compasses just do not work very well. Then one day I bought a M8N gps from rtfq(30$), which has the compass built inside of the metal casing of the gps board. It works perfectly, and I have the onboard compass working with the external compass on the gps. I bought a second one for another vehicle, and same story, works perfectly. So now I have two vehicles with both the internal and external compasses enabled, and working. No variance errors, everything is good.

Hi Hiri and William,

Thanks so much for your kind help.

On closer inspection, There is no jumper on this 2.8.

I did find away in the parameter menu to turn all pre arm checks off. This allows me to arm the motors and hand fly the quad copter.

I think I will order the Pixhawk and M8N compass before i lose what hair I have left.

William Im glad you have found success with this combination however I can see others have had the very same compass issues with the Pixhawk?

Thanks again.


That board won’t have the jumper because it doesn’t have the onboard magnetometer !

Fantastic! and well picked up.

Really appreciate your help for a first timer…

So now this is indicating i have a fault with the external compass correct?

whats the deal with the different coloured boards? is this how you tell if you have a clone or an original?

Just a thought. Is your GPS unit on a mast?
Are u using USB or telemetry for compass calibration ? . magnets (speakers) in laptop could affect calibration.

Thanks again Hari for your help.

The compass is on a mast and I’m using USB to calibrate. I did manage to calibrate it once like this to get me flying in the initial stages, It was however after a couple of low impact roll overs that the motors would no longer arm as the compass unhealthy message could not be removed.

I have not yet even looked into telemetry.

Best regards,