Compass off by 100 degrees, Pitch and Roll Reversed, After Switching to Rover and Back

I have an mRo Pixhawk x21 with a Holybro Ublox GPS module.
It has worked great running copter on a DJI f450.

At some point I switched to ardurover 4.0 for a boat project, and have since been experiencing the following when connected to mission planner:

  • Compass is off by about roughly 100 degrees. i.e., when Pixhawk is pointed north, compass shows about 260. Compass and accelerometer were successfully calibrated multiple times

  • While board orientation is standard, the pitch and roll axes are reversed, meaning pitch motion causes roll and roll motion causes pitch. Yaw seems ok.

  • Getting ‘unhealthy ahrs’ warning. GPS lock is good.

I tried switching back to the latest copter release, reinstalling mission planner, resetting Pixhawk and reloading firmware multiple times, but problem persists.

You will need to fully re-calibrate after doing that

Can you please elaborate?
Compass and accelerometer were calibrated multiple times - is there anything else that needs to be calibrated?

Did you calibrated accelerometer and compass after installing the latest copter release?

Yes. Multiple times :slightly_smiling_face:

post a log, or it never happened :slight_smile: