Compass calibration issue with Copter 3.6.2


I’m trying to do a compass calibration with mRo compass using MP v 1.3.62. Every time after reaching 99% it goes back to 0. Tried over 10 times and fails to do a successful compass cal. I’m using Copter-3.6.2 with MP 1.3.62.

Any help is appreciated. Thank you.

I tried with different versions of MP and still could not do a successful compass cal.

Hi @arjun7965,
Are you using ChibiOs or NuttX version of Arducopter?

Nuttx version of Copter-3.6.2

I had a problem with compass in ChibiOs but never in NuttX. And because of that I also had problems with calibration.
If you’re not seeing the “Compass not healthy” message then that isn’t the case.

— UPDATE ----
Anyway you could connect to MP, select the Status tab and monitor compass values. They must not freeze.

1 Like

@sergbokh that’s not the case. Just having problem doing a successful compass calibration

have you tried relaxing the fitness of the compass calibration? its at the bottom of the onboard mag calibration screen. If you have done that the next option would be to move the compass away from whatever is interfering with it, easier said than done on some airframes.

@anon94298870 I did try with relaxed fitness and had the same issue. After spending a day on this figured it was the Compass offsets was higher than the default max offset set in ArduPilot which is 850. Tried to move the compass away from all the interference and that helped.