Coaxial Helicopter Tuning

Since this thread doesn’t belong in single/coax, I wanted to pull it over to the trad heli topics but I didn’t want to move the original poster’s discussion.

@Tarek-H has a coaxial helicopter flying and was looking for some tuning advice. The logs are in the referenced posting.

Looking at the log, The first thing to do is enable the harmonic notch. Initially you will set INS_HNTCH_ENABLE to 1. Then reload the parameters to see the options for the harmonic notch.
HNTCH_FREQ - rotor speed in Hz (I estimated yours to be 28 hz (1680RPM)?)
HNTCH_HMNCS: 11 (for two bladed rotor system)

As far as tuning, I think you should reduce the VFF gain for pitch and roll to 0.08. That should help reduce the overshoots.

Sorry that it has taken me so long to get back to you. I ran out of time this evening. I will try to look over it more this week.

Hello ,I will continue to test to improve performance, the harmonic notch is new to me, I think it is to improve the states estimates in the presence of vibrations !?
for the overshoot ,maybe it’s because the carbon protetion around the drone which adds inertia, I will test without and see
I send you some video of the tests with 4.1dev

Hello , i did some tests yesterday with ** 4.1.5** version and **harmonic notch enable **
there is improvement, it can be seen on the log with the PIDR.act and PIDP.atc variables
about the harmonic notch parameters i changed a bit from what you suggested

HNTCH_MODE: 0 static notch ,recommended for helicopter with external governor (even I have an rpm sensor )

HNTCH_REF: 1 (I didn’t quite understand this parameter, I tested it like that, but I’m thinking of setting it to 0 )

HNTCH_FREQ - 26 HZ ( rotor speed around 1600rpm)
HNTCH_HMNCS: 5( Three blade rotor system : 1sr and 3rd harmonic )

I share comparison captures with and without harmonic notch filter
there are some cuts for the graphs of PIDR.act and PIDP.act , I think it’s a bug in the log recording or the sd card, because I didn’t have this problem before and it appeared when I activated the FAST ATTITTUDE and FAST IMU for the log recording, I I will check this later

harmonic notch enabled

Well if you are using an esc with a built in governor then I would agree that your setup is fine.

I would recommend that you turn off FAST IMU and leave FAST ATTITUDE on. It will cut down on some of high rate logging.