Not sure where I should post this issue, but it is related to Arduplane, so I guess this is the right place.

I have now discovered 2 inconsistencies between NUTTX and CHIBIOS:

  1. Connecting both the Airspeed sensor and Lidar on I2C doesn’t work on NUTTX, but works on CHIBIOS

  2. Camera trigger set as relay on AUX-OUT 4 works on NUTTX, but not on CHIBIOS. (It works as PWM output though)

The last issue even makes Mission Planner return the message “Command failed to execute”.

It makes me a bit un-secure which operating system we should use. I need CHIBIOS to connect both Airspeedsenso and Lidar on I2C, I need NUTTX to make the camera trigger work on AUX4.

How to solve this problem? And when would be a good time to change from NUTTX to CHIBIOS?

Check your BRD_PWM_COUNT. It’s now enforced with Chibios.

Yes, thanks, that worked.

However, I find that highly confusing. Before, if you changed the function of a pin from PWM to Relay, it just worked. Like when you set the function for the Camera using Initial Setup -> Optional Hardware -> Camera Gimbal -> Shutter from Servo 12 to Relay.

I’m using APM, Pixhawk, Cube for almost 6 years now and it always used to work that way. Suddenly, it doesn’t work anymore. How is one supposed to know this without posting in this forum?

What I mean is, if something like this changes, there should be at least a warning to look at BRD_PWM_COUNT when changing the function of the AUX pins.

And, what other surprises are there changing form NUTTX to CHIBIOS???

Septentrio GPS does not get detected in ChibiOS and PWM rangefinder do not work.
Apart for those, ChibiOS is better :slight_smile:

Both of those should be working with the current stable releases with ChibiOS. When did you last test them?

I tested the septentrio last week with master. It required a pixhawk reeboot.
The PWM rangefinder I have not tested in a couple of months.