Check BRD_TYPE: Baro: unable to initialise driver

How to resolve this error “Check BRD_TYPE: Baro: unable to initialise driver”?

Need more information! What hardware? Share screenshot of messages tab on Mission planner!

I am using Pixracer board and I am using mission planner software. After firmware update, I connect the machine via Mavlink.

I can’t able to see the machine orientation in Head up Display and I got above error msg in this display.


Last time I saw that message it was a USB power issue. Try a new cable/USB port. And make sure you are not drawing a bunch of power via connected sensors etc.

That screenshot is showing ArduCopter version 3.5.4. The current version is 4.0.2. So I think you likely have incorrect firmware selected or downloaded. The correct firmware APJ file is here:

No Sir, I tried with Latest firmware version arducopter V4.0.2. Now also I am getting same error.

Did you flash it from the link provided by @Pedals2Paddles?

There was a batch of knock-off PixRacers that had bad baros in them.

I assume this is a knock-off?


Yes. I used this link .apj file

Baro sensor or Controller

There is FRAM_MOSI pin (Pin 54) in the controller STM32F427. There is no signal coming out from that pin.

Please give a solution sir

Purchase a new board that doesn’t have a defective baro?

Share a picture of board. It will give some idea.

This is my board. It was working well. I flied many time with this board. But suddenly this problem came to me.

That looks like one of those ultra-cheap clones that didn’t come with the ESP8266 header. Good time to replace it…

Did it come melted too? This is definitely an example of getting what you pay for sometimes.

Consider switching to a new board. Ardupilot now supports wide range of hardwares. Kakute F7, Matek F765, Omnibus F7 are some examples.