Catapult throttle up delay

I was testing auto-takeoff a couple days ago. For the most part everything worked great. There were a couple times though where the motor was considerably delayed starting up, resulting in a minor crash.

Upon reviewing the logs I can see that in some instances the throttle is not raised until well after the launch. In a successful launch the delay might be 0.8s, in a failed launch it might be 1.6s. In all cases: TKOFF_THR_MINACC=15, TKOFF_THR_DELAY=0, and TKOFF_THR_MINSPD=0.

Is there a way to allow the motor to run at some low power setting before takeoff? In my case there is no risk of the prop striking anything on the launcher

What might be the problem here?

I figured out the problem. Turns out the problem is that I was launching mid-mission. A short ways off the end of the launcher the AP would decide it was flying and ramp up the motor. By properly restarting the mission each time the problem has been solved.

Thanks for confirming the issue, as I need to try this son myself. Can you are your acceleration threshold settings to trigger the motor?


Is there something beyond my original post that you require?

Apologies, just seen that now (I was after TKOFF_THR_MINACC which I see you have set to 15)