Can't throttle up beyond arming

Hi all,
Just replaced my ESC’s from SimonK 30A to Hobbywing Xrotor 40A BLheli_32.
I will add (don’t know if it matters) that the SimonK had BEC and the HobbyWing doesn’t.

After the replacement, I can not take off… (or fly naturally…), In MP the “spin when Armed” is set to 0.2 and “spin minimum” to 0.3. (“spin maximum” was at 0.9).
I arm, motors spin, I increase throttle, motors increase a bit but then even if I increase all the way up, there is no increase of motor rpm.

I calibrated the new ESC’s (tried both at “normal” and “Dshot 1200”, no change)
I did have a telemetry low signal red line in pre-flight tab but even if I remove this line from the pre-flight check, no change (the signal was ~90%, why this is red I don’t understand… noted that this is controllable via parameters though).

Anyway, with or without MP, same. Arming, motors spin, increasing throttle - motors rpm goes slightly up and that’s it.

Your solution be highly appreciated, this pixhawlk is sooo frustrating! issue after issue, not had the pleasure of going up to the air, let alone fly and advance…

hi Dudi
are you can get full throttle in ESC calibariton ?
to test your ESC and your Pixhawk , remove your propellers and put your pixhawk in ESC calibration mode and increase throttle to maximum
if your motors spins at full throttle , your ESCs are ok and my advice to you is re-flashing your Pixhawk.
if your motors still not sniping at full throttle you should test your ESCs with another flight controller.

and look at this link you are not alone , It might be a problem between Arducopter and BLheli firmware (i guess not 100% sure)

I’m having the same problem.

Hi Hosein, thanks, your reply made me think about the calibration process, I went back to the MP, defined a BLHeli pass through, changed to Dshot150 and two things came up:

  1. I installed BLHeli suit, managed to connect but the suit shows all ESC’s have no data
  2. Suddenly seems like I can throttle up.

I will re-check with props installed and see if I can takeoff and fly.
Will update…

This is driving me crazy for months now… I’ve built my 1st quadcopter, X500 based, wanted to use it as a platform for some ideas. Anyway, current situation is that it has BlHeli_32 ESC’s, 3508 motors (700Kv), a Pixhawk 2.4.8. Motors were properly connected and are working, ESC’s calibrated, BlHeli suit data looks ok. Ranges for all motors are: Min 1010, center 1500, Max 1990. I’ve set BlHeli pass through on the mission planner. However… When arming motors start spinning, throttling up a bit and they respond, BUT any increase beyond the initial RPM increase (a bit above arming RPM) has no effect. Throttle remain constant. Any solution will be appreciated. I’m not getting to the point of takeoff… Thanks in advance !!!

Have you tried switching off " Low RPM power protect " in Blheli-32 suite.


BINGO!! Thanks a lot!!
I actually asked the guy who has like 12 long videos on youtube titled “BLHeli32 100% Explained” and his response was “sounds like a PixHawk issue”. I’ve been messing with parameters back and forth, now hopefully it is flight time ! (not crash time hopefully) :laughing:

Glad to hear that. Happy Flying.

1 Like