Can't get quad motors to arm

I’m building a quadplane using the Pixhawk lite. I’ve got the plane motor working. However, I can’t seem to get the quadplane ESCs to arm. I’ve using Gforce SimonK ESCs. I swapped out one of the ESCs for a non-simonK ESC to see if it would fire up. No luck. In the latest try, I’ve disabled any arming requirements. I’ve spent hours and hours of this with no luck. GPS and compasses are working. Tried to arm using MP. Got Mavlink rejected command. Any ideas? Thanks.

Mark

Are you out doors or inside

If inside make sure everything is deselected on the arming requirements page which I understand you have already done and make sure GeoFence is also turned off

See if that help

Are you getting any error messages in your ground station software

Paul

Thanks for the feedback. I’m inside in general. No fence or arming restrictions. Got messages up through APM initialized in the message tab. Manual works but any of the Q states don’t spin the motors (e.g., QHover).

Mark

The GPS is connected to 9 satellites. I’ve got throttle in plane mode. I switch to QHover mode which MP confirms. I looked at the dataflash log and it shows output on Channel 3 when in manual mode. When in Qhover it shows the output on channels 5, 6, 7 & 8 to be 982 which is no throttle. I’m stumped. Is there any variable that is needed or would prevent output on Channels 5 through 8. I believe I’ve followed the instructions in the quadplane section. Thanks.

Mark

I’ve confirmed the input on Channel 3 at all times and confirmed power to the forward plane motor in manual and acro mode. In the “Q” modes, I see input on channel 3 but no PWM values (other than the minimum) on channels 5 through 8. Anyone have any ideas on what conditions would cause copter motor output to be blocked? Are they any techniques I can use to further log and identify the failure condition? Thanks.

Mark

Mark thank you for posting this. I as well am struggling with the exact same issue. I’ve exhausted every option and can’t seem to find the solution. Have you had any luck?

are you connected to Mission Planner?
it will usually tell you why it will not arm

Thank you for your response. Mission planner is actually able to arm perfectly fine when I have the motor connected to RC channel 3 the motors beep and arm. Mission planner also allows me to arm perfectly fine. I make sure as well to set the flight mode to Qstabilize. However, when I connect my quad motors to channels 5-8, the motors only do the first initial beep but does not give the “initialized” beep. In mission planner (with Qstabilize set) I am able to Arm as well but motors are not spinning (since they are now coming out of channels 5-8). It’s like you are getting a pulse to initialize the motors only in channel 3.
I tried one more thing to ensure it is not my board: I initialized the motors in Channel 3 (it worked fine). I then changed the esc cables to channel 5-8 and it works. There seems to be a setting somewhere in the parameters that can set the quadmotor channels to initialize the esc as well (as channel 3 does).
I hope that made sense. Reading through the internet, it seems several people out there are having the same issue. Since APM Plane defaults to fixed wing mode, it only gives the channel 3 the ability to initialize the motors/esc.

Hopefully I won’t confuse things by mentioning this but… When you say ‘initialise the motors/esc’ are you referring to ‘calibrating the ESCs’? If so, ArduPlane with Quadplane support has a very nice way of calibrating all ESCs at once. The documentation is here.

thanks dazzab for your response. Yes, I am aware but since I cannot get a pulse/signal out of channels 5-8 I am not even ablet calibrate the ESC’s all at once. That is why I have to manually calibrate them manually.

To further add, I know for a fact that it is not a hardware issue. I previously tested the same hardware (esc, motors and flight board) with the quadcopter firmware. Everything was able to calibrate and initialize without a problem. Therefore, I imagine it has to be a setting somewhere in the parameters that I am missing.

Have you tried running the motor test in Mission Planner under ‘Optional Hardware’? The default motor speed for the test is 5% which you may have to increase depending on your motor size. But it’s a great way to see if the outputs are working.

Thank you for the response. Yes, I’ve tried running the motors test and no luck. Quad Motors not working in motor test

That’s very odd. Check that RC X _Function in the parameters map RC5-8 to the motors. That should have been done automatically when you selected quadplane option but it’s worth checking. Other than that, I’m out of ideas so hopefully you’ll get a response from one of the developers soon.

As well verified the rc functions. Ensured they were all mapped correctly. Thank you. I fear I may have to re-install the plane firmware again and see if that works.

Just SOLVED it! Because I am using the E-flight 60A brushless ESC’s, I needed to go into the Q_M_PWM_TYPE parameter and set it to 3 (Brushed16kHz). See link for reference: http://ardupilot.org/plane/docs/parameters.html
There are also additional types to choose from that matches your ESC’s (e.g. one-shot, etc)
Hope this helps anyone out there that may be having a similar issue.

Also, thanks everyone for your contribution and assistance during this frustrating moment.

Hi,

I have a similar problem. I’ve set up a quad plane according to the documentation, hooked up the motors and servos, GPS is locked, on top I disabled all disarming. The only modes in which the motors actually run is Manual and FBW A. As soon as I switch to Q_hover or Q_ Loiter, the motors stop. I have tried the various suggestions in this forum, to no avail.
I use Plane 3.9.7 on a Pixhawk V1. I work mostly with QGC, as it’s easier to carry my MACBook around with me.
There’s one more thing - when I connect the power module, I get a red main LED and it won’t go out. It does not change anything, I thought it might be worth mentioning. I ordered a new power module, and will continue testing, though I think that’s not my problem.
I am relatively new to this game so I may be overlooking something that might be obvious to experienced users. Can anybody help me out here please?

I forgot to mention that I am building a Tiltrotor Quadplane, so motors are supposed to run in forward flight. All motors run in FBW A and Manual, so TILTMASK Q_Frame etc seem to be set correctly.

Please somone help me here, My quadcopter motors are not arming, i might not be very much familiar with your hi-tech terminologies, I am a newbie in this. This is my first time building a drone so pls, come down to my level