Can't flash firmware onto Pixhawk 5X

Hello, as stated I am trying to flash V4.3.0 hexacopter firmware onto a Pixhawk 5X using Mission Planner, but every time I try it gives me a pop-up saying “Failed to discover board id. Please reconnect via usb and try again.” Of course I tried this, but it still isn’t working. I also tried installing firmware legacy but it gives me a “no response from board” error. I suspect the person before me flashed quad firmware onto it with QGround Control but I can’t be sure. Consequently I assumed that this 5X doesn’t have Ardupilot already installed, so following these instructions I tried putting it on myself, but got stuck when it said to “Hold down the board’s DFU button or temporarily bridge its “BOOT” pins, and plug in a USB cable (attached to your PC). Release button or unbridge once powered”, as the 5X doesn’t seem to have a “DFU button” or “BOOT pins”. As usual, any help is much appreciated. Thanks.

Try QGC to flash Ardupilot to the board. Or download the .apj file from here and use Mission Planners “load custom firmware” to flash it.
Pixhawk 5X

Forget about the process you linked to, it’s not for the Pixhawk boards.

1 Like

Sounds good, I’ll try that. Thanks.

Hi, I managed to flash Ardupilot using the load custom firmware feature in MP, but I had a quick question. Will this work with a hex drone? All the guides say choose your drone configuration and upload appropriate firmware from MP, but the .apj doesn’t seem to correspond to any one particular drone configuration.

As long as you’ve loaded ArduCOPTER then you’ll be fine. You set the final configuration when you are doing the initial setup of the drone.

1 Like