Can't connect PX4Pilot after flashing Chibios

I want to try Chibios on my plane but run into the same problem every time
I click upload V3.9.2 and when MP asks “Upload Chibios” I click yes, it flashes normally
After the musical tones my com port disappears and i cannot connect,
Rebooting the FC a couple times brings back my com port,
When i try to connect the window times out with “No Heartbeat Packets Received”
I have to reflash V3.9.2 to get it to connect again this time clicking no to “Upload Chibios”

My FC is a PX4Pilot from hobbyking (px4v2 presumably fmuV2?)
MP Version 1.3.59
Arduplane V3.9.2

Can anyone think why this is happening / how to fix this?

edit: tested Ardurover V3.4.2 and Arducopter V3.6.0 exact same problem

I have the same issue on px4v2 using 3.9.2 when I agree for Chibios in the MP, he firmware is updated without issues, the tones confirm it but after that MP cannot can not connect. The COM port is visible but the MP times out. Tested arducopter V3.6.0 and had the same issue.
Finally I did the update again but using APM Planned in Mac there is not Chibios prompt but it updated and worked after. The RTOS is nuttx

Under Windoze the com port number changes and a new driver is installed.
I started getting ‘driver install failed’ messages.
In the end (after a few more problems with an update to Mission Planner) I deleted Mission Planner and reinstalled from scratch using the ‘latest’ msg file.
Seems to running fine now.

So be aware that a new com port is created and a new driver is required when you go Chibios

I have been using MP in a virtualbox in Mac for a couple of years now without issues, I also have used it with Omnibus F4 PRO boards. On the px4v2 the USB and com port are refreshed and remains being the same, the os recognizes it but when I attempt to connect it is like the MP not getting response.

Tried on a different computer, updated to latest MP and flashed chibios plane v3.9.2.
After reboot a new com port appeared “stmicroelectronics virtual com port (COM14)”
It seems the problem is computer specific as it still doesn’t work on my first computer but at least i can run chibios now.
I’d still like to figure out why it won’t work on my laptop, I’ll let you know if i find a solution

FYI, in case anyone else can figure out whats happening:
PC that didn’t work: ASUS-G751JM Windows 10 Pro 64Bit
PC that DID work: PANASONIC-CF31 Windows 10 Pro 64Bit

I was able to make it work what happened is that I have multiple FCs and each one has its own USB signature in MAC, in VirtualBox I had to create a filter for each of them, what was confusing is that VirtualBox assigns the same name always so you’re under the impression that you already did it.

You can also try to installing/reinstalling ST Eletronics USB/Com port driver.

I seem to have a similar issue, ie after flashing V3.9.2 the USB driver name has changed and I cannot load the driver or get the port to work. The FC otherwise seems to boot up and play the tunes and flash the lights as normal.
My FC is a Pixhawk Mini, 3DR (px4v2)
MP Version 1.3.59 updated today
Arduplane V3.9.2 updated from V3.8.4 today

I have two of the Minis which were both working this morning. I decided to update but left the one as it was after this problem.

The USB driver used to be ‘Legacy FMU’ whereas now it is looking for a FMUV3. I think this may be the problem as I cannot find this driver, presuming it has changed. So I cannot communicate as it does not have a driver.

I note that for a long time the update failed until this morning it got through and stated successful. This seems to be the case but now lost USB. The second Mini is still fine and working on the Legacy FMU driver.

Any ideas on problem and fix.

Thanks, Rob

OK. I installed ST Electronics USB/Com port driver. It moved the port to 25 but now works.

I will check further before I update the other Pixhawk.


This appears to be a computer issue for not recognizing the “new” USB device. It’s always a different port (higher for me). My laptop recognizes both versions fine. I wonder if some meddling around in the device manager would solve any problems.

I recently installed the drivers from Arduino_STM32 for a different project and that seems to have fixed the issue for me, I now have a new com port appear after flashing chibios. So if the stm32 drivers mentioned above don’t work try the drivers from here:

I was having trouble, but decided to restart computer before changing the drivers. Surprisingly enough, when my Windows 10 machine came back up…there was a new Com port and MP connected.

I already had some STM32 drivers in place, but they did not find the port until after the restart.
Might be worth a try.